asa5505 passing the internet from PPOE

Unanswered Question
Dec 14th, 2009

Hi,

I am configuring a ASA5505 and as of now I only need a basic setup, which is to pass the internet connection from vlan 1 clients coming from vlan 2 (ppoe). My current dilemma is why the internet is not passing when I am in vlan 1 where when I connected directly to the internet I do have an internet connection. I have attached my code, please do comment where I made a mistake or what I am missing.

thanks in advance.

Regards,

Eduard

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sachinraja Tue, 12/22/2009 - 12:24

Hi eduard

If i understand right, are you configuring trunking to allow vlan 1 & Vlan 2 on the same interface of the ASA ? SInce you have so many interfaces on the ASA, why dont you configure your inside & outside on two different ports ? Also after connecting to PPPOE, do a show interface vlan 2, and see what is the ip address assigned ? we need to verify if the default gateway is good which is 5.5.5.5 ? are you doing nat on your pppoe device ?

Raj

vilaxmi Sun, 01/03/2010 - 13:29

Hello,

In order to gain internet access for you inside users (192.168.1.0/24) you need to REMOVE the following static route statement :

route outside 0 0 5.5.5.5

And ADD on your outside interface, the following command in order to get a default route automatically from your PPPOE device :

interface vlan 2

ip address ppoe setroute

All other config looks OK.

Once all connections are done, check the IP address and default route info which your ASA has received from the PPPOE device.

Make sure that device is not doing NAT, because if it is doing any NAT, then you will have to remove NAT/GLOBAL pair from you ASA.

HTH

Vijaya

Actions

This Discussion