Bandwidth profiles not working at all

Unanswered Question
Dec 15th, 2009
User Badges:

I just purchased a SA520w and it seems like bandwidth profiles don't work at all. I upgraded to the lastest firmware, and tried several different combinations (physical ports, vlans, protocols, etc) for bandwidth profiles none of them seemed to work.

Has anyone gotten bandwidth profiles to work on their SA hardware?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
William Childs Tue, 12/15/2009 - 04:17
User Badges:
  • Bronze, 100 points or more

I would liked to have replied with something useful, but you didn't include a debug, screenshot, etc. for me to look at. The best I can do at this point is recommend you consult page 87 of this manual, and try to start again fresh but with this as a guide.

This is the manual in pdf format. Please post more information as to how you have it configured if you are still having trouble.


l01010101 Tue, 12/15/2009 - 12:21
User Badges:


Sorry about the lack of details. Have you gotten bandwidth profiles to work on a cisco sa520w? I was initially wondering if the feature was completely broken or not. Anyway, I am running firmware 1.0.17, and in the bandwidth profiles section I tried various values for the minimum bw like 0, 100, or 5000. The max bw I always kept as 5000. Also note that the network pipe is 50mbit downstream, 10mbit upstream. In the traffic selectors section I tried various combinations of vlan, port, mac tied to any service. I also tried ssh with a vlan. All combinations resulted in the computer obtaining more than 5mbit of bandwidth. I tested this via sftp, ftp, and http connections. Attached are a few screenshots of my current configuration. Please advise.

William Childs Wed, 12/16/2009 - 03:51
User Badges:
  • Bronze, 100 points or more

I was able to set this up in our lab here. I followed the Admin guide verbatim, and everything worked the first time. Maybe you could post your config file and I can download it to my SA520W.

It looked as though you had yours setup properly, but still not able to make it work. Will you please describe the tests you are performing, and how you know it is not working.


jamccord Wed, 12/16/2009 - 05:50
User Badges:

Please be aware that firmware 1.0.39 is available.  Please follow the very specific upgrade instructions and upgrade your device.



l01010101 Wed, 12/16/2009 - 14:29
User Badges:

I upgraded my device to 1.0.39 and did some more testing... still can't get bandwidth profiles to work. Attached is my configuration. Please see if you can replicate my issue in your lab. I also changed the max bandwidth to 100, and during the single file download tests I easily get over 100.

For my network tests I download 10 megabyte dummy files from a ftp or http site. The http site I used was and

I have another question about the bandwidth profile. Is that max setting supposed to limit the total bandwidth available or is it saying per tcp connection that is the max bandwidth?

Another minor issue I've been having while testing this issue is that one can't change the bandwidth profile while it is in use. The error I get is 'Bandwidth profile edit failed as it is being used by traffic selector.' So I have to create another bandwidth profile, and then switch the traffic selector. Would be nice if I could do it on the fly.

l01010101 Wed, 12/16/2009 - 16:35
User Badges:

Found another potential issue/bug. I have three vlans configured. 1, 200, 400. I had vlan 200 configured for bandwidth profiles, and nothing setup on vlan 400. I had assumed that if one vlan wasn't set up /w a bandwidth profile, it would use what was available. Any device on vlan 400 was maxing out at 5mbit. My pipe is 50mbit. While I was using firmware 1.0.17, I was in the exact same configuration, and I was able to get max bandwidth on vlan 400. Also note that if I tried to put in a bandwidth profile for vlan 400 of 50000, I still want maxing out at 5mbit. Bandwidth profiles on my sa520w really isn't liking me. Please advise.

Steven Smith Thu, 12/17/2009 - 14:49
User Badges:
  • Gold, 750 points or more

I am reading the documentation on this, and it appears that bandwidth profiles are limiting the data that is transmitted, not received.  Can you try testing it this way?

I am looking into why you can't edit a profile with a selector attached.


This Discussion

Related Content