LMS3.2 RME4.3.1 Problem with Device Group Administration

Answered Question
Dec 15th, 2009

Hi all,

I want to create a RME User Defined Group with the following criteria:

# Automatic membership update

# Rule: "Device.System.Contact contains "CORE""

I have 24 devices in RME which fulfill this rule, all devices have "snmp-server contact CORE" in their running/startup config. I have checked this issue with a RME compliance report, and all devices matched the criteria "+ snmp-server contact CORE[#.*#]".

Unfortunately only 12 out of 24 devices are automatically put into the "Objects Matching Membership" list.

What could be wrong?

Thanks in advance for every hint.

Alfred Brunner

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 1 month ago

Yes, this is CSCtb16925.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 12/15/2009 - 10:32

Check the RME Inventory Detailed Device Report for these devices, and make sure the proper SNMP contact is visible there.  It could be that these devices have not been properly inventoried by RME.

alfred.brunner Tue, 12/15/2009 - 22:44

You are right. The Detailed Device Report shows that some of the devices were stored with a string different to "CORE*". I changed the SNMP contact and did a re-inventory. But this had no effect.

Is it possible that there is a relationship to the effect that some of the devices cannot be inventored ("No inventory collection of some 65xx devices" - Patch CSCtb16925 required)?

Regards

Alfred Brunner

Joe Clarke Tue, 12/15/2009 - 23:38

That is certainly possible, but you have not provided any errors as to why inventory collection is failing for these devices, so I cannot say for certain if this bug is the cause.  After performing an inventory collection for one of the failing devices, post the IC_Server.log.

alfred.brunner Wed, 12/16/2009 - 06:02

Meanwhile I have installed RME device upgrade packages from cisco.com, then I did a inventory collection on all devices and now the SNMP contact string on some machines has been updated in RME. Automatic group membership with criteria "Device.System.Contact contains "CORE"" also works.

The only open issue is the missing RME inventory on some devices, but this handles another thread (RME 4.3.1 - No inventory collection of some 65xx devices). So I will close this one and wait for our consultant to get the patch regarding CSCtb16925 from CCO. Unfortunately I can't contact CCO directly in Europe :-(

Thanks a lot for helping.

regards

fred

Actions

This Discussion