ASA 5505 behind DSL router

Unanswered Question
Dec 15th, 2009

Greetings to all,

I have a static IP, comcast DSL router, ASA behind the dsl router, trying to VPN through the internet using the Cisco VPN client. On the DSL router I have port forwarded UDP 500, UDP 50, UDP 4500, TCP/UDP 10,000 to the ASA but it is unresponsive. If I am on the local (outside VLAN) on the ASA I can connect OK to the inside VLAN using the client but not from the internet. Here is my config, any help is appreciated. Regards, Steve

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stevo2k2k Tue, 12/15/2009 - 15:01

I'm not so sure I can do that with this router, I'll have to check in the morning it's just an elcheapo dsl router they provide with the service with no more functionality than forwarding and triggering ports. Any workarounds you can think of? Thanks for responding

CB900f2003 Wed, 12/16/2009 - 08:34

Can you possibly setup the modem to do a PPPOE passthrough?  You would have to configure the ASA for PPPOE, but the ASA has the outside IP address, not the modem.  Also I've seen some modem's support a "DMZ" client.  It should push all outside traffic to this one IP.

Good luck.

nedian123 Wed, 12/16/2009 - 11:15

hi acomiskey,

I am facing the same problem but instead of DSL router I am having a router having static NAT for ASA's private IP, when i test it w/o NAT i.e. RA VPN to ASA private IP it works....

VPN Client-------Router-------ASA

I have checked that NAT on the router is happening properly...& NAT-T is enabled on the ASA....Any hints in this regard....

Regards,

Akhtar

CB900f2003 Wed, 12/16/2009 - 12:05

Nat-T only works when the client is behind a NAT not the ASA.  ASA needs an public IP address to function properly..

stevo2k2k Wed, 12/16/2009 - 12:29

Thanks for the insightful comments, I do believe the problem lies with the forwarding of the ESP protocol which I have been unable to do with any of these internet routers thus far. I have tried putting the ASA's IP in the DMZ to no avail, tried it on 2 different brands of internet routers. A colleage of mine stated something similar to Mr. Feagins, "the outside IP must be the public internet address, if you can't ping that interface from the internet you're not going to be able to VPN through". This is where I'm at so far, and thanks again. Cisco should make an ASA with a telephony interface for DSL

Steve

Parminder Sian Wed, 12/16/2009 - 22:57

Hey Steve,

Since start of this discussion I have been looking at word "forwarding" being used. What we need is a passthrough i.e open the required ports on this internet router rather then forward the request to ASA. Say for example if there was a PIX/ASA in fornt of your ASA following acl's would have done the trick:-

access-list acl-out permit esp any host
access-list acl-out permit udp any host eq isakmp
access-list acl-out permit udp any host eq 4500
access-g acl-out in int outside

So what you really need to do is find a way out to open these ports rather then forward them.

Hope this helps,

Regards,

Sian

Actions

This Discussion