×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CME 4.1 no Local Directory?

Unanswered Question
Dec 15th, 2009
User Badges:

I have a small lab to study for

CCNA Voice.  CME is on a 2610xm router, running IOS 12.4.(15)T11 and CME 4.1 CUCME.  I have currently have two phones on the system.  One 7960 and one 7940.  I have a basic setup right now which works just fine, but when studying the section on Local Directory, it states that the local directory is built automatically based on the names under the ephone-dns, which I have, but there isn't even an option on the phones to view the local directory.  I've checked the telephony services and local directory service is enabled.  All I have listed is when the directory button on the phone is pressed is missed calls, received calls, and placed calls.


Can anyone shed some light on why I don't have the local directory option under directories on the phone?


Thanks
Dan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Tue, 12/15/2009 - 14:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Phone FW up to date ?

daniel.vaughn Tue, 12/15/2009 - 16:50
User Badges:

I "assume" it is, I just down loaded it prior to building the CME box.  The load I'm using is

P00308000100.loads or the cmterm-7940-7960-sccp.8-0-1 file.

paolo bevilacqua Wed, 12/16/2009 - 01:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Please upgrade to 8.0.(10).

daniel.vaughn Wed, 12/16/2009 - 09:20
User Badges:

Upgraded to 8.0.(10) and no change.  I did reboot the router just to make sure the phones had a fresh start.

Jason Burns Wed, 12/16/2009 - 09:22
User Badges:
  • Silver, 250 points or more

The IP Phone builds the Corporate Directory link based on the contents of the HTTP "Directory URL" that comes over in the TFTP configuration file.


In CUCM you can modify this parameter in Enterprise Parameters.


The corporate directory feature on the phone is HTTP based. This may help shed some light on to how the CME works.


From the phone's perspective we parse the TFTP config file, pull the URL from it, resolve the name, and then connect.

daniel.vaughn Wed, 12/16/2009 - 09:50
User Badges:

ok, I think I'm following your logic, but how can I check to see if the phone is actually pulling the http information it needs?  Or is there a parameter on the router I need to check for http?  I do see "ip http server" in the running config, and since I didn't put that in, I assume that is a default setting.  Is this something the phone needs/uses?  Or should there be some kind of http configuration under telephony services?

paolo bevilacqua Wed, 12/16/2009 - 09:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

http comes after, before that, cme pushes the menu entry to the phone via sccp.

Send config.

daniel.vaughn Wed, 12/16/2009 - 10:06
User Badges:

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname routercme2610xm
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.4.1 192.168.4.9
!
ip dhcp pool VOICE_SCOPE
   network 192.168.4.0 255.255.255.0
   default-router 192.168.4.1
   option 150 ip 192.168.4.1
   dns-server 4.2.2.2
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
description Router Voice Vlan Interface
encapsulation dot1Q 10
ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0.50
description Router Data Vlan Interface
encapsulation dot1Q 50
ip address 192.168.2.3 255.255.255.0
!
interface Serial0/0
no ip address
shutdown
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
!
tftp-server flash:P00308001000.loads alias P00308001000.loads
tftp-server flash:P00308001000.bin alias P00308001000.bin
tftp-server flash:P00308001000.sbn alias P00308001000.sbn
tftp-server flash:P00308001000.sb2 alias P00308001000.sb2
!
control-plane
!
!
!
!
!
!
!
!
!
telephony-service
load 7960-7940 P00308001000
max-ephones 8
max-dn 16
ip source-address 192.168.4.1 port 2000
max-conferences 4 gain -6
transfer-system full-consult
directory entry 1 4001 name Dan Vaughn
directory entry 2 4002 name Mark Vaughn
!
!
ephone-dn  1
number 4001
name Dan Vaughn
!
!
ephone-dn  2
number 4002
name Mark Vaughn
!
!
ephone  1
mac-address 0030.94C2.D26B
button  1:1
!
!
!
ephone  2
mac-address 000D.BC04.868B
button  1:2
!
!
!
line con 0
password cisco
login
line aux 0
line vty 0 4
password cisco
login
!
!
end

Jason Burns Wed, 12/16/2009 - 10:29
User Badges:
  • Silver, 250 points or more

You can see if the phone has the proper entry for the Directory URL by going to the following:


Settings > 3 (Network Configuration) > 27 (Directories URL)


If this entry is correct, then try going to that address in a browser and see what gets returned.


If that entry is not correct then check the TFTP config file the phone downloads from CME.


from windows cli


tftp get SEP.cnf.xml


and look in that XML file for the directories URL entry.

daniel.vaughn Wed, 12/16/2009 - 11:02
User Badges:

As you can see from the config I posted, I have the following listed under tftp:


tftp-server flash:P00308001000.loads alias P00308001000.loads
tftp-server flash:P00308001000.bin alias P00308001000.bin
tftp-server flash:P00308001000.sbn alias P00308001000.sbn
tftp-server flash:P00308001000.sb2 alias P00308001000.sb2


These are the only files I am aware of that the phone needs.  Is there another file I'm missing?  Under "hostname" on the phone it list the file SEP and the MAC address.  Under directory URLs, there isn't anything listed.

paolo bevilacqua Wed, 12/16/2009 - 11:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

In fact you don't need the .bin file

I had a problem w/ 8.0(10) in which Hlog softkey was inffective, solved w/ 8.1(2), you can try the same.

Jason Burns Wed, 12/16/2009 - 11:28
User Badges:
  • Silver, 250 points or more

In the CME type


show telephony-service tftp


Find the .cnf.xml config file path and then type


more system:


That will show you exactly what the phone is going to go to for the directory.


In my system it was


http://:80/localdirectory


Does your cnf.xml TFTP config file have that local directory path?

daniel.vaughn Wed, 12/16/2009 - 11:54
User Badges:

routercme2610xm#sh telephony-service tftp
tftp-server system:/its/SEPDEFAULT.cnf
tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf
tftp-server system:/its/XMLDefault7960.cnf.xml alias SEP003094C2D26B.cnf.xml
tftp-server system:/its/XMLDefault7960.cnf.xml alias SEP000DBC04868B.cnf.xml


routercme2610xm#more system:/its/XMLDefault7960.cnf.xml

routercme2610xm#

I don't see any information at all......

paolo bevilacqua Wed, 12/16/2009 - 12:18
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Then IOS is buggy, try some other image.

daniel.vaughn Wed, 12/16/2009 - 19:40
User Badges:

Okay, dropped down one IOS version to 12.4(15)T10

, and also went from using the IPVoice version to the Enterprise version.


No change, still don't have the local directory.


Is there a known IOS version,CME, and Phone load that I could use to absolutely ensure it's not a code issue?

paolo bevilacqua Thu, 12/17/2009 - 07:26
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Problem is that having an old router, you're limited in IOS choices.

I'm sure I have it working on some 2600, will check on that.

I do not think is part of any certification question, anyway.

daniel.vaughn Thu, 12/17/2009 - 10:32
User Badges:

Thanks p.b!  If you can find the combo that works, let me know. I would like to see it work, but I'm going to press

on with my studies without this piece.  Even if there are questions, I think I should be able to answer based on my

studies of the subject.


Thanks Again!

daniel.vaughn Thu, 12/17/2009 - 10:33
User Badges:

Thanks Jason!  Appreciate the help, but unless you have other things I can try/check/

upgrade, I think i'm going to move past this issue.  It's just a lab, so no customer complaints...;)


Thanks Again!

amit_raaaj Thu, 04/24/2014 - 23:40
User Badges:

Hi Dan, 

As per the configuration you have not mentioned the type of the phone in ephone. 

ephone  1
mac-address 0030.94C2.D26B
button  1:1
!
ephone  2
mac-address 000D.BC04.868B
button  1:2

When you do not mention the type in the ephone, TFTP will provide  XMLDefault.cnf.xml file since TFTP server will not know the specific model and hence no specific file. When you mention the type TFTP server will provide specific file for example XMLDefault7941.cnf.xml. 

I tested this scenario in my lab and I before "type 7941" was mentioned TFTP provided  XMLDefault.cnf.xml and after I mentioned "type 7941" I could see TFTP providing XMLDefault7941.cnf.xml to the phone.

Here is the configuration:

ephone  113
 mac-address 0024.C4FD.5EF4
 username "Quinrom"
 type 7941
 button  1:113

Here is the output from the debug tftp events:

1. Before type 7941

206387: Apr 25 01:12:44 CST: %IPPHONE-6-UNREGISTER_NORMAL: ephone-113:SEP0024C4FD5EF4 Socket:31 DeviceType:Phone has unregistered normally.
206389: Apr 25 01:13:30 CST: TFTP: Looking for CTLSEP0024C4FD5EF4.tlv
206390: Apr 25 01:13:31 CST: TFTP: Looking for SEP0024C4FD5EF4.cnf.xml
206391: Apr 25 01:13:31 CST: TFTP: Looking for XMLDefault.cnf.xml
206392: Apr 25 01:13:32 CST: TFTP: Opened system:/its/vrf1/XMLDefault.cnf.xml, fd 9, size 2898 for process 295
206393: Apr 25 01:13:32 CST: TFTP: Finished system:/its/vrf1/XMLDefault.cnf.xml, time 00:00:00 for process 295
206394: Apr 25 01:13:35 CST: %IPPHONE-6-REG_ALARM: 22: Name=SEP0024C4FD5EF4 Load= SCCP41.8-4-2S Last=Reset-Reset
206395: Apr 25 01:13:35 CST: %IPPHONE-6-REGISTER: ephone-113:SEP0024C4FD5EF4 IP:10.238.151.52 Socket:31 DeviceType:Phone has registered.

 

2. After type 7941

206412: Apr 25 01:25:23 CST: %IPPHONE-6-UNREGISTER_NORMAL: ephone-113:SEP0024C4FD5EF4 Socket:31 DeviceType:Phone has unregistered normally.
206414: Apr 25 01:26:11 CST: TFTP: Looking for CTLSEP0024C4FD5EF4.tlv
206415: Apr 25 01:26:12 CST: TFTP: Looking for SEP0024C4FD5EF4.cnf.xml
206416: Apr 25 01:26:13 CST: TFTP: Opened system:/its/vrf1/XMLDefault7941.cnf.xml, fd 9, size 1243 for process 295
206417: Apr 25 01:26:13 CST: TFTP: Finished system:/its/vrf1/XMLDefault7941.cnf.xml, time 00:00:00 for process 295
206418: Apr 25 01:26:15 CST: TFTP: Looking for English_United_States/mk-sccp.jar
206419: Apr 25 01:26:16 CST: TFTP: Looking for United_States/g3-tones.xml
206420: Apr 25 01:26:16 CST: %IPPHONE-6-REG_ALARM: 22: Name=SEP0024C4FD5EF4 Load= SCCP41.8-4-2S Last=Reset-Reset
206421: Apr 25 01:26:17 CST: %IPPHONE-6-REGISTER: ephone-113:SEP0024C4FD5EF4 IP:10.238.151.52 Socket:31 DeviceType:Phone has registered.

 

So type command can be the resolution of your issue.

Let me know if this helps. 

Thanks,

Amit 

 

Actions

This Discussion