CUCM upgrade from 7.0(2) to 7.1(3)

Answered Question
Dec 15th, 2009

Do you need a to get a new Software Feature License if you are upgrading CUCM from 7.0(2) to 7.1(3)?

I would also like to say that I rarely have to post a question because I usually find the answers to my questions here.  Thanks to all that post and answer questions.


I have this problem too.
0 votes
Correct Answer by rob.huffman about 6 years 8 months ago

Hi Kristine and Mohammed,

Thanks for continuing your excellent follow-up in this thread +5 points

each for this kind gesture to help others here!

Just to summarize;

Kristine....your problem ended up being related to having too many

different License files being loaded? Is this related to a Bug or by design?

If this is a Bug could you please post this up for us. also referenced a Bug or Bugs you have discovered

in this process, can you please link them up as well.

Thanks again! Great work.


Correct Answer by rob.huffman about 6 years 10 months ago

Hi Kristine,

As far as Licensing goes,only an upgrade to a new "train" requires the Software Feature License. So for example;

CUCM 7.0(x) to 7.1(x) = No

CUCM 6.(x) to 7.0(x) = Yes

So in your case, you should be good to go

Hope this helps!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Correct Answer
rob.huffman Tue, 12/15/2009 - 13:14

Hi Kristine,

As far as Licensing goes,only an upgrade to a new "train" requires the Software Feature License. So for example;

CUCM 7.0(x) to 7.1(x) = No

CUCM 6.(x) to 7.0(x) = Yes

So in your case, you should be good to go

Hope this helps!


rob.huffman Tue, 12/15/2009 - 14:10

Hi Kristine,

You are most welcome my friend!

Good luck on your upgrade



KRISTINE OBrien Fri, 12/18/2009 - 18:09

Well all was going good until I got a licensing error.  I checked the license report and found that I no longer had any node licenses.  I opened a TAC and I am waiting to hear back from them but does anybody know how to fix this?  Do I need to get new license files?



rob.huffman Fri, 12/18/2009 - 18:45

Hi Kristine,

Sorry to hear this

Cisco Licensing is very,very good about re-homing these licenses when required. Just send an email to;

[email protected]

Something like this;

We recently upgraded our CUCM cluster and have somehow lost our Node licenses, they were tied to original PAK xxxxxxxxxxx. We have 1 Publisher Node and x Subscriber Nodes and now require the license to be homed to our Publisher MAC AAABBBCCCDDD accordingly.

Here is the pertinent info;

End User Name -

Legal Address


Purchase Order Number - 111111

Sales Order Number - 2222333

Bill to ID - xxxxx

Ship to ID - xxxxxxxxx

Thanks in advance for all your help with this! Can you please email the new license to:

[email protected]

Hope this helps!


KRISTINE OBrien Wed, 02/03/2010 - 11:26

I have not gotten this straightened out yet. I was going to open another TAC case to find out if I may be running into a bug having to do with too many license files. I found it the other day and forgot to save the bug id and couldn't find it again yesterday.

I was told that my licenses should be good from the licensing team. I'll post again after opening the TAC case.

KRISTINE OBrien Wed, 02/03/2010 - 11:29

No. I was issued a temporary license from TAC and its about to expire

so I need to get this figured out soon.

mnour401917_2 Thu, 02/04/2010 - 17:22

Hi all,

I am in exact the same situation right now.  I upgraded my CUCM version from 7.0. (2) to 7.1(3) and got the Node license error.

I contacted Cisco TAC yesterday and one of the Cisco TAC licensing team told me I have to order new License as upgraded CUCM 7.0 to 7.1 and need to contact my account manager , I was shocked as I did my homework before upgrading.

After arguing for 5 minutes I convinced him that I do not have to order and asked if I can get escalation to support team.

I received another e-mail from Cisco TAC this morning and I have to perform a work around to fix the issue, see below.

I will be trying this today.

I hope this helps,



Hi Mohammad,

Please run the following workaround:

1- restart the Cisco License Manager from the Control Center - Network Services.

If the restart didn't work, then we need to delete all the licenses and add them once again.

We can delete all the licenses by running the following commands:

Login to the CUCM through CLI

Run the following command:

File delete license */

Then upload all the license files, and then restart only the Cisco License Manager, this will solve the issue for sure. But we don't need to restart the whole server, we only need to restart the Cisco License Manager.

Please inform me with the results.


Thanks for the post.  I keep getting conflicting answers about the licensing.  When I contact the licensing team one person is telling me I don't need one but then another is processing my upgrade.

Did they give you a temp license or did you switch back to the other partition?

Please post an update after you do it so I can proceed with my upgrade.



mnour401917_2 Thu, 02/04/2010 - 18:01


I asked but I wasnt able to get a temp LIC. i havent switched back to prevous partition yet.

i was lucky this is a new install and it is not in production yet. it will be in production in 5 days and i need to resolve it ASAP.

I upgraded as i found a bug during my testing.



KRISTINE OBrien Thu, 02/04/2010 - 18:58

The response I got from TAC was to open a case with the licensing team

to consolidate the license files due to the bug.

The response I got from the licensing team was asking for the sales

order number. The system has been in place for 2 years. Which

sales order are they referring to?

I will call them in the morning and let you guys know what they say.

Sent from my aiPhone

On Feb 4, 2010, at 8:15 PM, "[email protected]"

mnour401917_2 Thu, 02/04/2010 - 23:24


I did what Cisco TAC recommended and NO joy, it is even worse now.

I deleted all the LIC files using the command "File delete license */".

Then when I try to add the LICs, I got an error saying the LIC file already exist.

Then i restarted Cisco License Manager and Cisco CUCM callmanager service.

After that I tried to add the LICs again and same problem I can't add it back. It says file already exist.

Then i rebooted the CUCM server and after the reboot attempted to add the LIC files again, same problem I cannot add the LIC files back.

So now I have no license on the server and I can't add any as well. Can anyone else help with this please.



KRISTINE OBrien Tue, 02/09/2010 - 13:47


I am at the point with TAC that they have told me to delete the license

files and then add new ones. The last post didn't sound like something

I want to go through with a production system. Were you able to

resolve? And if so how?



mnour401917_2 Tue, 02/09/2010 - 16:51

Hi Kristine,

I was NOT able to resolve it until now, TAC requested root access last week to remove them from the DB, even having root access to CUCM still NO success.

I am in the process of getting NEW license generated now. I suggest you have the LIC's in hand first before deleting any LIC files.

Hope this helps



KRISTINE OBrien Wed, 02/10/2010 - 07:57

Yesterday I was issued a license file that consolidated all my phone

license files into one. Last night I went through the license files and

deleted them one at a time and then added the node license and the

software feature license back. I had around 40 phone license files or

so and now I have 4 license files total.

KRISTINE OBrien Wed, 02/10/2010 - 08:11

Yes it's working now. I have 2 node licenses, 1 phone license and 1

upgrade license. The upgrade license is the feature license I was

referring to.

KRISTINE OBrien Wed, 02/10/2010 - 08:19

I don't think it's required. The issue that I was having was that I had

too many phone license files and needed to get the files consolidated

into one file.

mnour401917_2 Wed, 02/10/2010 - 17:12

Thanks for the update Kristine, glad to see yours is fixed and hopefully mine will follow as well. I think what Gate referring to is, will you need a NEW NODE license for upgrading from 7.(2) to 7.1(3). It looks to me like a New NODE License is required due to a bug or design issue for this particular upgrade.

For example I have a new system and I had my licenses for 7.0(2). When I upgraded to 7.1(3) the Node license could not be recognized. Removing and adding the licenses I had for 7.0.(2) doesn’t work.

So the only option I have now is to get a NEW NODE license for 7.1(3). Hopefully I will get it before the end of the week.


Mohammed Nour 

Correct Answer
rob.huffman Thu, 02/11/2010 - 06:40

Hi Kristine and Mohammed,

Thanks for continuing your excellent follow-up in this thread +5 points

each for this kind gesture to help others here!

Just to summarize;

Kristine....your problem ended up being related to having too many

different License files being loaded? Is this related to a Bug or by design?

If this is a Bug could you please post this up for us. also referenced a Bug or Bugs you have discovered

in this process, can you please link them up as well.

Thanks again! Great work.


KRISTINE OBrien Thu, 02/11/2010 - 07:32

Glad I could help.  Like I said early on I really appreciate all the people who post and answer questions on this forum.  I rarely have to post a question because I can find the answers here.

The bug that caught my attention is CSCtc43971.  I found it in another post.  I am not sure if I was hitting this bug but it does refer to having too many licenses and that got me to start asking questions.

Happy Posting,


rob.huffman Thu, 02/11/2010 - 07:40

Thanks Kristine!

Another wild and wonderful Bug for sure. Who would have thought

This is an excellent reference and something to keep in mind going forward.



mnour401917_2 Thu, 02/11/2010 - 17:43

Hi Rob,

The main issue I was having on the previous version 7.0(2) is related to DBreplication. For some reason replications and DB change notifications between PUB and SUB fails. I did a research and figured out it could be related the following bugs.



I was also having another issue where the core switch was crying about "duplex mismatch" between the CUCM interfaces and the switch ports. When I check the switch interface and CUCM eth0, they both show 1000/Full.

When I upgraded to 7.1(3) all the problems are now gone, but now I am stuck with new problem (NODE licensing).



Tommer Catlin Thu, 02/11/2010 - 07:52

When it was put in as 7.0, it did not require a server software license.  I think that was the bug.  The Node licenses always worked.   There was a two part process you had to get for CUCM after 7.1.   First is the Node license. (Publisher, Subscriber, etc).  Then there was the server software license.   In 7.0, it was not required (which I thing was the bug)  you could leave it running as is with node licenses.  But when you upgraded to 7.1, it flipped a trigger and found that the server software license was not loaded (in the bottom screen of the licensing summary screen).

In your SmartNet contract, you have to checkout the Node license and the server software licenses for this.  You can always email [email protected] to get a temp license while you get it all sorted out. (or escalate to TAC to get it)

Thought I'd post some feedback after running my uprade from 7.0.2 to 7.1.3.  Ran the upgrade no problems then had the dreaded license error warning my feature licenses were at a negative number.  So I had the upgrade licenses and applied them, still didn't work.  Opened a TAC case and what finally fixed it was deleting the upgrade feature licenses off that I had just applied and the original 7.0.2 feature license and then reapplying them, restart the licensing and CM service and it worked.  Seems like the licensing should be the easy part....


IAN HOLMES Sun, 03/14/2010 - 22:15

Restart of the Cisco License Manager service worked. Upgrade was from 7.0 to 7.1(3) DLU's and Node units showed negative values. Nice need to discuss with TAC or Licensing. Thanks for the guidance.

k6lw Tue, 04/06/2010 - 12:04

I am trying to upgrade from 3.3.3 to 7.1.3.

Purchased four brand new 7 appliances.

It's now been four days on the line with TAC and the blasted

license files are still buggered. Downloading and reinstalling

the files over and over is not correcting the problem. Any one know how to fix this

in reality?

Tommer Catlin Tue, 04/06/2010 - 12:10

So not sure what your problem is exactly.

License files from Cisco are generally a pain all the time.  And when you do an upgrade, I tell everyone you need at least a week to get all the licensing completed.  If not, ask for a temp license, then sort out the perm keys later after the install is done.

As for the upgrade software, If the DMA is not taking, you will probably need to send the TAR file to TAC and let them try in the lab.  3.3 is really tricky from what i heard and the DMAs are not very sucessful as 4.x is.   Sounds like if you have 7 appliances, its a large 3.3 enviroment and rebuilding from scratch is not an option.  However, rebuilding from scratch might be beneficial for you to start off with a clean cluster.

k6lw Tue, 04/06/2010 - 13:18

Problem is we upgraded the 3.3 to 4.2.3. Ran DMA onto the new appliance.
Followed prescribed licensing procedures and submitted the PAK file
numbers for the new license files along with the
unit license file. Up loaded the license files and rebooted the server
as instructed. License report shows the unit license, no node license and no software license.
Going to the license up load page shows all three files present.
Have downloaded replacement license files following TAC recommendations and still no joy.
Now are being told there is a bug and to remove all the files and then
just upload the node license to see if that works...

Insert sound of buzzer. Thanks for playing as that didn't work either.

I have four really nice "bricks" and no upgraded call manager.
This is not how to win friends and influence people. ;>

Tommer Catlin Tue, 04/06/2010 - 13:23

Someone must have told you it easy to get licensing.       Its not.   You basically have to know what to ask for exactly or close the ticket, re-open after 5pm pst time so you get Aust TAC.   You can also escalate it to a duty manager to get it resolved asap.

But basically, if 7.x loaded, you are ok.  Work on the Publisher and get it licensed first before you try to install the Subs.   Its been a couple months since my last upgrade, so maybe the process has changed, but typically, if you put in the complete order through PUT, an email is sent to you with your Entitlement number.  I would then go ahead and forward this email to [email protected]   Request a temp license for the DLUs you need, # of nodes and a server software key for 60 days.  Then you should be able to load up the subs, test it all out and deal with the id10ts later.    Licensing is a pain, it always has been unless you know someone internally to get it for you asap.   But typically, if you close the ticket, reopen another ticket you can sometimes get someone who knows what they are talking about.

Network Adminis... Wed, 05/19/2010 - 13:43

I had the same issue. I upgraded from 7.0.2 to 7.1.3 and when I switched versions I had a licensing error stating I had a temp license and it cut my unit licenses in half. Luckley I reverted back .I  Called TAC and was told I did not need  version license upgrade. But guess wha?t I did need a version license upgrade. I was on version 7.0.2 but found that the current license was for 6.0. I contacted Cisco licensing team and was asked for the SO#, what A nightmare this became. The licensing team was no help at all. It ended up being the original SO# for the CUCM that they wanted. it took me 6 weeks to get the license. Cisco Licensing team was a nightmare to deal with. After spending a great deal of money I would hope for better service.I even had the our Cisco sales team try to help me get he process moving faster they came back frustrated too.


Christian Chautems Tue, 08/03/2010 - 00:35

I hit this problem in a few occurences and did some research. This problem is docummented in the 7.1.3 Release Notes !!!

Node Licenses Missing After an Upgrade

If the node license file contains multiple features (for example: SW_FEATURE + CCM_NODE), after you upgrade to Cisco Unified Communications Manager 7.1(3), the following licensing warnings might display:

System is operating on insufficient licenses.

Please upload additional license files.

For additional details and workaround, see CSCtf15332.

The bug proposes 2 workarounds that I have used with success. On some cases the restart of the Licensing has fixed the problem
directly on other cases I had to apply toe workaround 1)




This Discussion

Related Content