Help configuring Frame-relay

Answered Question
Dec 16th, 2009

I have 3 2600 series routers and I have configured R1 as FR switch and have configured for static mapping for the remaining two routers. Listed below is the configuration file of all the routers, and I have run all frame-relay specific commands and everything indicates that it is working but I cannot ping R2 from R3 and vice versa.

R1 configuration

Current configuration : 1170 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R1

!

enable password xxxxx

!

ip subnet-zero

!

!

ip ftp username cisco

ip ftp password cisco

no ip domain-lookup

!

ip audit notify log

ip audit po max-events 100

frame-relay switching

!

!

!

interface Ethernet0/0

ip address 192.168.1.40 255.255.255.0

half-duplex

!

interface Ethernet0/0.1

!

interface TokenRing0/0

no ip address

shutdown

ring-speed 16

!

interface Serial1/0

no ip address

shutdown

no fair-queue

!

interface Serial1/1

no ip address

encapsulation frame-relay

clockrate 64000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 200 interface Serial1/2 100

!

interface Serial1/2

no ip address

encapsulation frame-relay

clockrate 64000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 100 interface Serial1/1 200

!

interface Serial1/3

no ip address

shutdown

!

router eigrp 1

network 192.168.1.0

network 192.168.10.0

no auto-summary

eigrp log-neighbor-changes

!

ip classless

ip http server

ip pim bidir-enable

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

R2 configuration

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R2

!

enable password xxxxx

!

ip subnet-zero

!

!

ip ftp username cisco

ip ftp password cisco

no ip domain-lookup

!

ip audit notify log

ip audit po max-events 100

!

!

!

interface Ethernet0/0

ip address 192.168.10.1 255.255.255.224

half-duplex

!

interface Serial0/0

ip address 192.168.10.66 255.255.255.252

encapsulation frame-relay

frame-relay map ip 192.168.10.70 100 broadcast

frame-relay lmi-type ansi

!

interface TokenRing0/0

no ip address

shutdown

ring-speed 16

!

router eigrp 1

network 192.168.10.0

no auto-summary

eigrp log-neighbor-changes

!

ip classless

ip http server

ip pim bidir-enable

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

end

R3 configuration

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R3

!

enable password xxxx

!

ip subnet-zero

!

!

ip ftp username xxxx

ip ftp password xxxx

no ip domain-lookup

!

ip audit notify log

ip audit po max-events 100

!

!

!

interface Ethernet0/0

ip address 192.168.10.33 255.255.255.224

half-duplex

!

interface Ethernet0/0.1

!

interface Serial0/0

ip address 192.168.10.70 255.255.255.252

encapsulation frame-relay

frame-relay map ip 192.168.10.66 200 broadcast

frame-relay lmi-type ansi

!

interface TokenRing0/0

no ip address

shutdown

ring-speed 16

!

router eigrp 1

network 192.168.10.0

no auto-summary

eigrp log-neighbor-changes

!

ip classless

ip http server

ip pim bidir-enable

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

end

Here's some of the output of the commands that I run to troubleshoot it.

R1 #sho frame-relay route

Input Intf      Input Dlci      Output Intf     Output Dlci     Status

Serial1/1       200             Serial1/2       100             active

Serial1/2       100             Serial1/1       200             active

R2 #show frame-relay map

Serial0/0 (up): ip 192.168.10.70 dlci 100(0x64,0x1840), static,

              broadcast,

              CISCO, status defined, active

R3 #sh frame-relay map

Serial0/0 (up): ip 192.168.10.66 dlci 200(0xC8,0x3080), static,

              broadcast,

              CISCO, status defined, active

R1 #sh frame-relay pvc

PVC Statistics for interface Serial1/1 (Frame Relay DCE)

              Active     Inactive      Deleted       Static

  Local          0            0            0            0

  Switched       1            0            0            0

  Unused         0            0            0            0

DLCI = 200, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial1/1

  input pkts 1177          output pkts 1185         in bytes 75328

  out bytes 75840          dropped pkts 0           in pkts dropped 0

  out pkts dropped 0                out bytes dropped 0

  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0

  out BECN pkts 0          in DE pkts 0             out DE pkts 0

  out bcast pkts 0         out bcast bytes 0

switched pkts 1176

  Detailed packet drop counters:

  no out intf 0            out intf down 0          no out PVC 0

  in PVC down 0            out PVC down 0           pkt too big 0

  shaping Q full 0         pkt above DE 0           policing drop 0

  pvc create time 20:46:09, last time pvc status changed 20:45:52

PVC Statistics for interface Serial1/2 (Frame Relay DCE)

              Active     Inactive      Deleted       Static

  Local          0            0            0            0

  Switched       1            0            0            0

  Unused         0            0            0            0

DLCI = 100, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial1/2

  input pkts 1186          output pkts 1176         in bytes 75904

  out bytes 75264          dropped pkts 0           in pkts dropped 0

  out pkts dropped 0                out bytes dropped 0

  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0

  out BECN pkts 0          in DE pkts 0             out DE pkts 0

  out bcast pkts 0         out bcast bytes 0

  switched pkts 1185

  Detailed packet drop counters:

  no out intf 0            out intf down 0          no out PVC 0

  in PVC down 0            out PVC down 0           pkt too big 0

  shaping Q full 0         pkt above DE 0           policing drop 0

  pvc create time 20:46:10, last time pvc status changed 20:45:50

From above everything should work but I cannot ping any host nor does show ip route shows any adjacent routers. Any help is greatly appreciated.

I have this problem too.
0 votes
Correct Answer by jgagznos about 6 years 11 months ago

Check your IP addressing.  R2 and R3 serial interfaces are on different subnets.  Fix that and see if you can get it to work!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
jgagznos Wed, 12/16/2009 - 16:54

Check your IP addressing.  R2 and R3 serial interfaces are on different subnets.  Fix that and see if you can get it to work!

osman97229 Wed, 12/16/2009 - 19:19

That fixed the problem. Thank you for the quick reply. I have been struggling this for awhile.

Actions

This Discussion