Quick question regarding HSRP

Answered Question
Dec 16th, 2009

Hi All,

I have two 2821s configured with the LAN interface in HSRP, tracking the WAN interface.

They are the same model with the same hardware & software and the output of the ''show standby all'' is that the primary is active and the secondary is standby. Seems to be working fine, but if I shut down the LAN interface, then the secondary won't become active.

My question is... the only difference between both routers is that one has an ATM working interface attached to an ADSL modem, and the other does not.

Could this be the cause of the problem? Is a requirement for HSRP to be exactly the same Hardware or do I need to look somewhere else?

Thank you All!

Federico.

Correct Answer by Jerry Ye about 7 years 2 months ago

The default decrement value is 10, when you lose your outside failed, it will not switch over because it is only decreasing 10 from 150, and the default priority on an interface is 100.

To get this to work, set your higher priority interface to 105 and try again.

You should also put the NAT on the other interface to get everything to work correctly.

Regards,

jerry

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lamav Wed, 12/16/2009 - 22:17

Hi:

Can you post the config of both routers and the output of a sh standby on both?

Thanks

Giuseppe Larosa Thu, 12/17/2009 - 02:27

Hello Federico,

you probably need

standby group# preempt

on both devices, by default HSRP does not provide the capability for active router switchover until current active router is alive.

with preemption enabled standby router claims the active role with a coup message and the other device resigns.

Hope to help

Giuseppe

lamav Thu, 12/17/2009 - 05:39

Giuseppe:

I think you may have misread his question...

In his test, the o/p is not failing the WAN interface that is being tracked, which would cause the priority of the activre router to drop lower than the standby router. In that case, the standby router would need preempt configured to send the coup message to the active router.

Instead, the o/p is telling us that he has failed the LAN interface itself. In that case, as you know, no hellos will be sent to the standby router, and after the configured holdtime, it will become the active router. Preemption in that case is not an issue.The standby router will become the active router once the holdtime expires, which by default is 3 times the hello time. Default timers are 3 and 10, respectively.

HTH

Victor

Giuseppe Larosa Thu, 12/17/2009 - 05:46

Hello Victor,

you are right, but I thought it could be a mistyping I don't see any other reason the standby router could stay standby because as you noted in 10

seconds it should take the role for the fact that HSRP hellos from active router are missing regardless of preempt settings.

So I thought that original poster "wan" interface could be a lan port connected to an ADSL  modem.

But of course I can be wrong.

Hope to help

Giuseppe

lamav Thu, 12/17/2009 - 06:41

Giuseppe:

I totally agree with you. The question would makse sense if the o/p had said that he failed the WAN interface. I was just sticking to what he actually wrote ....just in case.

By the way, I dont have vrrp capability on my 3550 at home....does vrrp act the same way, I wonder?? Do you need vrrp preempt enabled when you have the exact same scenario as the o/p describes regarding tracking?

[EDIT] I take it back...preemption is enabled by default on Cisco routers running vrrp and you cant disable it. {EDIT]

Giuseppe Larosa Thu, 12/17/2009 - 06:52

Hello Victor,

VRRP should have preemption enabled by default but there is another question related to the VRRP master, that is the VRRP VIP can be equal

to a device ip address in that case probably preemption does not apply.

see

If a VRRP router owns the IP address of the virtual router and the IP address of the physical interface, this router will function as a virtual router master.

http://www.cisco.com/en/US/partner/docs/ios/ipapp/configuration/guide/ipapp_vrrp_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1054602

so here the question is slightly different I remember some other thread about this.

Hope to help

Giuseppe

Federico Coto F... Thu, 12/17/2009 - 13:08

Hi,

Thank you all for your comments!...   the configuration is a standard one with the LAN interface on the primary unit with a higher priority and preempting and tracking the WAN interface (which is another Ethernet interface).....

What I really want to know is the following.... for HSRP to work is not a requisite to have both routers with exactly the same hardware (in this case, same amount of physical working interfaces)????

Thank you!!

Federico.

Jerry Ye Thu, 12/17/2009 - 13:14

You don't need identical hardwares to get HSRP to work. Please look at Giuseppe's comment, did you configured preempt for HSRP? Posting your HSRP config will help all of us to understand your problem.

Regards,

jerry

Federico Coto F... Thu, 12/17/2009 - 13:22

Hi!

interface FastEthernet0/0/0
ip address 192.168.100.6 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
standby 1 ip 192.168.100.5
standby 1 priority 150
standby 1 preempt
standby 1 track GigabitEthernet0/0.11

interface FastEthernet0/1/0
ip address 192.168.100.7 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.100.5
standby 1 preempt
standby 1 track GigabitEthernet0/0

The first one is the Primary LAN interface, the second one is the Secondary LAN interface configured for HSRP...
The GigabitEthernet has the public IP address, and a default gateway to the Internet....
HSRP is only configured on the LAN interfaces on both routers...
Now, I realize that the secondary router is not doing NAT on the LAN interface, but still, the secondary should become
active when I turn off the Fas 0/0/0 interface on the Primary Router, correct?


Thanks!

Federico.

Correct Answer
Jerry Ye Thu, 12/17/2009 - 13:29

The default decrement value is 10, when you lose your outside failed, it will not switch over because it is only decreasing 10 from 150, and the default priority on an interface is 100.

To get this to work, set your higher priority interface to 105 and try again.

You should also put the NAT on the other interface to get everything to work correctly.

Regards,

jerry

Actions

This Discussion