SRST Fallback - no ephone-dn assigned to extensions

Answered Question
Dec 17th, 2009
User Badges:

Hi there,


Hopefully someone can help me out, I´m running out of ideas here.


I´m pretty newbie to CCM, installed a CCM 7.1(3) with a H323 Gateway, running IOS 15.0(1)XA,. Right now I´m testing SRST with this gateway, but it doesn´t appear to work fine. When in Fallback mode, the phones show the "Fallback mode" on screen, but get no extension.

Upon SRST registration, ephone debugs, I found the following on the ephone debugs:

ephone-2[1/-1]:SkinnyVideoParmsUpdate: phone: 1, action: 2, dn_index: -1


I assume this "dn_index -1" isn´t normal at all. Here is what I get on sh ephone:

------------------------------------------------------------------------------

ephone-1[0] Mac:001E.F7C3.21BD TCP socket:[2] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 17/17 max_streams=5
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1 caps:11
IP:192.168.101.2 * 36015 7961  keepalive 38 max_line 34 available_line 0
Preferred Codec: g711ulaw
Lpcor Type: none


ephone-2[1] Mac:0024.9734.362A TCP socket:[1] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 17/17 max_streams=5
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1 caps:12
IP:192.168.101.4 * 28833 7911  keepalive 38 max_line 6 available_line 0 dual-line
Preferred Codec: g711ulaw

------------------------------------------------------------------------------


And here is my fallback config:


--------------------------------------------------------------------------------

2851-VG#sh call-manager-fallback
CONFIG (Version=8.0)
=====================
Version 8.0
For on-line documentation please see:
http://www.cisco.com/en/US/products/sw/voicesw/ps4625/tsd_products_support_series_home.html


ip source-address 192.168.0.162 port 2000
ip qos dscp:
ef (the MS 6 bits, 46, in ToS, 0xB8) for media
cs3 (the MS 6 bits, 24, in ToS, 0x60) for signal
af41 (the MS 6 bits, 34, in ToS, 0x88) for video
default (the MS 6 bits, 0, in ToS, 0x0) for serviceservice directed-pickup
max-ephones 15
max-dn 100
max-conferences 8 gain -6
dspfarm units 0
dspfarm transcode sessions 0
huntstop
no huntstop channel
huntstop channel 0
default-destination 202
cnf-file location: system:
cnf-file option: PER-PHONE-TYPE
network-locale[0] US   (This is the default network locale for this box)
network-locale[1] US
network-locale[2] US
network-locale[3] US
network-locale[4] US
user-locale[0] ES    (This is the default user locale for this box)
user-locale[1] US
user-locale[2] US
user-locale[3] US
user-locale[4] US
srst mode auto-provision is OFF
srst ephone template is 0
srst dn template is 0
srst dn line-mode single
time-format 24
date-format dd-mm-yy
timezone 23 W. Europe Standard/Daylight Time
call-forward busy 203
call-forward noan 203 timeout 10
call-forward pattern 0T
transfer-pattern 0T
alias 1 202 to 202 cfw 203 timeout 20
alias 2 203 to 203 cfw 202 timeout 20
alias 3 201 to 203 cfw 202 timeout 20
keepalive 30 auxiliary 30
timeout interdigit 3
timeout busy 5
timeout ringing 30
timeout transfer-recall 0
timeout ringin-callerid 8
timeout night-service-bell 12
caller-id name-only: enable
system message primary Modo SRST
system message secondary Modo SRST
Limit number of DNs per phone:
  12SP: 76
  7902: 76
  7905: 76
  7906: 76
  7910: 76
  7911: 76
  7912: 76
  7920: 76
  7921: 76
  7925: 76
  7931: 76
  7935: 76
  7936: 76
  7937: 76
  7940: 1
  7941: 76
  7941GE: 76
  7942: 76
  7945: 76
  7960: 1
  7961: 76
  7961GE: 76
  7962: 76
  7965: 76
  7970: 76
  7971: 76
  7975: 76
  7985: 76
  anl: 76
  ata: 76
  bri: 76
  CIPC: 76
  vgc-phone: 76
  IP-STE: 76
  6921: 76
  6941: 76
  6961: 76
Log (table parameters):
     max-size: 150
     retain-timer: 15
transfer-system full-consult
transfer-digit-collect new-call
local directory service: enabled.
Extension-assigner tag-type ephone-tag.

------------------------------------------------------------------------


I´ve tried several IOS 12.4T versions, but the problem stays the same. Also according to the compatibilit matrix with CUCM, I need to run at least SRST 7.2 or 8.0 to support CUCM 7.1(3).

Any ideas why the ephones show available_line=0?


Suggestions, questions or any kind of advice will be appreciated!


Thanks

Javi

Attachment: 
Correct Answer by keanej about 7 years 4 months ago

Guys,

Am I missing something here ?


A phone needs a tftp server to get its image and config file - usually this tftp server is its CCM. When a phone cant see the CCM it attempts to use its SRST.

Now it kick the process off , the handsets need to see the CCM at least once to work out their SRST reference and download a compatiable image.


So .. normally I test the handsets by connecting them fully, testing a few calls and then killing the link to CCM and they then failover to SRST.


I dont believe connecting the handsets to an SRST reference (h323 gateway) without them ever seeing the CCM will work, as they wont have a config file / new firware.

Correct Answer by j.faure about 7 years 4 months ago

HI


i've the same problem , quite same config except CUCM 7.1.2 and i've tried SRST 7.1 and 8.0 . I've tried also several IP phone 7960 and 7941 , no pb with IP phone 7960 it's working but impossible to have a line associated with IP phone type 7941/7961 etc...

Also i've tried with different Phone Firmware and for me the pb is coming from here .

With the default firmware of CUCM 7.1.2 which is 8-5-2 , i've the pb with firmware 8-4-1 NO PB

I've not seen any bug on Cisco ??


ephone-1[0] Mac:001A.A19A.0D8E TCP socket:[2] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 17/17 max_streams=5
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:10.16.101.23 * 19027 7971  keepalive 41 max_line 8 available_line 2
button 1: cw:1 ccw:(0)
  dn 1  number 9711005  CM Fallback CH1   IDLE
Preferred Codec: g711ulaw
Lpcor Type: none

ephone-2[1] Mac:0013.1A6E.CFFB TCP socket:[8] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 11/9 max_streams=0
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:10.16.101.19 * 52259 Telecaster 7960  keepalive 41 max_line 6 available_line 2
button 1: cw:1 ccw:(0)
  dn 2  number 81914002  CM Fallback CH1   IDLE
Preferred Codec: g711ulaw
Lpcor Type: none


ephone-4[3] Mac:0017.E065.AE02 TCP socket:[9] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 17/17 max_streams=5
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:10.16.101.20 * 21098 7941  keepalive 40 max_line 2 available_line 0
Preferred Codec: g711ulaw
Lpcor Type: none

RS16-XCODE#sh ephone phone-load
DeviceName        CurrentPhoneload       PreviousPhoneload      LastReset
=====================================================================
SEP001AA19A0D8E    SCCP70.8-4-1SR1S       SCCP70.8-4-1SR1S      TCP-timeout
SEP00131A6ECFFB   8.1(1.0)               8.1(1.0)               CM-ICMP-Unreach
SEP0017E065AE02    SCCP41.8-5-2S                                TCP-timeout

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
david-lima Thu, 12/17/2009 - 05:34
User Badges:
  • Bronze, 100 points or more

Hi friend, just two things:

1. Did you create the SRST referende in system->srst and include it in the device pool.

2. Make sure that you have the "ccm-manager fallback-mgcp" command in your router.

hth

David

infomicro Thu, 12/17/2009 - 05:46
User Badges:

Hi David,


Thanks for your reply.


1 - Yes, the phones get the SRST reference from the CCM, I can see the correct IP for SRST under the phone configuration

2 - Nope, didn´t configure ccm-manager at all. Do I need that even if it´s working as H323 gateway? I thought this was only when the gw is working with MGCP.


Thanks!

Javi

Correct Answer
j.faure Thu, 12/17/2009 - 09:12
User Badges:

HI


i've the same problem , quite same config except CUCM 7.1.2 and i've tried SRST 7.1 and 8.0 . I've tried also several IP phone 7960 and 7941 , no pb with IP phone 7960 it's working but impossible to have a line associated with IP phone type 7941/7961 etc...

Also i've tried with different Phone Firmware and for me the pb is coming from here .

With the default firmware of CUCM 7.1.2 which is 8-5-2 , i've the pb with firmware 8-4-1 NO PB

I've not seen any bug on Cisco ??


ephone-1[0] Mac:001A.A19A.0D8E TCP socket:[2] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 17/17 max_streams=5
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:10.16.101.23 * 19027 7971  keepalive 41 max_line 8 available_line 2
button 1: cw:1 ccw:(0)
  dn 1  number 9711005  CM Fallback CH1   IDLE
Preferred Codec: g711ulaw
Lpcor Type: none

ephone-2[1] Mac:0013.1A6E.CFFB TCP socket:[8] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 11/9 max_streams=0
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:10.16.101.19 * 52259 Telecaster 7960  keepalive 41 max_line 6 available_line 2
button 1: cw:1 ccw:(0)
  dn 2  number 81914002  CM Fallback CH1   IDLE
Preferred Codec: g711ulaw
Lpcor Type: none


ephone-4[3] Mac:0017.E065.AE02 TCP socket:[9] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 17/17 max_streams=5
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:10.16.101.20 * 21098 7941  keepalive 40 max_line 2 available_line 0
Preferred Codec: g711ulaw
Lpcor Type: none

RS16-XCODE#sh ephone phone-load
DeviceName        CurrentPhoneload       PreviousPhoneload      LastReset
=====================================================================
SEP001AA19A0D8E    SCCP70.8-4-1SR1S       SCCP70.8-4-1SR1S      TCP-timeout
SEP00131A6ECFFB   8.1(1.0)               8.1(1.0)               CM-ICMP-Unreach
SEP0017E065AE02    SCCP41.8-5-2S                                TCP-timeout

infomicro Thu, 12/17/2009 - 10:40
User Badges:

Hi!


Interesting! Didn´t think about changing the phone firmware. Indeed I´m using firmware 8.5.2 for the 7961 and 7911.

I´ll try with a newer/older firmware early next week and post the result.

Thanks for sharing your experience, it could shed some light on my confused brain :-)


Javi

infomicro Tue, 12/22/2009 - 08:13
User Badges:

Just an update: indeed the problem was on the phone firmware!


I´ve tested from 8.5.3 down to 8.4.1, only with 8.4.1 and 8.4.2 the phones got their extensions and SRST worked as it should! I ended up testing with SRST 7.1, where according to the specs, the supported firmware is indeed SCCPxx.8-4-1-23 - ie 8.4.2. Strange that newer firmware versions are not supported :-/

http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/requirements/guide/srs71spc.html

I miss the same document to be published for SRST 8.0!

Now I´ll have to sort out why the locale changed back to English when I downgraded to 8.4.2 :-)

Thanks for posting your thoughts guys!

Rick Morris Fri, 12/18/2009 - 08:44
User Badges:
  • Silver, 250 points or more

only issue the mgcp command if you are running mgcp.  if you are using h.323 then mgcp command will do nothing for you

Correct Answer
keanej Tue, 12/22/2009 - 08:26
User Badges:

Guys,

Am I missing something here ?


A phone needs a tftp server to get its image and config file - usually this tftp server is its CCM. When a phone cant see the CCM it attempts to use its SRST.

Now it kick the process off , the handsets need to see the CCM at least once to work out their SRST reference and download a compatiable image.


So .. normally I test the handsets by connecting them fully, testing a few calls and then killing the link to CCM and they then failover to SRST.


I dont believe connecting the handsets to an SRST reference (h323 gateway) without them ever seeing the CCM will work, as they wont have a config file / new firware.

infomicro Tue, 12/22/2009 - 08:47
User Badges:

All the testing was performed with an initial connection to CCM, otherwise we would not be able to test SRST like you said. Same config everywhere except the phone firmware, and magically the ephones get a DN only with certain specific firmware versions.

j.faure Wed, 12/23/2009 - 00:51
User Badges:

Ok same conclusion also it's clearly a bug , i've opened a case to the TAC.As the dafault firmware for CUCM 7.1.X is 8-5-1 i need to have a fix for all new deployment of CUCM 7.1.X

Thanks for info i'll keep you posted concerning the bug fix .

Just FYI to confirm the findings in this thread:



http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCte08121



SRST8.0:  7937 with sccp version 17 would not register to SRST.

Symptom:
IP phones running firmware that uses sccp  version 17 can not register to SRST/CME-SRST or will register but not  obtain any lines.

Conditions:
SRST router  running 15.0(1)XA.  This is the first image with sccp version 17 support  for SRST.

Workaround:
Download the IP phone firmware  to a version that does not use sccp version 17.
For 79x1/5/2 phones  and 7970s this is 8.4 firmware.
For 7937 phones get a load prior to  1.4(1).




hien


Tim Smith Thu, 04/28/2011 - 18:21
User Badges:
  • Silver, 250 points or more

Just an update on this one.. see my other post.

https://supportforums.cisco.com/thread/2079690


This IOS bug is fixed with XA2 and above.

However I was still having problems getting my CUCM 8.5(1) phones running 9.1.1sr1 firmware to register correctly via SRST.

So 9.1.1sr1 seems to have a bug with same symptoms as this IOS bug. (Phone registers, DN does not)


I dropped back to 9.0(3) and this works ok.

I upgraded to 9.2 firmware and this works ok too.


Still awaiting feedback on TAC. I'm hoping 9.2 release next month should include this fix.


Cheers,


Tim


Actions

This Discussion

Related Content