Topology Services Java issue

Unanswered Question
Dec 17th, 2009

Just upgraded from LMS3.1 to LMS3.2.  Having issue with java when launching Topology Services.  I have completely removed java and let it reinstall using the version that it required but still get the attached error message everytime I try to launch the app.  Topology services worked fine previously with LMS3.1 and the java I had installed.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (7 ratings)
Joe Clarke Thu, 12/17/2009 - 08:40

This was recently discussed on this forum.  The key is doing the installation of the plug-in as the local Administrator on the client.

Once the plug-in has been installed as Administrator, it should just work as any other account on the client.

David Niemann Fri, 12/18/2009 - 11:26

As local administrator or as an account with local administrative privileges? My account falls in the latter category.

David Niemann Fri, 12/18/2009 - 12:12

That does not appear to be my issue as I just completely removed all java versions, rebooted, logged in as local administrator and installed Java 1.6.11.  I still get the same error.  "jacorb-sing-1-3.jar, avalon-framework-4.1.5-sign-1-3.jar, logkit-1.2-sign-1-3.jar install successfully.  Please launch Campus Applications again to work properly.  Click OK to exit from the plugin."

I get this same error everytime.  Could it be a browser security setting? I run IE8 (same as I was running with LMS3.1 which did not have this issue).

Joe Clarke Fri, 12/18/2009 - 12:26

What are the contents of the endorsed subdirectory under (by default) C:\Progra~1\Java\jre6\lib?

Joe Clarke Fri, 12/18/2009 - 12:34

This is what I thought.  When you did the JPI installation as the local Administrator, did you download the NMSROOT/htdocs/plugin/jre-6u11-windows-i586-p_withjacorb.exe file from the server, then install it from the local EXE, or did you let the browser install it?

David Niemann Fri, 12/18/2009 - 12:43

I installed it from a locally saved copy when I logged in as administrator.

Joe Clarke Fri, 12/18/2009 - 12:57

Okay.  Try copying these three files from NMSROOT/campus/www/classpath on the server into that endorsed subdirectory.  Then restart your browser, and see if you can launch topology services.




mshatkus1 Wed, 03/24/2010 - 09:17

This did not work for me.  I am still getting the same message that it installed successfully and to restart the campus apps.  The 3 .jar files are in the 'endorsed' directory but still getting the same message

yjdabear Wed, 03/24/2010 - 09:31

Try it again, after first clearing the cache ("Temporary Internet Files") from the Java control panel.

mshatkus1 Wed, 03/24/2010 - 13:16

Ok, I got it working server side, but I still get the same message on the client side.

Martin Ermel Thu, 03/25/2010 - 02:35

which browser are you using?

what is the exact error you get on the client when you try to start Topology services?

Try to set the LMS Server as a trusted site. Do you get a pop-up with jnlp file?

mshatkus1 Thu, 03/25/2010 - 04:26

I have tried IE 7, and Firefox 3.0. I get the same message that this thread was started about

"jacorb-sing-1-3.jar, avalon-framework-4.1.5-sign-1-3.jar, logkit-1.2-sign-1-3.jar install successfully.  Please launch Campus Applications again to work properly.  Click OK to exit from the plugin."

Martin Ermel Thu, 03/25/2010 - 05:30

from the client, try to telnet to these ports on the LMS server: 42342 and 43242.

This must be possible for topology services to run. If it is not, then some kind of firewall or access list is blocking the connection.

Also when you are logged in to LMS try to chang the URL to the following:


if it does not auto-launch, you should at least be prompted to open "Topology_Services.jnlp" with "Java(TM) Web Start Launcher".

laptev.valery Mon, 08/09/2010 - 22:24

I have instaled java from LMS 3.2, but my ASDM 615 stoped working...

may be ther is a version of java, that suuported both whith LMS3.2 and ASDM???

Joe Clarke Fri, 08/13/2010 - 23:01

Not sure what ASDM supports, but LMS 3.2 supports JPI 1.6.0_11 or higher (of 1.6, that is).  So you can install up to 1.6.0_20, and that will work with LMS.

carltonjo Tue, 02/14/2012 - 12:45

Have there been any other fixes or workarounds for this issue?  I'm having the same exact problem on my client machine and have tried pretty much everything on this page.  We're using LMS 4.0.1.  We just installed it and I've been having loads of trouble with it.  I had trouble getting LMS to discover devices.  I got that figured out.  I'm still having trouble with the other modules seeing the devices but I'm still trying to figure that out on my own.  This is the main issue I have now and it started when my IT department gave me a new desktop with Win 7 on it.  I'm kinda figuring it's a client issue since it worked on my XP machine.  It's working on another machine that we have running Win 7 Ultimate but not on mine running Enterprise. 

Any help would be greatly appreciated.


benjaminlarochelle Tue, 03/13/2012 - 10:00

I'm experiencing the same issue as Mr. Carlton, except I'm still on LMS 4.0.  Topology Services worked great with XP and IE7 or 8 , but not with Win7 and IE9.  I'm currently using an XP vm as a work around to this issue, but it would be much nicer to have it work on my primary OS.  Please let me know if there are any settings I need to change in IE9 or if I need to use a differnt browser like Firefox.



Joe Clarke Tue, 03/13/2012 - 11:37

You need to use Firefox.  IE 9.0 is not supported in your version of LMS.

Michel Hegeraat Wed, 03/14/2012 - 00:57

You need to make the endorsed directory Writable for  "Users" on that machine.

C:\Program Files\Java\jre6\lib\endorsed

The problem is that you are not administrator and the java weblaucher wants to write into that directory.



benjaminlarochelle Thu, 03/15/2012 - 10:12


I went in and changed the permissions on this folder to allow "Users" full control and now it works!


I just realized that your 5th entry on this discussion would have worked for me too.

Thank you both for the help,



This Discussion