ACE "ssl url rewrite" not working

Unanswered Question
Dec 18th, 2009

Given this sample configuration and the info from and when I request the request is not rewritten.

I have A2 1.6a system image file.

action-list type modify http HTTP2HTTPS-REWRITE
ssl url rewrite location "test\.webserver\.com"

class-map match-any L4-SFARM-HB-IN-CHIARO
description VIP service WEB  SSL termination on ACE
2 match virtual-address tcp eq https

policy-map type loadbalance first-match L7-SFARM-HB-IN-CHIARO
description Policy to balance request to SFARM-HB
class class-default
   sticky-serverfarm STICKY-SFARM-HB-IN-CHIARO

policy-map multi-match L4_VIP3_POLICY
description Multi-Match VIPs on Vlan 13 to ServerFarms
   loadbalance vip inservice
   loadbalance policy L7-SFARM-HB-IN-CHIARO
   loadbalance vip icmp-reply active
   ssl-proxy server SSL_PROXY_SERVER

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rvavale Sun, 12/20/2009 - 19:29

Hi Giovanni,

With current config, if the Server sends a 302 Redirect Location header as "" then
ACE will rewrite this request and forward it to Client as HTTPS "".

Is this what you want to achieve with this config and its not working?

Please explain expected behaviour when giving request.



Gilles Dufour Mon, 12/21/2009 - 11:27

Get a sniffer trace to verify if there is really a redirect and what the location field looks like.

You can also try to set the url to ".*" so that we know it is not an issue with the url.



This Discussion