Skype Sip calls not passing digit to auto attendant

Answered Question
Dec 18th, 2009

Hi

I have a uc520 configured with Skype Sip trunk.

Incoming calls on the trunk are forwarded to the auto attendant.

The auto attendant answer and plays the message Press 1, 2, 3 etc.

However when the calller enters the digits the auto attendant keeps playing the recording.

Any suggestions?

John

I have this problem too.
0 votes
Correct Answer by Maulik Shah about 6 years 11 months ago

I think this issue is something we have seen in CCA when the access code for outbound calls is the same as the leading DID digit that we are looking to fix in a future CCA release. Options are:

1. Use a different access code which may not work for you (such as say 8)

2. Add below CLI and seeif this fixes your issue

dial-peer voice 1003 voip
dtmf-relay sip-notify rtp-nte

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Maulik Shah Sun, 12/20/2009 - 21:51

Need the config as well (link sent earlier has info on how to gather this) as I can see that the UC500 is not sending the RFC2833 event in the 200 OK to Skype which is not how CCA normally configures the UC500 for Skype for SIP

Snip of logs:

Inbound SIP INVITE from Skype:

024284: Dec 20 20:07:17.020: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:[email protected]:5060 SIP/2.0
...

m=audio 22438 RTP/AVP 18 8 0 101
a=rtpmap:8 PCMA/8000
a=rtpmap:18 G729/8000
a=rtpmap:101 telephone-event/8000
a=rtpmap:0 pcmu/8000
a=fmtp:18 annexb=no

Response from UC500 to INVITE is missing 101:

024622: Dec 20 20:07:17.160: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
......
m=audio 17974 RTP/AVP 0
c=IN IP4 86.40.234.229
a=rtpmap:0 PCMU/8000
a=ptime:20

Correct Answer
Maulik Shah Mon, 12/21/2009 - 14:43

I think this issue is something we have seen in CCA when the access code for outbound calls is the same as the leading DID digit that we are looking to fix in a future CCA release. Options are:

1. Use a different access code which may not work for you (such as say 8)

2. Add below CLI and seeif this fixes your issue

dial-peer voice 1003 voip
dtmf-relay sip-notify rtp-nte

johnroche_2 Tue, 12/22/2009 - 13:14

Changing the access code isnt really and option.

I added the cli and it worked perfectly.

Thanks very much

John

Maulik Shah Sat, 12/19/2009 - 15:42

Does DTMF only fail inbound or outbound as well? To diagnose this further would need below:
https://supportforums.cisco.com/docs/DOC-9830

I know Ted Trentler had this issue but turned out to be a Skype gateway issue - check his comment below:

Dimitris, Skype had a mis-configuration on some of their SIP Gateways.  They changed the config on all of the affected Gateways.

Actions

This Discussion