2811 Router Password on Compact Flash recovery

Unanswered Question
Dec 21st, 2009
User Badges:

Hi !


I have a problem with a 2811 Router. I am trying to do a password recovery but it fails.

All the configuration files are on a compact flash card. In Rommon mode, I cannot access the files on the card to delete them or anything.

I have tried to use the confreg 0x2402 something command and reset the router but it still boots from the compact flash card.

When in rommon mode, when listing the directory, all I can access is the flash: directory, Isn't there a nvram directory as well?

Should I be able to boot the router without the compact flash card`? because i cannot now.

Someone got any ideas? Do you need more info on how to solve it just let me know.


Thanks,

Linus

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Mon, 12/21/2009 - 15:37
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Eject the CF and allow the router to boot into ROMmon and enter the command "confreg 0x2142" and continue with the password recovery.

mseklemian Mon, 09/13/2010 - 20:42
User Badges:

I'm having the same problem - With a complication - I get garbage on the console/hyperterm.


I got to the ROMMON> prompt once;  entered "confreg 0x2142";  entered "reset"; eventually got:   "C"  and nothing else for a LONG TIME (10+ minutes);


I POR'd the router and now all I get is garbage...


any ideas?

mirober2 Tue, 09/14/2010 - 05:49
User Badges:
  • Cisco Employee,

Hi Mark,


Double check the serial settings in Hyperterminal--sometimes when you see garbage output like that, it indicates the serial port is not configured quite right. The correct settings are:


Speed: 9600

Data bits: 8

Stop bits: 1

Parity: None

Flow Control: None


You might also a try another serial cable to rule out any cable problems. Hope that helps.


-Mike

mseklemian Tue, 09/14/2010 - 07:38
User Badges:

Thanks Mike,


I have verified the hyperterm settings, even tried some other baud rates (in vane).


I had been using the same hyperterm and cable to check the switch settings (show running-config) and to update that config.  Then somehow I got locked out - too many attempts with the wrong pw.  there are so many in the lab - and I was doing too many things at once.


Unfortunately I do not have a second cable handy - but as I said this one worked earlier.


I will try rebooting the hyperterm machine (just in case).


Anyone have any other suggestions?


thx

Actions

This Discussion