SPA509G & BLF & Asterisk

Unanswered Question
Dec 21st, 2009
User Badges:


It's possible to configura a line key 1 with an extended function like

fnc=blf+sd+cp;[email protected];nme=Ext 200

in order to monitor the extension 200 without an attendant Console?

I did it on an spa942 and spa962 but i don't know if it's possible on a SPA5XX

Thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
cinglalls Mon, 12/21/2009 - 10:54
User Badges:

I try it, but the led is all the time orange.

My Configuration is:

Extension: Disabled

Share Call Appearance: Shared

Extended Function: fnc=blf+sd+cp;[email protected];nme=Ext 200

Short Name: 200

Server Type: Asterisk

The Call Pickup and BLF doesn't work Speed Dial Works fine

Can you help me?

Patrick Born Mon, 12/21/2009 - 15:12
User Badges:
  • Cisco Employee,

Hi cinglalls,

At asterisk's CLI, type: core show hints

This will tell you who is watching what

Verify that you've a hint in the extensions.conf file.


SPA509 has the following configuration to subscribe and monitor extension 508:

     fnc=blf+sd+cp;[email protected];nme=508

The extensions.conf has the following:

exten => 508,1,Dial(SIP/508,10,rT) ;ring for 10 seconds
exten => 508,hint,SIP/508 ; hint: core show hints *CLI sees extension state
exten => 508,2,VoiceMail([email protected],u)
exten => 508,3,hangup
exten => 9508,1,VoiceMailMain(508) ;mailbox access for extension

Make sure that the sip.conf allows your phone to subscribe to extension 200's state. Continuing my example, sip.conf snippet:

; allow phone to subscribe to another phone's extension state




cinglalls Mon, 01/04/2010 - 09:57
User Badges:


I put the other unused extensions to disabled and it works.

Thank's for your help.

adpslabcisco Thu, 03/04/2010 - 04:39
User Badges:


I have a SPA504G and I'm trying to configure BLF with Elastix 1.6.

I can make a speed dial but the ligth is off.

Ryan Finnie Thu, 08/12/2010 - 11:24
User Badges:

FYI, I had the same type of problem (getting the last 4 line keys to be BLF+SD on a SPA509G), and disabling the unused lines did not help.  It turned out the attendant console units were enabled in the config, but I did not have any SPA500S units attached.  Disabling the two consoles in the config made BLF on the line keys work again.


This Discussion

Related Content