CUCM 7 Route Filter doesn't OR

Unanswered Question
Dec 21st, 2009

Hi I am trying to configure a route filter to block all calls except calls to US, UK, Ireland and Australia (I am in New Zealand).

the clauses I want to use in the filter are:

country code == [^1]    and  internationall access exists

OR

country code == [^44]    and  internationall access exists

OR

country code == [^61]    and  internationall access exists

OR

country code == [^353]    and  internationall access exists

I beleive this should match any international call except those with the country codes above.

Then I am using the 1.@ with my route filter above to block this pattern.  I add a partition and apply it to the line CSS (I have a device CSS that passes all calls).

The problem I experience:

          if I put all four clauses in calls to the USA are blocked (001)

          if I take out UK (44) and leave in the other three countries including USA (1) it works fine, but I cannot get all four working together, is this a limit to the number of ORs we can use??

I am using CUCM 7.1(2)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shane.orr Tue, 12/22/2009 - 09:06

I think you may be going about this in a manner which will not work. Beause you are utilizing the "^" symbol which means it will matcfh other numbers execpt the number following the "^" things are not working as you expect. The problem is that it is going to make a match right away and not refer to any other clauses because of the use of "^" in conjuction with the "OR".

Example:

If you have the clauses listed in the order above and you try and dial 1 + international-access + (44 UK) + ...... the first clause (^1) would be matched because the country code does not equal 1 so then it automatically does not refer to any other clauses because there is already a match.

Here is what I would recommend

1. Create a seperate Blocked Partition and add that Partition to your Calling Search Spaces.

2. Modify or add a new Route Filter that looks identical to what you have except remove all of the "^" symbols.

3. Create or modify a Route Pattern and apply the Blocked Partition, the Route Filter, and select the Block Pattern option.

That should do the trick.

Please rate helpful posts

CLIFFORD BARTLE Tue, 12/22/2009 - 14:26

Hi, thanks for your reply, but it doesn't explain why it works fine for just the three, like this, any ideas:

country code == [^44]    and  internationall access exists

OR

country code == [^61]    and  internationall access exists

OR

country code == [^353]    and  internationall access exists

shane.orr Tue, 12/22/2009 - 14:35

Could you post the results of the Dialed Number Analyzer (DNA), I think that will help

understand things a little better.

Actions

This Discussion

Related Content