Wireless Client not associating with strongest AP

Unanswered Question
Dec 21st, 2009
User Badges:

AP = AIR-LAP1131G-E-K9 

WLC = WS-C3750G-24WS-S25



Total 6 floors building, 2AP on each floor.


Problem Statement:- Eg: Wireless Clients from ground floor are associating with AP on the 3rd floor.

This happens throughout the whole building.


I would expect that ground floor clients would be connected to ground floor AP.

Is there a way to force clients on specific floors to connect to their designated floor APs?


A thorough check indicate that, ground floor AP is not congested and only a few clients are connected to it.


please advise

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Mon, 12/21/2009 - 19:33
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Temporarily disable the radios of the 3rd floor AP and see if the clients associate to their respective AP.

J_Vansen_S Mon, 12/21/2009 - 19:45
User Badges:

Yes i have tried disabling the radio on 3rd floor.

My wireless clients associates back to ground floor AP, and some users to 2nd floor AP.


Arent clients suppose to connect to AP which is nearest & strongest signal to it?

Or is there any tuning of the WLC/AP that has to be done


Please advise

Leo Laohoo Mon, 12/21/2009 - 20:16
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

There are alot of reasons.  WLAN NIC card drivers and signal interference are common causes.

George Stefanick Mon, 12/21/2009 - 20:28
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, October 2015

What type of clients??


I would update the drivers and test other types of clients.

J_Vansen_S Tue, 12/22/2009 - 19:26
User Badges:

Is there a way to force clients to connect to specific AP?

Leo Laohoo Tue, 12/22/2009 - 20:09
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Sure.  The NICs can be specified to associate to the AP of your choice.

Mark Mattix Thu, 05/31/2012 - 09:26
User Badges:

I'm having a very similar issue in my network. Is it possible to force the NICs to associate with a specific AP's MAC because the other APs around are all broadcasting the same SSID.
Is there a feature in the WLC that can disassociate the client when the WLC knows there's better reception in the clients area, or forward it to the other AP?

Leo Laohoo Thu, 05/31/2012 - 15:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

I'm having a very similar issue in my network. Is it possible to force the NICs to associate with a specific AP's MAC because the other APs around are all broadcasting the same SSID.

Depends on the client wireless NIC drivers.  But unless you have a very, very old firmware this "feature" has long been abandoned by wireless NIC codes.


Is there a feature in the WLC that can disassociate the client when the WLC knows there's better reception in the clients area, or forward it to the other AP?

No.  The wireless NIC card of the client always makes the final decision on which WAPs to associate.


You can, however, try different tricks:


1.  If you are using 802.11b/g radio, disable the low data rates such as 1, 2, 5.5, 6, 9 and 11.  Make 12 as Mandatory and the rest supported.


2.  Check the firmware of the wireless NIC and see if you can upgrade it. 

David Santos Thu, 05/31/2012 - 14:09
User Badges:

Vansen


on the wlc please do debug client to see what is happening. Is the TPC algorithm performing right?


DS

mstrz@weston Fri, 06/01/2012 - 17:48
User Badges:

It's also possible you have the antenna power set too high on the APs. You don't want clients hopping between APs on different floors. Check your power settings


Sent from Cisco Technical Support iPad App

fbarboza Sat, 06/02/2012 - 10:18
User Badges:
  • Bronze, 100 points or more

Hi,


Remmber that AP selection or roaming is a client based decisicon and not a WLC or AP option.

On the access points or WLC there is no configuration that we can set for the client to conenct to an specific AP.

All wireless clients have there own algorithm to go to select the best AP to connect to and this algorithm usualy checks, siganl to noise, RF interfirence, avialable bandwith, number of clients on the APs, etc.


The most we can do on the AP or WLC side is make sure you have deployed the access points correctly on the site so that the coverage area between each access point is not more than 15%, make sure that you have used the 3 nonoverlapping channels between the units on the 2.4ghz radio.


Eventhough the WLC has auto RRM, for auto RRM to properly work and asigne the correct channels to each access point, the correct power level we need to have more than 3 access points and that each access point can see the siganl of the other access point and that they are not to close becasue auto RRM will fail and also if they are very far apart auto RRM will not work.

Actions

This Discussion