AP does not associate after software downgrade

Unanswered Question
Dec 22nd, 2009


I recently downgraded our WLCs software from to but after that access point is not associated. I have searched some similar issues here but I cannot get the resolution. It seems that the flash of the AP is full and unfortunately I am not able to delete some files as recommended by others.

AP# sh flash:

Directory of flash:/

%Error oepning flash:/  (Invalid argument)

No space information available

-----got this error from show logging----

capwap_image_proc: encounter flash problem, retry here

----cannot issue delete command to remove some files----

AP# delete?

% Unrecognized command

When I try to issue the "sh ver" to check the LWAPP image version, it is still showing version and IOS 12.4(21a)JA2 since the AP join was not successful.

Any help would be appreciated.

Br, Anthony

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Stephen Rodriguez Tue, 12/22/2009 - 06:20

The way the AP are managed, it should still be able to download the code, the flash is 32M, and the images are only around 8M, so it should be able to hold two images.  and we do purge the old images

from the console of the AP

debug capwap con cli  <---this will give you access to the commands

dir <--show contents of flash, alternately dir flash:

be very careful of what you remove from the flash memory, if you remove all the images, the AP may not boot further.

You should also gather debugs from the CLI of the controller

debug mac add < ap mac address >

debug capwap event enable

debug capwap error enable

debug pm pki enable

     hopefully there will be some message as to what is happening when the AP tries to join, and why it is not downloading code.

avrquintero Tue, 12/22/2009 - 21:05

Thanks Steve. Just ignore this post as my AP has now successfully registered to the controller after I disconnect it to the network and reconnecting for a while. I've got no idea what was the real issue and I'm glad now it's back online. Thanks again.

Br, Anthony


This Discussion