CUCM7+CUC7 and missed calls

Unanswered Question
Dec 22nd, 2009
User Badges:
  • Bronze, 100 points or more

Hi friends, I have a CUCM7, CUC7 with VoiceMail and AutoAttendant. When a user check the PSTN incoming missed calls on the IP Phone, it only shows the CTI number configured for the AA.

I want that the IP Phone show the "real" missed call and not the CTI number, so,

If you have any suggestion, please let me knows to resolve this incovenient.

Thanks a lot

David

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Justin Brenton Wed, 12/23/2009 - 10:15
User Badges:
  • Silver, 250 points or more

Hi there,


You will want to configure forwarded call information display on the CTI Route Point to Redirected Number.



Forwarded Call Information Display

Caller Name

Checking this check box will cause the caller name to display upon call forward.

Redirected Number

Checking this check box will cause the number that was redirected to display upon call forward.

Caller Number

Checking this check box will cause the caller number to display upon call forward.

Dialed Number

Checking this check box will cause the original dialed number to display upon call forward.



HTH, Please vote if this helps.


Thanks,

Justin

david-lima Tue, 04/06/2010 - 06:43
User Badges:
  • Bronze, 100 points or more

Hi Justin, thanks for your mail and sorry for the late response. I tried your suggestion but it is not working yet. I noticed that the missed number that shows the VoiceMail Port instead of the real calling party number only appears in the IP Phone 7941/61. I upgrade the firmware to 8.5 but no results.

If I'm missing something please let me known.

Thanks again

David

david-lima Mon, 04/26/2010 - 06:31
User Badges:
  • Bronze, 100 points or more

Hi all, I upgrade the IP Phone 7941/7961 to the latest firmware but with no results. The missed calls only shows me the VoiceMail port number. Does any one has a similar issue or a suggestion. It only happens with this IP Phone model, all the other models (7940/7960) are working fine.

Thanks a lot forum

David

MARK BAKER Wed, 12/15/2010 - 19:49
User Badges:
  • Bronze, 100 points or more

David,


I have been fighting this same issue on call forwards from UCCX scripts as well. I was considering moving the AA in question to CUC in hopes that it would work differently. From your post, I see that it doesn't.


I am currious from your last post. Are you saying that 7940/60 phones are showing the callers caller-id and not the CTI port number? If this is the case, then Cisco has gone backward with the 7941/61 phones. I assumed it would be the same on all phone models. I need to test this on our newer 7962 phones to see if it works on them.


Thanks,
Mark

Rob Huffman Thu, 12/16/2010 - 05:24
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Mark,


Have you tried playing with this setting?


CallManager System Parameter:


Clusterwide Parameters (Device - Phone)


Display Original Calling Number on Transfer from Cisco Unity = True


When we changed this parameter from the default = False to True the proper

clid is shown on transfers from UC 7.1 AA to the following tested models;


7940/7960

7941/7961

7942/7962

7945/7965


Cheers!

Rob

MARK BAKER Thu, 12/16/2010 - 10:46
User Badges:
  • Bronze, 100 points or more

Rob,


Thanks for the reply. Since the functionality of calls tranfered from Unity Connection to phones can be changed with a service parameter, wouldn't it sound feasible that the same thing could be done for UCCX call transfers? I sent a feature request to my Cisco rep about this. I started a new thread on this for the UCCX issue and posted all of the messages I had sent to my Cisco rep in hopes that a Cisco developer can shed some light on this with UCCX.


Thanks,
Mark

david-lima Thu, 12/16/2010 - 11:18
User Badges:
  • Bronze, 100 points or more

Hi Mark, I change the service parameters value as Rob suggest but the result was the same only for the ip phones 7941/61. I was working with CUCM 7.0 and CUC 7.0, but, as Rob mentioned, may be with version CUCM 7.1 / CUC 7.1 there is no problem.

I will try with this version and I'll let you know asap.

hth

David

srsivara Thu, 12/16/2010 - 13:17
User Badges:
  • Cisco Employee,

Have you tried setting "Display CTI Route Point Name or DN" service parameter to "False" ?


- Sriram

MARK BAKER Thu, 12/16/2010 - 13:39
User Badges:
  • Bronze, 100 points or more

Sriram,


Disply CTI Route Point Name or Number is for redirected calls and not transferred calls.


Thanks,

Mark

Actions

This Discussion