Cisco 4948 Local Login Issue

Answered Question
Dec 22nd, 2009
User Badges:

This is a simple configuration that I don't quite know why it's doing it. Created local users and enabled ssh but the local login password does not

bypass the enable password.  I know ssh works fine because I can authenticate, except it won't go  into priv mode after I put in the password.


Cisco 4948-10GE v 12.2(50)SG


username user priv 15 password password


lin vty 0 4

login local

transport input ssh


Is there something with this code ?

Correct Answer by sachinraja about 7 years 7 months ago

hi


can you paste the aaa configurations on this switch ? Is the authentication pointing to local database ?


aaa authentication login default local


aaa authorization exec default local


Can you let us know ?


Raj

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
sachinraja Tue, 12/22/2009 - 15:46
User Badges:
  • Red, 2250 points or more

hi


can you paste the aaa configurations on this switch ? Is the authentication pointing to local database ?


aaa authentication login default local


aaa authorization exec default local


Can you let us know ?


Raj

xayavongp Tue, 12/22/2009 - 15:51
User Badges:

I was considering this but this is a requirement on these IOS ?

I did not have to do it for other switches (cisoc 3130s).

sachinraja Tue, 12/22/2009 - 16:08
User Badges:
  • Red, 2250 points or more

Hi


Did you try login local under line vty ?? it forces all logins to refer to local authentication, instead of configuring the AAA.. configuring AAA gives you more flexibility though...


Raj

sachinraja Tue, 12/22/2009 - 16:09
User Badges:
  • Red, 2250 points or more

ooops.. missed the configs posted on your original post.. my bad..

xayavongp Tue, 12/22/2009 - 16:21
User Badges:

Thanks for your answer.  That was the problem. I guess in these newer IOS you have to enable aaa and configure it to

point to the local database ?


Anyway thanks for your help.

Actions

This Discussion

Related Content