Problem in uploading image into the web-authentication page

Unanswered Question

Hi All,
Lately i tried to create a customized web-authentication page that will re-direct any user to the web-page once they are connected to the network.

The problem is, i just cant attach/upload the image of the logo into the customized web-page (welcome/login page).
Been researching about it, found and tried some clue bout it on cisco documentation, but still can't solve the problem. Anyone face this problem before? Thanks in advance.

Cisco document :
Catalyst 3750 Switch Software Configuration Guide
Cisco IOS Release 12.2(52)SE
September 2009

switch version :
WS-C3750-48TS

show flash :
2 -rwx 12305677 Mar 1 1993 01:27:03 +00:00 c3750-ipservicesk9-mz.122-52.SE.bin
3 -rwx 131 Mar 1 1993 00:17:25 +00:00 log.text
5 -rwx 3254 Mar 1 1993 00:01:01 +00:00 config.old
8 -rwx 113 Mar 1 1993 03:24:33 +00:00 pass.htm
9 -rwx 1088 Mar 1 1993 03:39:18 +00:00 login.htm
10 -rwx 113 Mar 1 1993 03:21:30 +00:00 fail.htm
11 -rwx 104 Mar 1 1993 03:25:32 +00:00 expire.htm
12 -rwx 856 Mar 1 1993 00:05:19 +00:00 vlan.dat
14 -rwx 2479 Mar 1 1993 01:25:05 +00:00 web_auth_logo.jpg
16 -rwx 1048 Mar 1 1993 00:01:01 +00:00 multiple-fs
27 -rwx 1053 Mar 1 1993 02:18:34 +00:00 webauthpage.html
38 -rwx 6551 Mar 1 1993 01:19:33 +00:00 logotest.html

following is my running configuration :
Building configuration...

Current configuration : 4205 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
!
aaa new-model
!
!
aaa authentication login default group radius
aaa authentication login line-console none
aaa authentication dot1x default group radius
aaa authorization auth-proxy default group radius
!
!
!
aaa session-id common
switch 1 provision ws-c3750-48ts
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool USER
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
!
!
ip device tracking
ip auth-proxy proxy http login expired page file flash:expire.htm
ip auth-proxy proxy http login page file flash:logotest.html
ip auth-proxy proxy http success page file flashass.htm
ip auth-proxy proxy http failure page file flash:fail.htm
ip admission proxy http login expired page file flash:expire.htm
ip admission proxy http login page file flash:logotest.html
ip admission proxy http success page file flashass.htm
ip admission proxy http failure page file flash:fail.htm
ip admission name WEBAUTHRULE proxy http inactivity-time 60
!
!
!
dot1x system-auth-control
!
!
!
!
fallback profile WEBAUTHPROFILE
ip access-group USER in
ip admission WEBAUTHRULE
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet1/0/1
switchport access vlan 100
switchport mode access
spanning-tree portfast
!
interface FastEthernet1/0/2
!
interface FastEthernet1/0/3
!
interface FastEthernet1/0/45
!
interface FastEthernet1/0/46
!
interface FastEthernet1/0/47
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface FastEthernet1/0/48
switchport access vlan 200
switchport mode access
authentication host-mode multi-host
authentication order dot1x mab webauth
authentication port-control auto
authentication fallback WEBAUTHPROFILE
mab
dot1x pae authenticator
dot1x timeout tx-period 1
dot1x max-reauth-req 1
spanning-tree portfast
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan200
ip address 192.168.2.1 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip access-list extended USER
permit udp any any eq bootps
permit udp any eq bootpc any
permit udp any any eq domain
permit tcp any any
permit udp any any
!
ip radius source-interface Vlan100
ip sla enable reaction-alerts
!
radius-server host 192.168.1.99 auth-port 1645 acct-port 1646 key cisco123
radius-server vsa send authentication
!
!
line con 0
login authentication line-console
line vty 5 15
!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion