unable to activate HSRP

Unanswered Question
Dec 23rd, 2009
User Badges:

Hello to all,

I have the following problem: I have two routers connected to the same switch (not Cisco) and I tried to configure the HSRP between the two routers (CS3825 and CS2811). In the CS3825 I had a fastetherent interface available while in the CS2811 I used a switched port (HWIC-4ESW). For this router before I configured a VLAN (1) with the relative HSRP parameters and linked the fast ethernet port to this vlan, while for the other router I configured directly the FE interface. I can ping the routers but the HSRP does not go up: the secondary router does not receive the hello packets:


CS3825:


interface FastEthernet1/1
description --- Customer LAN--
ip address 10.10.10.7 255.255.255.0
duplex full
speed 100
no cdp enable
standby version 2
standby 50 ip 10.10.10.1
standby 50 priority 110
standby 50 preempt
standby 50 name HSRP-pqev136-pqev139
standby 50 track 20 decrement 20

CS2811:


interface FastEthernet0/0/0
duplex full
speed 100
!
interface Vlan1
ip address 10.10.10.220 255.255.255.0
standby 50 ip 10.10.10.1
standby 50 priority 105
standby 50 preempt
standby 50 name HSRP-pqev136-pqev139




Vl1         50  105  P Active   local           unknown         10.10.10.1

I put the VLAN 1 for try to be aligned with the customer switch: no vlan, default configuration

I tried with other VLAN but the result is the same. I'm not able to understand why the HSRP does not work

Thank you for your support


Marco Perduca

Solution Consultant Orange Business Services

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
milan.kulik Wed, 12/23/2009 - 05:42
User Badges:
  • Red, 2250 points or more

Hi,


are you sure the non-Cisco switch is forwarding HSRP multicasts from one port to the other?

I had the same issue with a 3Com switch in the past - it was not forwarding multicasts by default.


BR,

Milan

Peter Paluch Wed, 12/23/2009 - 07:36
User Badges:
  • Cisco Employee,

Hi Marco,


Just a one brief hint after going quickly through your configuration: on the C3825, you have activated HSRPv2. On the C2811, you are running HSRPv1. They are not entirely compatible and they also use different vMAC addresses. That would be the first thing I'd try to correct - make both routers run the same version of HSRP.


Best regards,

Peter

Actions

This Discussion