cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3212
Views
0
Helpful
6
Replies

Etherchannel trunk between a 4003 CatOS and 3550 IOS

poirot1967
Level 1
Level 1

I need to configure an etherchannel trunk between a 3550 running IOS, and an aged 4003 running CatOS.  The person before me tried to do so, but didn't quite get it to work.  Here is the config I propose to use :

3550

interface GigabitEthernet0/11
description etherchannel trunk to 4003
no channel-group 1 mode on  - to remove the previous attampt
channel-group 1 mode desirable
switchport mode trunk
switchport trunk encapsulation dot1q
speed 1000
duplex full

interface GigabitEthernet0/12
description etherchannel trunk to 4003
no channel-group 1 mode on
channel-group 1 mode desirable
switchport mode trunk
switchport trunk encapsulation dot1q
speed 1000
duplex full


---------------------------------------------

4003

set port speed 2/47 1000
set port speed 2/48 1000
set port duplex 2/47 full
set port duplex 2/48 full

set spantree portfast 2/47 disable
set spantree portfast 2/48 disable
set trunk 2/47 on dot1q
set trunk 2/48 on dot1q

set port channel 2/47-48 mode desireable
set trunk 2/47 desireable

I can only take these 2 down for a short time to configure them, so I won't have much time to troubleshoot if I botch it.  Any suggestion to the above configs?

Poirot

1 Accepted Solution

Accepted Solutions

glen.grant
VIP Alumni
VIP Alumni

  Normally between cisco devices I think they recommend you add the parameter "non-silent"  after the desirable in the channel statement .   Also when you do this on the IOS side shutdown the portchannel SVI (interface port channel x)   make your changes then no shut it which will bring up both physical interfaces at the same time  which is important when negotiating a port channel.

3550

Interface Portchannel 1

switchport mode trunk

switchport encapsulation dot1q

shut

interface GigabitEthernet0/11
description etherchannel trunk to 4003
no channel-group 1 mode on  - to remove the previous attampt
channel-group 1 mode desirable non-silent
switchport mode trunk
switchport trunk encapsulation dot1q
speed 1000
duplex full

interface GigabitEthernet0/12
description etherchannel trunk to 4003
channel-group 1 mode desirable non-silent
switchport mode trunk
switchport trunk encapsulation dot1q
speed 1000
duplex full


---------------------------------------------

4003

set port speed 2/47 1000
set port speed 2/48 1000
set port duplex 2/47 full
set port duplex 2/48 full

set spantree portfast 2/47 disable
set spantree portfast 2/48 disable
set trunk 2/47 on dot1q
set trunk 2/48 on dot1q

set port channel 2/47-48 desirable non-silent

View solution in original post

6 Replies 6

Reza Sharifi
Hall of Fame
Hall of Fame

Hello Poirot,

Your config looks good, but I would take some unused ports on both switch and test before using it in production.

Also, for consistency and ease of troubleshooting, can you make the portchannel number the same on both switches.

Take a look at this document on some limitation when using PAGP or LACP (depending on IOS version).

http://www.ciscosystems.org.ro/en/US/products/hw/switches/ps663/products_configuration_example09186a0080094aec.shtml

Good Luck

Reza

Thanks for the idea.  I will do so on Monday.

Poirot

glen.grant
VIP Alumni
VIP Alumni

  Normally between cisco devices I think they recommend you add the parameter "non-silent"  after the desirable in the channel statement .   Also when you do this on the IOS side shutdown the portchannel SVI (interface port channel x)   make your changes then no shut it which will bring up both physical interfaces at the same time  which is important when negotiating a port channel.

3550

Interface Portchannel 1

switchport mode trunk

switchport encapsulation dot1q

shut

interface GigabitEthernet0/11
description etherchannel trunk to 4003
no channel-group 1 mode on  - to remove the previous attampt
channel-group 1 mode desirable non-silent
switchport mode trunk
switchport trunk encapsulation dot1q
speed 1000
duplex full

interface GigabitEthernet0/12
description etherchannel trunk to 4003
channel-group 1 mode desirable non-silent
switchport mode trunk
switchport trunk encapsulation dot1q
speed 1000
duplex full


---------------------------------------------

4003

set port speed 2/47 1000
set port speed 2/48 1000
set port duplex 2/47 full
set port duplex 2/48 full

set spantree portfast 2/47 disable
set spantree portfast 2/48 disable
set trunk 2/47 on dot1q
set trunk 2/48 on dot1q

set port channel 2/47-48 desirable non-silent

Thank you for the reply.  I would not have thought about shutting he port-channel down first.  I will put that into action and let you guys know the outcome.

Poirot

Thanks.  Worked like a charm.

Poirot

vvasisth
Level 1
Level 1

here is a sample config :-

CatOS(enable) show config
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
......
................
................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
# time: Wed Jan 28 2004, 09:39:55
!

# version 6.4(2)
!
# errordetection
set errordetection portcounter enable
!
# frame distribution method
set port channel all distribution mac both
!
# vtp
set vtp domain cisco
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state
active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state
active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state
active mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
# ip

!--- This is the IP address for management.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!
# set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat5000-supg.6-4-8.bin
!
# mls
set mls nde disable
!
# port channel


!--- Ports are assigned to admin-group 200. Administrative groups
!--- specify which ports can form an EtherChannel together. An administrative group
!--- can contain a maximum of eight ports. This admin-group assignment happens
!--- automatically with the configuration of the port channel. You can also
!--- assign it manually, as done in this example. However, you do not need to assign
!--- the admin-group manually. Let the switch create
!--- the admin-group automatically.
!--- Note: This configuration sets ports 4/1 through 4/4
!--- for port channel, but only configures ports 4/1-2. This is
!--- normal behavior. You can use ports 4/3 and 4/4 for any other purpose.


set port channel 4/1-4 200
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 : 2-port MM MIC FDDI
!
#module 3 : 24-port 10/100BaseTX Ethernet
!
#module 4 : 12-port 10/100BaseTX Ethernet

!--- This enables port channeling with PAgP and configures desirable silent mode.

set port channel 4/1-2 mode desirable silent
!
#module 5 : 2-port MM OC-3 Dual-Phy ATM

!--- Output suppressed.

end

IOS

# show running-config
Building configuration...

Current configuration : 3852 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6509
!
!
redundancy
main-cpu
  auto-sync standard
ip subnet-zero
!
!
interface port-channel1
no ip address


!--- This example has configured a Layer 2 (L2) EtherChannel.
!--- You can configure a Layer 3 (L3) EtherChannel on the Catalyst
!--- 6500/6000 switches running Cisco IOS Software; however, this is not
!--- the focus of this document. For details on the Layer 3 EtherChannel configuration,
!--- refer to the document Configuring EtherChannels.



switchport


!--- This command puts the interface in VLAN1, by default.

switchport mode access
!
interface FastEthernet6/1
no ip address

!--- On the Catalyst 6500/6000, you must issue the switchport command once,
!--- without any keywords, to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default.
!--- You do not need an additional command.


switchport


!--- This command puts the interface in VLAN1, by default.

switchport mode access


!--- The port is a member of channel group 1 with autonegotiation
!--- that uses PAgP and silent mode.


channel-group 1 mode desirable
!
interface FastEthernet6/2
no ip address


!--- On the Catalyst 6500/6000, you must issue the switchport command once,
!--- without any keywords, to configure the interface as a L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default.
!--- You do not need an additional command.


switchport


!--- This command puts the interface in VLAN1, by default.

switchport mode access


!--- The port is a member of channel group 1 with autonegotiation
!--- that uses PAgP and silent mode.


channel-group 1 mode desirable
!
interface FastEthernet6/3
no ip address
!
interface FastEthernet6/4
no ip address
!

!--- Output suppressed.

interface FastEthernet6/45
no ip address
shutdown
!
interface FastEthernet6/46
no ip address
shutdown
!
interface FastEthernet6/47
no ip address
shutdown
!
interface FastEthernet6/48
no ip address
shutdown
!


!--- This is the IP address for management.

ip address 10.10.10.3 255.255.255.0


!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
!
end
Cat6509#

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco