WRVS4400Nv1 to WRVS4400Nv2 upgrade

Unanswered Question
Dec 24th, 2009
User Badges:

There were a few issues with the original V2 release, so I rolled back to v1.  Now I would like to try v2.0.0.8 and I am getting a unsupported file error.  Is there a way around this issue.  V2.0 is no longer available...my main issue is with wireless access which appears to have solutions for.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
priest.dahustla Mon, 12/28/2009 - 08:17
User Badges:

I currently have Firmware Version: V1.1.13 loaded on my router.  I have tried to upgrade the firmware directly to V2.0.0.8 and when I do so I get an error "Upgrade file is not the correct type or version for this device. Upgrade failed.  Please obtain the correct file and try again."

Filename: WRVS4400Nv2-fw-

Note:  I was curious as to whether or not others have gone from v1.1.13 to v2.0.0.8 without issue or is a firmware jump from this version no compatible.  Some firmware updates require that you upgrade in steps.  In my original message I indicated that I upgrade to v2.0 without issue but the VPN function added problems, so I rolled back.

I have also tried rolling back my current firmware version to v1.0.6 and attempted to upgrade from there....and it failed as well.  This is why I was looking for the firmware upgrade file for V2.0.

Thanks for your feedback!

Darren DeCroock Mon, 12/28/2009 - 09:00
User Badges:
  • Silver, 250 points or more

The firmware version that will work with your router is dependant upon the hardware version of the router.

Newest verions available

Hardware versions 1.0 & 1.1 - firmware 1.1.13.

Hardware version 2.0 - firmware version

Firmware version, is not compatible with hardware versions 1.0 & 1.1.

priest.dahustla Mon, 12/28/2009 - 09:29
User Badges:

I get what you are saying...this is just a little discouraging.  I do remember an update for V1 firmware release 2.0 coming out some time back but there were issues with it.  Hopefully those of us that shelled out cash for the V1 router won't be forgotten (Mine isn't very old)...I would like to see improvements with my routers wireless function.

kirksaban Sun, 01/03/2010 - 23:36
User Badges:

Can you please point me to the release notes for  I cannot seem to find them anywhere.


Brandon_NC Thu, 01/28/2010 - 06:15
User Badges:

I know this is an older post but it is the same issue I am having.

Is there any update on the original issue of updating the firmware on a v1 hardware?


Tracking number: CT20100127_0000003441

When attempting to upgrade from Firmware Version: V1.1.13 to v2.0 I get the
following error.  I was unable to locate any information on the forum.


"Upgrade file is not the correct type or version for this device.
Upgrade failed.
Please obtain the correct file and try again. "
Device: WRVS4400N

William Childs Tue, 02/02/2010 - 03:05
User Badges:
  • Bronze, 100 points or more


The problem you are experiencing is your HARDWARE is a version 1 or 1.1. However you are trying to load FIRMWARE for a version 2 router. This will not work because the v1 and 1.1 hardware has different hardware than the v2 router. Its like loading a windows xp driver on a windows vista machine, the code is written differently to work with different hardware.

In your case, you need v1.1.13 firmware. The v2.0.0.8 is for the version 2 HARDWARE. You can find your hardware version on the sticker on the bottom of your router.



Brandon_NC Tue, 02/02/2010 - 05:55
User Badges:

Thanks for the reply Bill.  I guess I am up to the latest version.

My original issue is that the router drops wireless connections and the only way to fix is to reboot the router.  I have read about others having this same issue but I have been unable to find a fix.  I was hoping a firmware update would resolve the issue.

Not wanting to thread jack can you point me to a place that has a resolution for the dropped wireless connections?


This Discussion