Terminal Lines hanging

Unanswered Question
Dec 25th, 2009

Dear Experts,

I am configuring a reverse telnet with a serial device connected to Cisco 2801 Router. The snapshot of the connectivity is below:

2801 serial router is connected to a device (OCB is name)  using a serial cable. Remote users will access this said device using the IP Address of the router with port number 200x (x=line Number)

interface Loopback0
ip address

interface Serial0/0/0
physical-layer async
no ip address
encapsulation slip
dialer in-band
async mode interactive
interface Serial0/0/1
physical-layer async
no ip address
encapsulation slip
dialer in-band
async mode interactive

line 0/0/0 0/0/1
session-timeout 10
modem InOut
no exec
transport input all
databits 7
parity even
stopbits 1
flowcontrol software
line vty 0 4
password 7 153C263F

The Issue is when the link is disconnected the telnet session which I made using is hanging. I need to manually reset the device (OCB) to reestablish the connection.

I have attached the config output for your reference . Please help

thanks in advance


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
snarayanaraju Fri, 12/25/2009 - 03:03


I missed to mention that  I even tried using absolute-timer setting in line 0/0/0 0/0/1

line 0/0/0 0/0/1
session-timeout 10

absolute-timer 1

Is there any other way to solve this issue. I am focusing on to either set the timer to disconnect/tear the connection if it is not active or otherwise to accept more than one connection


Ronit Bhattacharjee Fri, 12/25/2009 - 05:07


When you think the line is "hanging", have you tried keeping "ctrl+shift+6" pressed and then tapping x?

snarayanaraju Fri, 12/25/2009 - 08:14

Hi Ronit,

Thanks for your response.

Yes, I tried Clt+Shift+6. No use. No key strokes is making effect.

I thought If the Idle timeout/Session timeout will solve the problem... But it didnt.

Please help


Reza Sharifi Fri, 12/25/2009 - 14:54

Hi Sairam

Under line 0/0/0 0/0/1

Tty this command and test





Check the output of show process cpu whenever you face the hanging problem.Might be the vty process(virtual execution) making high utilization.

run the command sh tcp brief and then clear tcp tcb < tcb address> during when the problem creates. You can clear those TCP session one by one which is either under waiting or not usable, using the above command. You can get the tcb address from sh tcp brief.




This Discussion