Cisco IP phone 7941

Unanswered Question
Dec 25th, 2009

Hi,

          The Cisco IP Phone 7941, at our site is showing an error while booting.

          Error: On power on the Display shows Cisco logo. Other than this the two line button keep glowing. The headset button glow is green and Mute in Red colour.

          This symptoms not allow to complete boot sequence of the phone.

          Kindly suggest for the same.

         

          Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (3 ratings)
Stevew1300 Fri, 08/03/2012 - 11:40

As I re-resurrect this old thread.  Heh.

I have some 7941s that need to be moved from one network to another.

I read this procedure, and tried it on two phones, both say "upgrade" now.

The 7940s I have are resettable without having to reload the phone's firmware from TFTP, but it seems the 7941 cannot be reset to defaults without having it on a network with the TFTP and parameters.

Which I don't have for the new network these are eventually going to be deployed on.

So is there no way to reset the phone without reloading the whole thing?

I just wanted to blow out old address books (personal employee information) and network settings leaving these phones in a state that they can be easily deployed later.

Thanks in advance.

Aaron Harrison Fri, 08/03/2012 - 12:36

Hi Steve

Bad you for creating a zombie.

I'll try for a headshot :-)

Basically you don't want to factory reset if you are going to a network where TFTP isn't set up propertly for these reasons:

1) TFTP/DHCP should always be set up properly.

2) TFTP/DHCP should always be set up properly.

3) TFTP/DHCP should always be set up properly.

4) Personal address books aren't stored on the phone. They are part of the CUCM database, so you take away the phone, they forget.

5) You can clear the 'network' config by going into the network config subment and doing an 'erase' there. Again, if DHCP etc is configured properly on the network you are going to, it's a non-issue as all that stuff gets picked up from the new LAN. If DHCP not configured properly, you need to configure the IP stuff manually so again, it's a non issue.

Regard

Aaron

Stevew1300 Fri, 08/03/2012 - 12:50

Aaron,

Yeah, created a zombie.  My bad.  Shoot for the headcrabs. 

It seems that address books are stored on 7940s, which I am much more familiar with. Well, AFAICT.

My surprise they are not on 7941s.

Or so you say.

However I have missed, received and placed calls that are there and should be erased.

These came from another division and no one knows the pw to reset network settings.

Unless there is a default pw, these all say locked. Well, on second look **# works.

But there is no default command that I can see. 

So it's kind of a PITA to have to erase parameters from a number of used phones.

Which is why the reset was necessary.  Some are also in other languages at this time. 

Like Japanese.  Things certain engineers were comfortable in.  Gad.

Aaron Harrison Fri, 08/03/2012 - 15:21

None of the phones have local storage for numbers - they are all stored in CUCM.

Language is downloaded from the target system based on the config there, unless the target system is broken.

Same for firmware.

Same for network settings.

So there is no data security stuff to worry about... and no setting stuff, or language stuff, unless your target system is broken. And if it is broken... fix the target system, don't reset the phone.

Aaron

Stevew1300 Fri, 08/10/2012 - 14:30

Aaron,

The target system isn't broken, it's just not on site.

I have suggested we set one up here. 

That has met with lukewarm response. Heh.

Is there an easy way to put new firmware on these phones without the CUCM being on site?

We have all local ips naturally, part of our security plan. 

These phones don't seem to get an IP from our local DHCP. 

They need the call manager, I guess.

vivkalra Sat, 12/26/2009 - 01:52

If there is only one 7941 phone which is not booting properly and other phones are working fine

then we can try factory resetting of that particular phone

To initiate the factory reset:

  1. Start with the phone in a powered off state.
  2. While holding the "#" key down on the keypad, apply power to the phone.
  3. Keep the "#" key depressed until you see the LEDs on the phone begin a 'walking' sequence, where they walk down from top to bottom.
  4. After you see the LED walk sequence begin, you can release the "#" key and enter one of the reset sequences below.  You have to enter the sequence as is, any deviation from the given sequence will abort the factory reset and resume a normal boot sequence.

Soft Reset

The code for the soft factory reset is: 123456789*0#

A soft reset does the following:

  1. deletes key files on the phone including /etc/init.tab
  2. reboots
  3. phone recovers default loads file from TFTP server

Total Hard Reset

The code for the total hard reset is: 3491672850*#

A total hard reset formats /flash0 blowing away everything except CNU.  All settings and personalization of the phone is removed.

Hard Reset with Network Setting Preservation

The code for the network preservation hard reset is: *7412369#085

And it also does a complete format of /flash0 - yet it preserves the network settings so that after the format, any static IP and other network settings are preserved. The settings are stored in volatile RAM, so it is important to not remove power to the phone during this process

For CSCsi60439 reference please see document EDCS-609633.

Prerequisites

There are a number of prerequsites that are necessary for a successful factory reset.

  1. You must have a network environment in which DHCP is used to provide the phone with an IP address and a TFTP server (i.e. DHCP option 150).
  2. There must be an appropriate default load for your phone model on that TFTP server:      
    • The default load name is: termxx.default.loads (where xx is part of the model number, 41 for 7941, 62 for 7962, 70 for 7970, etc.)
    • The version of the default load must be the same signing type (dev or release) as the phone on which you wish to do a factory reset.
    • This file (termxx.default.loads) is packaged with every phoneload that is installed on the callmanager, but since the name is not unique per phoneload version, the copy of termxx.default.loads is always the one from the most recent load that was installed on the callmanager. It may not be the type (dev or release) that you want.
ruttersean Wed, 06/02/2010 - 07:40

The Total Hard Reset process posted above worked for me.

I had a 7941 that did not boot at all and had a random pixellated display.

The Total Reset wiped the phone and allowed the firmware to be upgraded.

Phone now works perfectly.

Thanks

INEMINEMINEMINEM Thu, 05/12/2011 - 14:54

Hello,

After doing a Total Hard Reset, which procedure should be done to put new firmware on the phone without a CUCM, it is possible with TFTP only?

Best Regards

Carlos

mystichman Wed, 05/30/2012 - 06:47

Thank You Vivek. The total hard reset worked for me too. I never knew about this procedure until now. The phone I was working with was a 7962 stuck on 'Upgrading' and would not load the new image. It took a few minutes and had me worried when the screen went blank for a couple of minutes but it eventually came back to life, rebooted and upgraded immediately.

Much Apprectiated...

abrashic Wed, 07/11/2012 - 14:44

Vivek,

Thaks for the post.  I did manage to recover to 7941s that appeared to be completely dead.  One thing I have noticed is that option 150 does not seem to work very well outside of the cisco environment.  Even with tftp32 as the tftp server the phones would not communicate properly.  I wound up loading all my files on my 2900 ISR and setting the option 150 address to the ISR.  Everything worked great then.

Paolo Bevilacqua Fri, 08/03/2012 - 12:01

The reason why option 150 doesn't work with tftpd32 is that it expects option to be format ascii not IPs. So one tries to prefix 0x and put the address in hex backward, just to find still trouble. At the end, router works better, as you found.

Actions

Login or Register to take actions

This Discussion

Posted December 25, 2009 at 4:28 AM
Stats:
Replies:12 Avg. Rating:5
Views:30627 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
159
95
75
66
55