no network connectivity with 2650xm router

Unanswered Question
Dec 25th, 2009

Hi all,

i have 2650xm  router directly connected to cable modem.

I have laptop on fa1/0 port and port fa0/0 connects directly connect to cable modem.

My Laptop  has IP  and its gateway is fa1/0 interface IP

fa0/0  interface on router has IP  96.X.X.X.

From my laptop i am unable to access any internet sites also unable to ping the Fa0/0 interface on the router.

i rebooted cable modem and laptop few times no luck.

any ideas which i can try



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Ganesh Hariharan Fri, 12/25/2009 - 20:50

What is the status of the fa0/0 by issuing a command show fa0/0 and are you able to ping the gateway ip ?



mahesh18 Sun, 12/27/2009 - 10:05


i am able to telnet the router now by public ip

i will past my config here .

from router i am unable to ping the 96.x.x.x ip which my int fa0/0 has got from my isp.

i can ping the fine.

Please help


mahesh18 Sun, 12/27/2009 - 10:06


status of  fa0/0 is up up and public ip is assigned to it.

Nikos Nicolaides Sat, 12/26/2009 - 01:15


Have you enabled NAT on the router?

A sample configuration is displayed below:

interface fa1/0

ip add

description TO LAN

ip nat inside

interface fa0/0

ip address


ip nat outside

access-list NAT-ACL permit ip any any

ip nat inside source list NAT-ACL interface fa0/0 overload


And then ping a public ip, say with an internal ip

Ping source fa1/0


Hope that helps

mahesh18 Sun, 12/27/2009 - 10:07


thanks for reply

i have pasted my router config .

i have enabled nat.

still no luck.

please help



Reza Sharifi Sun, 12/27/2009 - 10:21


Do you have a default route configured toward your service provide?

Can you post the entire config?


mahesh18 Sun, 12/27/2009 - 15:05

Hi Reza,

thanks for reply i have entire config  attached please see my post from today


Reza Sharifi Sun, 12/27/2009 - 16:13

Hi Mahesh,

I do not see a default route in your config.

ip router (the address of the modem)

May be you did not post every thing



mahesh18 Sun, 12/27/2009 - 16:15

Hi Reza,

when you use ip address dhcp command under wan interface you do not need to maually config this command/

i pasted you all config



Giuseppe Larosa Sun, 12/27/2009 - 12:24

Hello Mahesh,

I see that your external interfaces takes an ip address by DHCP. This is made by using BOOTP packets that are UDP/IPv4 packets.

Actually, you send out a broadcast request but the answer is directed to your router's fas0/0 MAC address.

The fact that you cannot ping your default gateway may come from a security measure of provider, it is not a sure sign of problem.

The cable modem can act as a simple bridge and the default gateway can be in the head end serving a lot of users.

You say that you are not able to browse the internet from the laptop, have you tried to bypass the DNS function trying to access directly a public ip address that can be pinged?

in the file we see:

S* [254/0] via 96.X.Y.Z

have you got this from DHCP or you have configured it manually?

that is you are using

ip route 96.X.Y.Z 254

or a form including the DHCP keyword:

ip route dhcp 254



(Optional) Enables a Dynamic Host Configuration Protocol (DHCP) server to assign a static route to a default gateway (option 3).

Note Specify the dhcp keyword for each routing protocol.

Was the service working if the PC is connected directly to the cable modem? Could the provider have stored the MAC address of your PC?

from the laptop shell if you try to use the old nslookup tool what you get?

I see that you receive a DNS server that is in a different major network, this should not be a problem but testing the DNS part can help to understand if you have only a DNS issue, or an IP connectivity issue.


I have forgotten that you have been able to telnet to the public ip address of your router this should demonstrate IP connectivity.

Hope to help


mahesh18 Sun, 12/27/2009 - 13:46

Hi giuslar,

thanks for reply

in the file we see:

S* [254/0] via 96.X.Y.Z

have you got this from DHCP or you have configured it manually?  

Answer  i got this from DHCP.

Was the service working if the PC is connected directly to the cable modem

Answer  yes it works if pc is directly connected to cable modem.

Also i am unable to ping the IP  of interface fa0/0  when i am logged on router but i can ping this IP  from C>prompt of laptop.

Let me know if you need more info.

also Note i am able to telnet public IP only from my home Lan not from outside.



Ganesh Hariharan Sun, 12/27/2009 - 22:21


Are you able to ping the direct gateway from your laptop that is local lan and if yes try ping from router with extended ping command using source ip as fa0/0 and try ping laptop and  run ethereal software on your laptop and capture the packet what exatly is happening when you ping the interface fa0/0 and share your output.




This Discussion