cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1592
Views
0
Helpful
2
Replies

DHCP server

anitachoi3
Level 1
Level 1

Hi,

I config 3 VLANs in the network. There is one DHCP server per VLAN. I would like to achieve following:

VLAN 1: 192.168.11.0

DHCP svr: 192.168.11.23

backup DHCP svr: 192.168.12.23 and 192.168.13.23

VLAN 2: 192.168.12.0

DHCP svr: 192.168.12.23

backup DHCP svr: 192.168.11.23 and 192.168.13.23

VLAN 3: 192.168.13.0

DHCP svr: 192.168.13.23

backup DHCP svr: 192.168.11.23 and 192.168.12.23

Device: Catalyst 3750

Any missing in the config as below?

rdgs

--- config ---

interface GigabitEthernet1/0/1

description VLAN 1

switchport access vlan 1

switchport mode access

!

interface GigabitEthernet1/0/2

description VLAN 2

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/3

description VLAN 3

switchport access vlan 3

switchport mode access

!

!

interface Vlan1

description User segment 1

ip address 192.168.11.1 255.255.255.0

ip helper-address 192.168.12.23

ip helper-address 192.168.13.23

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface Vlan2

description User segment 2

ip address 192.168.12.1 255.255.255.0

ip helper-address 192.168.11.23

ip helper-address 192.168.13.23

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface Vlan3

description User segment 3

ip address 192.168.13.1 255.255.255.0

ip helper-address 192.168.11.23

ip helper-address 192.168.12.23

no ip redirects

no ip unreachables

no ip proxy-arp

!

----- end ----

2 Accepted Solutions

Accepted Solutions

Jon Marshall
Hall of Fame
Hall of Fame

anitachoi3 wrote:

Hi,

I config 3 VLANs in the network. There is one DHCP server per VLAN. I would like to achieve following:

VLAN 1: 192.168.11.0

DHCP svr: 192.168.11.23

backup DHCP svr: 192.168.12.23 and 192.168.13.23

VLAN 2: 192.168.12.0

DHCP svr: 192.168.12.23

backup DHCP svr: 192.168.11.23 and 192.168.13.23

VLAN 3: 192.168.13.0

DHCP svr: 192.168.13.23

backup DHCP svr: 192.168.11.23 and 192.168.12.23

Device: Catalyst 3750

Any missing in the config as below?

rdgs

--- config ---

interface GigabitEthernet1/0/1

description VLAN 1

switchport access vlan 1

switchport mode access

!

interface GigabitEthernet1/0/2

description VLAN 2

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/3

description VLAN 3

switchport access vlan 3

switchport mode access

!

!

interface Vlan1

description User segment 1

ip address 192.168.11.1 255.255.255.0

ip helper-address 192.168.12.23

ip helper-address 192.168.13.23

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface Vlan2

description User segment 2

ip address 192.168.12.1 255.255.255.0

ip helper-address 192.168.11.23

ip helper-address 192.168.13.23

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface Vlan3

description User segment 3

ip address 192.168.13.1 255.255.255.0

ip helper-address 192.168.11.23

ip helper-address 192.168.12.23

no ip redirects

no ip unreachables

no ip proxy-arp

!

----- end ----

Anita

There is nothing missing but be aware that all DHCP servers will be used for each vlan so the local DHCP will see the request but also the 2 ip helper-addresses will see the request per vlan as well. The local one should be the first to respond but that is not always a given.

So you need to make sure that each DHCP server hands out unique addresses per vlan ie. 3 DHCP servers per vlan means each DHCP server is responsible for a 3rd of the subnet for that vlan. You cannot have 2 or more DHCP servers responsible for the same address.

Jon

View solution in original post

Ganesh Hariharan
VIP Alumni
VIP Alumni

Hi,

Configuring DHCP you need to create pools for alloting ip address for particular vlan,check out the below link for configuraing dhcp in cisco switches.

http://www.cisco.com/en/US/docs/routers/access/1800/1801/software/configuration/guide/dhcpvlan.pdf

and check out the sample configuration regarding dhcp.

ip dhcp pool pool1
   network 10.10.1.0 255.255.255.0
   default-router 10.10.1.1
   dns-server what.ever.ip.itis
!
ip dhcp pool pool2
   network 10.10.2.0 255.255.255.0
   default-router 10.10.2.1
   dns-server what.ever.ip.itis2
vlan 10
ip address 10.10.1.1 255.255.255.0
!
vlan 20
ip address 10.10.2.1 255.255.255.0

the default-router command ties that pool to the interface (vlan)

Hope that helps out your query !!

Regards

Ganesh.H

View solution in original post

2 Replies 2

Jon Marshall
Hall of Fame
Hall of Fame

anitachoi3 wrote:

Hi,

I config 3 VLANs in the network. There is one DHCP server per VLAN. I would like to achieve following:

VLAN 1: 192.168.11.0

DHCP svr: 192.168.11.23

backup DHCP svr: 192.168.12.23 and 192.168.13.23

VLAN 2: 192.168.12.0

DHCP svr: 192.168.12.23

backup DHCP svr: 192.168.11.23 and 192.168.13.23

VLAN 3: 192.168.13.0

DHCP svr: 192.168.13.23

backup DHCP svr: 192.168.11.23 and 192.168.12.23

Device: Catalyst 3750

Any missing in the config as below?

rdgs

--- config ---

interface GigabitEthernet1/0/1

description VLAN 1

switchport access vlan 1

switchport mode access

!

interface GigabitEthernet1/0/2

description VLAN 2

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/3

description VLAN 3

switchport access vlan 3

switchport mode access

!

!

interface Vlan1

description User segment 1

ip address 192.168.11.1 255.255.255.0

ip helper-address 192.168.12.23

ip helper-address 192.168.13.23

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface Vlan2

description User segment 2

ip address 192.168.12.1 255.255.255.0

ip helper-address 192.168.11.23

ip helper-address 192.168.13.23

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface Vlan3

description User segment 3

ip address 192.168.13.1 255.255.255.0

ip helper-address 192.168.11.23

ip helper-address 192.168.12.23

no ip redirects

no ip unreachables

no ip proxy-arp

!

----- end ----

Anita

There is nothing missing but be aware that all DHCP servers will be used for each vlan so the local DHCP will see the request but also the 2 ip helper-addresses will see the request per vlan as well. The local one should be the first to respond but that is not always a given.

So you need to make sure that each DHCP server hands out unique addresses per vlan ie. 3 DHCP servers per vlan means each DHCP server is responsible for a 3rd of the subnet for that vlan. You cannot have 2 or more DHCP servers responsible for the same address.

Jon

Ganesh Hariharan
VIP Alumni
VIP Alumni

Hi,

Configuring DHCP you need to create pools for alloting ip address for particular vlan,check out the below link for configuraing dhcp in cisco switches.

http://www.cisco.com/en/US/docs/routers/access/1800/1801/software/configuration/guide/dhcpvlan.pdf

and check out the sample configuration regarding dhcp.

ip dhcp pool pool1
   network 10.10.1.0 255.255.255.0
   default-router 10.10.1.1
   dns-server what.ever.ip.itis
!
ip dhcp pool pool2
   network 10.10.2.0 255.255.255.0
   default-router 10.10.2.1
   dns-server what.ever.ip.itis2
vlan 10
ip address 10.10.1.1 255.255.255.0
!
vlan 20
ip address 10.10.2.1 255.255.255.0

the default-router command ties that pool to the interface (vlan)

Hope that helps out your query !!

Regards

Ganesh.H

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card