rv042 load balancing - dropping gtalk

Unanswered Question
Dec 26th, 2009

i've 2 adsl lines (1Mbps download speed and 512Kbps upload speed) and used rv042 for load balancing.

but sometimes, IM program like gtalks don't work well.sign out and sign in again and again

i adjusted MTU sizes (1500, 1490, 1492, 1480) and still have problem

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Alejandro Gallego Sun, 12/27/2009 - 13:23

Try this:

Required ports to use Google Talk


If you're having trouble connecting to Google Talk through your firewall or proxy, it may be because some necessary ports are blocked.

In order to connect to Google Talk and start sending IMs, you'll need to enable TCP connections to talk.google.com on port 5222, or on port 443.

If you'd like to make calls or transfer files through Google Talk, you need to:

  • Enable UDP connections to anywhere on any port; or
  • Enable TCP connections to anywhere on port 443.

If you're behind a public or corporate network that is blocking these ports or protocols, please contact your local network administrator for further instructions.

From Google Q&A

tuntunlin Mon, 12/28/2009 - 06:50

thanks for you kindly reply

not blocking port error. when i remove linksys rv042 and use with isa server, it is ok.

my network configuration is the followings

two adsl modems => linksys rv042 => isa server => local client computers

my problem is not blocking gtalk, it can easily connect gtalk server and sign in within 5 seconds.

but, within one hours, sign out and in again and again (three to five times).

pls advise me.

thanks in advance

Te-Kai Liu Mon, 12/28/2009 - 11:02

You could try to use RV042's Protocol Binding to bind the traffic destined to gtalk server to one WAN port.

tuntunlin Mon, 12/28/2009 - 19:53

yes. i've already set protocol binding rules like that.

HTTPS [TCP/443~443] -> []/WAN1

HTTPS Secondary [TCP/8443~8443] -> []/WAN1

Alejandro Gallego Mon, 12/28/2009 - 14:31
but, within one hours, sign out and in again and again (three to five times).

So you mean you are logged in and happy google tallking and then after about an hour the application logs out and then auto-logs back in?

Have you looked at the logs on the ISA server? I am not completely familiar with the back end of Gtalk so not sure if there is an IP change (re-direction) or if there are time-out values, but it alsmost seems like authentication is happening at one location (IP or Port) and talking else where (IP or Port). Maybe you missed something in the ISA after installing the new router???

That is very intersting behavior and will be tough narrowing this down. If possible, doing some packet capture between the RV and the ISA would be very helpful.

tuntunlin Mon, 12/28/2009 - 23:44

hi  mr. alegalle

thanks for your disscussion.

i think this is not isa problem coz problem still occur when i directly connect rv042 lan port.

pls advise me.

jamccord Tue, 12/29/2009 - 06:18

What happens when you only have one WAN connection enabled.  Do you still drop going thru the RV042 or will gtalk remain connected?  Does the application disconnect when you add the second WAN?  Please test and let me know the results.

tuntunlin Wed, 12/30/2009 - 01:05

when i removed WAN2 plug and i changed nothing in router configuration, it work fine.
is this load balancing problem ?

i found that gtalk connect google server with https:443.
i dont' let go https traffic to wan2 with this rules in protocol binding

HTTPS [TCP/443~443] -> []/WAN1

HTTPS Secondary [TCP/8443~8443] -> []/WAN1

jamccord Wed, 12/30/2009 - 12:27

Please confirm the version of firmware applied to the router. Current version is

tuntunlin Wed, 12/30/2009 - 20:28

yes. my firmware is that version

Serial Number :                     AHY08HC01533

Firmware version :             (Feb 13 2009 13:03:21)
CPU :                     Intel IXP425-266DRAM :                     32M


This Discussion