Caller ID for external outbound calls on CCM 7.0

Unanswered Question
Dec 28th, 2009


we are using CCM 7.0 and configure MGCP gateway with E1 PRI. users encounter the caller ID issues when dialing out to external phone calls, the IPT display the company mainline number eg. 29967688 for Hong Kong rather than the DID / extension numbers from users. we have checked below -
1. Checkbox for External Phone Number Mask on DN Config window
2. Checkbox for Calling Party's External Phone Number Mask under Calling Party Transformations on Router Pattern window
3. Calling Party Transform Mask under Calling Party Transformations on Route Patterns page is set to 8522996XXXX#

With the above setting, issue remain unresolved.

Caller ID (internal name and number) works perfect for internal 4-digit extension calls, is there any way that we could do the fine-tune / programming on CCM or gateway for the translation-rules to display the caller number when dialing out external outbound calls


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Marwan ALshawi Mon, 12/28/2009 - 02:53

first just stick will

the one way

in the DN setting of the ip phone lets say you have phone with number of 1234

under the external number mas in 1234 DN setting put it like 8522996XXXX  ( assuming that ( 8522996xxxx) the number that the teleco expect from you

under the route pattern that route the calls to the PSTN check the Checkbox for Calling Party's External Phone Number Mask  ( as you did )

do not do other trasformations to the calling number remove the setting you did in point 3

after that, if dosen 't work

debug the gateway

by enabling debug isdn q931   then make a call and see if you sending the calling number to he telco if Yes thats mean the telco is overriding the calling number

good luck

if helpful Rate

marychin21 Mon, 12/28/2009 - 19:17

appreciated for the info.

provided the checklists have been done for External Number Mask and Calling Party's External Phone Number Mask; and the correct calling number is sending to telco, is there anything we could do on the System > Service Parameters > Clusterwide Parameters (Device - Phone) or any workarounds to resolve the persistent CallerID issue

Marwan ALshawi Mon, 12/28/2009 - 21:46

did you do the debug in the voce gateway ? is the callling number sent by your CCM to the gateway then pstn ?

pstojanovski Fri, 10/29/2010 - 17:02

My only question for this is, how can I get it to display the name of the company calling rather than just the number.

Michel Marzol Wed, 02/09/2011 - 10:42

You have to speak to your telephony provider. They set that up for you. you can't set that in CUCM.


This Discussion

Related Content