CUPC failed to connect to VM - Invalid Credentials or Account Locked

Answered Question
Dec 28th, 2009

CUCM 7.1.3

Unity Connection 7.1.3

CUPS 7.0.2

I'm trying to configure my CUPC client to connect to voice messaging. I keep getting the "Invalid Credentials or Account Locked" error message when I look at server health. What username and password should I be configuring the CUPC client with?

In Unity Connection I have gone to Users > Edit > Change Password. Then I've set the "voice mail" and "web application" passwords to be the same. I configure CUPC with this password and the Unity Connection user alias. I have also tried entering the user extension instead of the alias but get the same error message.

Any ideas?

Thanks,

-mike

I have this problem too.
0 votes
Correct Answer by htluo about 6 years 11 months ago

You may test IMAP login with telnet.  See http://htluo.blogspot.com/2009/01/how-to-test-imap-connection.html

Thanks!

Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (4 ratings)
Loading.
Michael Murray Tue, 12/29/2009 - 06:23

Michael,

I actually came across your article prior to my original post but it looked like the IMAP testing detailed was for Unity and using an MS Exchange server. I tried doing a telnet to the cups server on port 143 but that failed. Is that how I test IMAP on Unity Connection?

Thanks,

-mike

htluo Tue, 12/29/2009 - 06:27

If you're using Unity Connection, the IMAP server is the Unity Connection server.

Try to telnet to the Unity Connection server on port 143.  The username is the "End User" of CUCM.  The password is the "Web Application" password of Unity Connection (unless you're using LDAP authentication for Unity Connection).

Thanks!

Michael

Michael Murray Tue, 12/29/2009 - 06:28

Scratch that (above). I was able to telnet to the Unity Connection server (duh) but am getting the following error:

"user is not licensed for IMAP"

htluo Tue, 12/29/2009 - 06:32

Then you should go to Unity Connection Administration > Class of Service.  There should be a default class called "Voicemail User" something.  And it's the default CoS for all users.  Click on this class and you'll find the IMAP settings.  You should allow user access IMAP header and body.

The detailed steps are explained in this book: http://www.lulu.com/content/5552336

Thanks!

Michael

Michael Murray Tue, 12/29/2009 - 07:23

Got it working. Just had to license the users in the Unity Connection class of service configuration.

From here:

http://www.cisco.com/en/US/docs/voice_ip_comm/cupc/7_0/english/installation/guide/servrec.html

Step 1 Set up a new or existing class of service in Cisco Unity Connection Administration to enable Internet Mail Access Protocol (IMAP) client access to voice messages.

a. Expand Class of Service in the left pane.

b. Click Class of Service.

c. Click the display name of the applicable class of service in the Search Results table, in the Search Class of Service window.

d. Check Allow Users to Use Unified Client to Access Voice Mail for port 7993 and TLS, under Features.

e. For all other ports and protocols, perform the following steps:

Check Allow Users to Access VoiceMail Using an IMAP Client under Licensed Features.

Select Allow Users to Access Message Bodies.

Check Allow Users to Use Unified Client to Access Voice Mail under Features.

f. Click Save.

-mike

Actions

This Discussion