Cisco ASA 5505 Vlan1 IP change

Unanswered Question
Dec 28th, 2009

Hi,

In default mode the ASA 5505 is setup with two Vlan's, one inside and one outside. Vlan1 is the default inside VLan, with IP 192.168.1.1. I would like to change the subnet of Vlan1 tot 192.168.10.1, but when I do, no Ethernet port is assigned to Vlan1 anymore (was 0/1 - 0/7). What I have done is;

#config t

(config)#interface vlan 1

(config)#ip address 192.168.10.1 255.255.255.0

But after that, no Ethernet port is within Vlan1, so I tried the following to assign one (port 0/1);

#config t

(config)#interface 0/1

(config)#switchport access vlan 1

(config)#no shut

But nothing happends when monitoring (#show run) interface 0/1 (no Vlan assigned)

Please help!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Tim Roelands Tue, 12/29/2009 - 09:48

Well, I did not solve it....The problem is when the Inside (vlan1) IP has been modified I'm no longer able to connect to the ASA using ASDM. I found on the internet that is has something to do with an DHCP Pool assigned to Vlan1, but Im unable to remove this pool, I guess as a result of leak of knowledge....

Maybe someone can help why changing the default IP of the default Vlan causes this much trouble...Thanks in advance.

Tim Roelands Tue, 12/29/2009 - 13:11

Well, solved it myself!

It's kind a drastic solution, but it worked. To configure an other default IP for Vlan 1, simply restore the ASA to it factory defaults with the following parameters;

Let's say we like to set Vlan1 to subnet 192.168.10.x instead of (the default) 192.168.1.x

(config)#configure factory-default 192.168.10.1 255.255.255.0

Jobs done, happy new year...

todd-nash Mon, 02/01/2010 - 14:51

Excellent job stendec75 , I was searching for the same issue. I used ASDM to change my Vlan1 IP, but then, after the change, I lost all access to it through ASDM. By posting your own found solution to your problem, you helped me out a ton.

Thank you.

shinepothen Thu, 02/23/2012 - 06:08

The reason why u lost ASDM connection is once you change the inside ip you have to allow the same ip for

http server enable

http 192.168.x.x 255.255.255.0 inside

If u do not do this the first ip will only be allowed and with the new ip which u given will not have access.

Sent from Cisco Technical Support iPad App

Actions

Login or Register to take actions

This Discussion

Posted December 28, 2009 at 2:29 PM
Stats:
Replies:6 Avg. Rating:5
Views:22326 Votes:0
Shares:0
Tags: vlan, ip, assign
+

Related Content

Discussions Leaderboard