UC520 Caller ID issue Greece Tellas

Unanswered Question
Dec 28th, 2009


A client in Greece uses tellas as PSTN provider.

Tellas doesn't use the usual cp tone GR, as far as I understand, because ip-phones ring for about 60s after call is not answered and hang up by the call-in party.

Any help to configure FXO ports to detect disconnect for Tellas will be appreciated.

Thank you.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ronlewis Fri, 01/15/2010 - 10:55

Did you get help on this issue?

If not, can you post a copy of your config, remove any passwords or other personal site info, so we can see what you have configured.
FXO compatability in Greece has been tested and used by other customers without issue.

Ron Lewis


Dimitris Mingos Mon, 01/18/2010 - 12:34

Hi Ron,

I will at clients premisses on Friday.

I will post the info you requested.

I am planning to capture the hung up frequency and create a custom cp-tone.

I am not the only one in the field who has problems with that provider.

I hope you can give me a simpler solution


Dimitris Mingos Wed, 01/20/2010 - 02:19

Hi Ron,

attached are the info requested.

We can say that this an Extended Loss of Service. The client doen't want to spend any money on the product till the problem is solved, (smartnet etc.) and I can not blame him.

Waiting your respose.

Thank you.


Steven Smith Wed, 01/20/2010 - 07:59

Under the FXO ports, I don't see the cptone commands.  Could you add them?

config t

voice-port 0/2/0

cptone GR


no shut

voice-port 0/2/1

cptone GR


no shut

Then try making the calls again. 

Dimitris Mingos Thu, 01/21/2010 - 11:50

Hi Steven,

We already tried it. (up from start)


Any other suggestions?


Steven Smith Tue, 02/02/2010 - 07:45


Does this work on a regular analog phone?  If so, when does the caller id show up?  In between rings, before the ringing? 

Could you try this...

voice-port 0/1/0

caller-id alerting dsp-pre-alloc
no shut

Ring in on that port and let me know if that helps.

Dimitris Mingos Wed, 02/24/2010 - 02:10


pls forgive my late replay.

Problem IS NOT SOLVED. And I do not see any way to find a solution.

The configuration is OK.

And we have 2 serious cases without solution.

1. The phone keeps ringing even though the remote party hangs up (if not answered) for about 2 min.

2. Caller ID is not possible.

Client is tired with that mess, we can not provide a solution.

Tellas is not giving any info to us.


Steven Smith Wed, 02/24/2010 - 10:22

For issue 1, I would recommend opening a TAC case.  We need to see what is coming in on the line, and it is possible to do on the UC500, but steps are detailed and requires a a large file transfer. 

For issue 2, you need to have OPX on your FXO port plar command.

connection plar 220

should be

connection plar opx 220

You could also try...

connection plar opx immediate 220 (might help with caller id, might not)

Dimitris Mingos Wed, 02/24/2010 - 21:31


Thank you all for your time ad effort.

We advised the client and the client agreed to return to the public PSTN provider OTE (Hellenic Telecomm).

I will try to find the time to open a TAC case.

Best regards



This Discussion