LinkSys RV042 router problem (upgrade)

Unanswered Question
Dec 27th, 2009

I have a LinkSys RV042 VPN router. When I logon to this router see only UPGRADE (FIRMWARE) window. Then I installed many different versions of router firmware (succesfully installed) I have a same window. (Just again only firmware upgrade window is coming).

What is that problem? Anyone could help me?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
William Childs Mon, 12/28/2009 - 21:40


Could you perhaps give a screen shot of what you are seeing? I have never encountered this error, I think.


P.S. Please post the steps you took to get to the router's management page.

vreid47362 Tue, 12/29/2009 - 04:12

From my experience with the RV series routers, this page appears if the firmware becomes corrupted.  Try downloading the appropriate firmware, performing a hard reset of the device, reflashing the device, and then performing another hard reset of the device.  Make sure you are directly connected to the router with a physical ethernet cable (not connected wirelessly) when you re-upload the firmware.  If that doesn't work, I have noticed that the newest firmware download comes with a tftp utility.  You might see if you can tftp the firmware to the device.

Always remember with the RV units, for best firmware upddate performance and to ensure less buggy operation, that you should perform a factory reset both before and after installing the new firmware.  That is, backup your config file and manually reset the device using the reset button on the device (hold the reset button for about 30 seconds, let the device reboot, and then do the procedure again after the system comes back online to make sure the config file is wiped out), upload the firmware, perform the reset procedure again, and then, finally upload your backed up configuration file. 

mungun2009 Mon, 01/04/2010 - 18:55

Thank you for your help. I tried with your suggestion.

1. Hard reset. (Hold reset button 30 sec and there's no any light changes. After that reboot and again reset.)

2. Download official version from Cisco (ver 1.3.7) and install it to router by Web and tftp with ethernet cable.

3. After intsallation also reset router.

(There's just 2 light on green - System and DMZ. ALso connected lan light)

Still same problem. (Firmware upgrade window comes)

Any other idea?

vreid47362 Mon, 01/04/2010 - 19:41

After resetting the router to factory settings, try to connect to it via the tftp utility included with the most recent firmware and upload the new firmware that way.  Hopefully this will restore your router to a functional state.