1250 ios image Upgrade

Unanswered Question
Dec 29th, 2009

Hi All;

     I tried upgrdaing the ios image on a 1250 AP which we bought recently from 12.4-10b.JDA3 to 12.4-21a.JA1. It stopped working after the initial loading of the image and gives an error message :

           %DOT11-2-RADIO_FAILED: Interface Dot11Radio0, failed -  failed: firmware file not found -Traceback= 0x627C4 0x53BD90 0x808F4C 0x53F780 0x1BC2E0 0x1BC3A0 0x59F04 0x5A1F4 0x1CEDB0 0x1D0B34

           %DOT11-2-NO_FIRMWARE: Interface Dot11Radio1, no radio firmware file (flash:/8001.img) was found

    i tried rolling the image back to what it was before, Even then it is still showing the same errors and shutting the Radio Channels and it doesn't even open a GUI but lets me connect using telnet.

    It even gives this message :


           Warning:  the compile-time code checksum does not appear to be present.
           Radio 1 A600 8000 0 0 A8030000 30

           Unable to create Frequency bands, Channel / Max Power information not found
           Radio 1 A600 8000 0 0 B8030000 13

           Unable to create Frequency bands, Channel / Max Power information not found
           tx_paks 1293
           tx_paks 646

  Could someone help me with this please.

Thanks in advance.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Stephen Rodriguez Tue, 12/29/2009 - 06:30

First thing I would try, is to redownload the image and then upgrade again, from the CLI:

archive download-sw /f /o tftp://

Leo Laohoo Tue, 12/29/2009 - 15:46

How did you upgrade the IOS?  Did you use the "copy" command and copied only the BIN file?  The 12.4(21a), like the 12.4(10b), needs the entire TAR file to be extracted to the appliance because part of the package is a pair of radio module firmware.

Steve Rodriguez's post contain the exact command you need.  I recommend that you follow them.


This Discussion