CUPC instant messaging button greyed out

Unanswered Question
Dec 29th, 2009

CUPC 7.0

CUCM 7.1.3

CUPS 7.0.2

I can't seem to IM other CUPC users. When I click on the contact the instant message button is greyed out (image attached). When I right click the contact the Send Instant Message option is greyed out too with "Contact Cannot Receive Instant Messages". I'm not using LDAP so I had to manually add the contact. I confirmed that both of our clients are set to "Available" and we can call each other successfully via softphone. I also confirmed user's presence on CUPS (image attached).

How to CUPC users find each other for IM?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
aravindhanelango Tue, 12/29/2009 - 23:20

Hi All,

I am facing the same issue. I am not able to use the instant messaging option in CUPC.

As per the system troubleshoot window, my configuration in CUPS seems to be correct.

Do I need to integrate CUCM and CUPS with LDAP server to make it work?

Please advice

Thanks in advance.


Michael Murray Wed, 12/30/2009 - 10:10

The release notes say an LDAP server is required

"The following servers are required for Cisco Unified Personal Communicator operation:

Cisco Unified Communications Manager is installed in your network and configured to handle call processing and point to point video. It provides Cisco Unified IP Phone control through the Cisco Unified Communications Manager computer telephony interface (CTI). For Cisco Unified Communications Manager details, see the following URL:

Cisco Unified Presence is installed and is operational. This server provides the Cisco Unified Personal Communicator client configuration and presence information. For Cisco Unified Presence details, see the following URL:

LDAP server version 3"

That being said, I have softphone, meetingplace express integration, voicemail integration working without it. Still can't get IM or deskphone control working though.

Michael Murray Wed, 12/30/2009 - 12:18

I figured out what my problem was. The users I was adding were via the CUPC client ...Contacts > Add New Contact. I needed to go to https:///ccmuser/. Then User Options > Contacts > Add New. Once I did this I was able to see their status and I could IM them.

scott.hammond Wed, 01/20/2010 - 07:11

I have call control, but IM is greyed out.

Added a contact from the web portal and it doesnt show up in UPC. it wont let add one from UPC


This Discussion