2960 and Broadcom BCM5716C card problems

Unanswered Question
Dec 29th, 2009
User Badges:

I have a 2960G-48TC-L and connected server with BCM5716C card.  This server is runing Windows Server 2003 and serving DHCP.  When the server is started the Netlogon service reports an error indicating no domain servers are available, DHCP service fails also.  Netlogon starts however DHCP does not, but I can manually start it without a problem.  It's as though the network connection has not finished initializing for some reason, however in the event viewer I see the NIC has completed it's connection.  If I plug the server into another Linksys switch it is able to startup without these errors.


I'd like to connect this server to the gigabit switch.  Should I upgrade the IOS?  It is currently running 12.2(25)SEE1.  If so which IOS should I upgrade to and anyother concerns I should have?


Thanks for any help you can provide.

JH


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Tue, 12/29/2009 - 14:15
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

missionbell wrote:


I have a 2960G-48TC-L and connected server with BCM5716C card.  This server is runing Windows Server 2003 and serving DHCP.  When the server is started the Netlogon service reports an error indicating no domain servers are available, DHCP service fails also.  Netlogon starts however DHCP does not, but I can manually start it without a problem.  It's as though the network connection has not finished initializing for some reason, however in the event viewer I see the NIC has completed it's connection.  If I plug the server into another Linksys switch it is able to startup without these errors.


I'd like to connect this server to the gigabit switch.  Should I upgrade the IOS?  It is currently running 12.2(25)SEE1.  If so which IOS should I upgrade to and anyother concerns I should have?


Thanks for any help you can provide.

JH




James


Just a quick check - have you enabled "spanning-tree portfast" on the port the server is connected into ?


Jon

missionbell Tue, 12/29/2009 - 14:17
User Badges:

Not sure.  It's been a while since I've config thru the CLI.  I've recently only been using the GUI.  What is the easiest way to determine this?

Jon Marshall Tue, 12/29/2009 - 14:20
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

missionbell wrote:


Not sure.  It's been a while since I've config thru the CLI.  I've recently only been using the GUI.  What is the easiest way to determine this?


I'm not familiar with the GUI but easiest way for me would simply to do a "sh run" and check the config for the relevant interface.


Jon

missionbell Wed, 12/30/2009 - 09:05
User Badges:

Ok, thanks for your help.  I looked at the running-config and for that port I only see the description I gave t

he port in the GUI.  I don't see anything else associated with that port or other ports, exce

pt for the uplink.  It had some additional info.

missionbell Tue, 01/05/2010 - 10:32
User Badges:

Alright, it appears enabling the port as a desktop thru the GUI added the appropriate settings.  It added the enableportfast setting.  Upon booting the server no problems with connectivity.


Thanks for your help,

James

sachinraja Tue, 01/05/2010 - 11:06
User Badges:
  • Red, 2250 points or more

Hi James


Desktop smartmacros will include the "spanning-tree portfast" command specified by Jon.. Apart from this, it will include all best practice configs for a end user PC/Server connectivity like - bpduguard enable (to prevent spanning tree instabilities), port-security configs, switchport mode access, and so on.. Incase you need to apply these commands on CLI, you can use the following:


switch1 (config) # interface fast 0/1

switch1 (config-if)# macro apply cisco-desktop


and automatically you will have these commands applied:


switchport access vlan 

switchport mode access 
switchport port-security
switchport port-security maximum 1 
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity 
spanning-tree portfast (most important)
spanning-tree bpduguard enable (important)


Hope this helps.. all the best...


Raj

Actions

This Discussion