No Dial and NewCall Softkeys on CME - Speaker disabled

Unanswered Question
Dec 30th, 2009

Hi,

We have a C2821 (IOS 12.4(22)T4) and CME 7.0(1) and after an IOS upgrade (previous IOS was 12.4(15)T) we lost a feature on all 7911 phones.

When handset is onhook "Dial" and "NewCall" softkeys are not working while on the previous version we could start a call on monitor with handset onhook, and when the called party answered we picked up the phone.

When debugging an ephone, I got the following message:


Dec 30 12:08:39: ephone-9[8/7][SEP002584A373FA]:SK NEWCALL line 0 ref 0
Dec 30 12:08:39: ephone-9[8/7]:speaker is disable, can't make a new call unless headset or handset is offhook

Then I tried to force speaker to be enabled, by following another post in this forum, but softkeys are not working anyway:

telephony-service

  service phone disableSpeaker false
  cnf-file location flash:
  cnf-file perphone

ephone-template  1
  service phone disableSpeaker false

ephone  9
  ephone-template 1

Does anybody know how to enable speaker on 7911?

I would prefer not to downgrade to previous IOS version because we had some transfer/forwarding problems that we have solved now.

I attach shrun output.

Thanks.

Regards,

Isaac.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Loading.
Paolo Bevilacqua Wed, 12/30/2009 - 06:36

Apparently Cisco now thinks that is the correct behavoir and I don't see how one could change it.

Isaac Romero Wed, 12/30/2009 - 06:42

Hi,

Thanks for answering.

If so, do you know where I can find any document or information that explains that behavoir?

Regards,

Isaac.

J. S. Black Sat, 01/02/2010 - 09:23

What is your phone load version?

I have a 7911 with CME 7.1 (12.4(22)YB4) and SCCP11.8-5-3S as a phoneload and my softkeys are fine. Try defining softkeys in your ephone-template, for example:

ephone-template  2
softkeys hold  Resume Newcall Join Select
softkeys idle  Redial Newcall Cfwdall Dnd
softkeys seized  Redial Endcall
softkeys alerting  Callback Endcall
softkeys connected  Hold Endcall Park Trnsfer Confrn Flash ConfList Join Select

HTH

JS

Paolo Bevilacqua Sat, 01/02/2010 - 11:40

OP does not have a problem with the softkeys displayed.

Rather, an IOS bugs prevents him to initiate a call from on-hook.

Actions

This Discussion