ospf

Answered Question

hi! i've multiple vlan interface in my 6509 with one of the interface as


interface vlan 10

ip address 172.16. 8.2 255.255.255.128


and i;ve the router ospf configured as


network 172.16.8.2 0.0.0.0 area 0


My question is, what's the different if in the network command instead of using 0.0.0.0, i use 0.0.0.128?


thx.

Correct Answer by Ganesh Hariharan about 7 years 2 months ago

Hi,


To understand the interafaces addition in ospf configuration see the below explanation hope this helps out !!


1. The definition of only one interface
Definitions of only one interface are done with a wildcard-mask of 0.0.0.0 and the exact IP address of the given interface. This will match exact on that interface and nothing else.


2. The definition of mutiple but not all interfaces into one area
If you have to specify multiple interfaces and the IP concept has been done nicely, you might be able to summarize them all into one network statement. So if we have an address range like 116.1.16.0/21 which belongs to area N we can use network 116.1.16.0 0.0.7.255 area N to define them in one network statement. Every new interface on that router with an IP in that range will automatically be added into the OSPF process and added to that area.


3. The definition of all interfaces into one area
If you want to specify all interfaces on the router, the network statement network 0.0.0.0 255.255.255 area N will do the trick. Every new interface with an IP address on the router will automatically join OSPF and this area.



Regards

Ganesh.H

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (4 ratings)
Loading.
Reza Sharifi Wed, 12/30/2009 - 10:20
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hello,


network 172.16.8.2 0.0.0.0 area 0 This will enable OSPF only on this specific Interface


network 172.16.8.2 0.0.0.128 area 0 This will enable OSPF on all the interfaces whose ip address's fall in between 172.16.8.0-128


HTH

Reza

Jerry Ye Wed, 12/30/2009 - 10:25
User Badges:
  • Cisco Employee,

BTW, you cannot use mask of 0.0.0.128, you have to use 0.0.0.127.


To answer your question, 0.0.0.0 means only the interface 172.16.8.2 will be in area 0. If you are using 0.0.0.127 and you have the following interface configuration


interface lo0

ip address 172.16.8.10 255.255.255.255

interface lo1

ip address 172.16.8.11 255.255.255.255

!
router ospf 1

network 172.16.8.0 0.0.0.127 area 0


both interface lo0 and lo1 will be in OSPF area 0.


HTH,

jerry

Correct Answer
Ganesh Hariharan Wed, 12/30/2009 - 23:09
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Hi,


To understand the interafaces addition in ospf configuration see the below explanation hope this helps out !!


1. The definition of only one interface
Definitions of only one interface are done with a wildcard-mask of 0.0.0.0 and the exact IP address of the given interface. This will match exact on that interface and nothing else.


2. The definition of mutiple but not all interfaces into one area
If you have to specify multiple interfaces and the IP concept has been done nicely, you might be able to summarize them all into one network statement. So if we have an address range like 116.1.16.0/21 which belongs to area N we can use network 116.1.16.0 0.0.7.255 area N to define them in one network statement. Every new interface on that router with an IP in that range will automatically be added into the OSPF process and added to that area.


3. The definition of all interfaces into one area
If you want to specify all interfaces on the router, the network statement network 0.0.0.0 255.255.255 area N will do the trick. Every new interface with an IP address on the router will automatically join OSPF and this area.



Regards

Ganesh.H

Actions

This Discussion