RV042 is not able to establish a connection via cable modem

Unanswered Question
Dec 31st, 2009

I bought my RV042 about six month ago and used it only with one DSL provider using PPPoE, which worked flawlessly. Now I wanted to add a second different ISP which uses a cable modem.

Problem is that my RV042 never gets an IP address from the second ISP. I know that the cable modem works, because I tried my laptop and several other routers and all devices were able to obtain an IP address from the cable modem instantly. Only my RV042 shows

I tried following already:

- Clone Mac address from laptop, which worked with cable modem

- Only connect RV042 to ISP with cable modem

- Tried cable modem on WAN1 and WAN2

- Upgraded to latest available firmware.

Now I hit a wall. Does anyone have an idea what I am doing wrong? Any help is appreciated.

Thanks in advance,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Darren DeCroock Fri, 01/01/2010 - 07:23


From what you wrote, we can determine that both Router, and the WAN1 port are working on the router. (When connected to your DSL connection.)

Sounds like you have tried most of the logical steps to resolve this.  One thing that I would check, or try, is to make sure the network cable you are using to connect to the cable modem is working.  Maybe use the same cable that works with the DSL connection.  Also, if you have not reset the router back to factory defaults yet, I would also try that.

When you connect your computer directly to the cable modem, what is the IP address you are receiving on your computer.  If your cable modem is in "router" mode, and the IP address you are getting is in the same subnet as the default IP of the routers LAN (192.168.1.x).  That could cause a conflict and will not work.  It has been a while since I have see that, and don't remember if it does not give you an IP address, or if you are just not able to get to the internet.  If that is the case, I would suggest you have the modem put into "bridge" mode.



erikriedel Fri, 01/01/2010 - 16:47


Thanks a lot for your fast reply.

I forgot to mention in my first post that I tried different network cable as well and ruled them out already.

Also when I connect directly to the cable modem from my computer I don't get an 192.168.x.x address. Therefore there shouldn't be a conflict with the IP addresses.

However I followed you suggestion to reset the router to factory default. It had not the result I was looking for but now at least the system log does report more things.

In the System log I can see that the router asks for an IP and gets one:

System Log    DHCP lease info: ip[] mask[] gw[] host_name[UNAVAILABLED] domain_name[hsd1.co.comcast.net.] server_name[NOT GIVEN] dns_server1[] dns_server2[] ttl[64] mtu[576] renew_time[2010/1/1 18:03:29] expire_time[2010/1/1 18:09:21]

But still I see at WAN2 IP and there is no DNS server configured for WAN2.

Then I tried to use the values I saw in system log directly and setup WAN2 with "Static IP" and filled in the above values. Unfortunately I had no success either. WAN2 IP still shows But at least the DNS server for WAN2 were now configured as and

Now I stuck again.

Any other ideas? I really appreciate your help!



erikriedel Sat, 01/02/2010 - 22:13


It's working now. I don't know why exactly, but never mind. I did another Factory Reset without success. Then I switched from "Smart Link Backup" to "Load Balancing" and this did the trick. Now I can switch back and forth between "Smart Link Backup" and "Load Balancing" and always get my connection.

Thanks for your help. I really appreciate it.


Alejandro Gallego Mon, 01/04/2010 - 16:48

This one of those things that makes the router seem like it is not playing along. As you have discovered, when you are in "Smart Link" the main page of the router will show the "Back Up" WAN port with an IP of This is because if WAN 1 is the primary WAN 2 is in a down state, and it is reflected in the main page. I wish they had an icon or something showing that the backup link is connected and ready but not active. As you also noticed, even if you placed the static information in WAN 2 the main page still shows 0s. Again, because that link is technically down and it is normal behavior.

Glad you were able to resolve your problem and let us know if you run into any other snags.

Happy New Year!!!

erikriedel Tue, 01/05/2010 - 12:04


Happy New Year to you, too!

This is not entirely true. When I first had the problem I didn't get an IP address via cable modem even when the DSL modem was disconnected. And I tried the cable modem on WAN1 and WAN2.

Now after factory reset it shows both IP address in status "Load Balancing" _and_ in status "Smart Link Backup"