stdout.log file

Unanswered Question
Jan 1st, 2010

My stdout.log file grows quite quickly (it's currently around 45MB and growing), however, because it's constantly in use it doesn't get rotated by my logrot process (I'm using LM3.2 on Windows 2003 Server).

Is there a reason why this file grows quite quickly and is there a way to rotate it without stopping the Daemons, renaming the file, and then restarting the Daemons??

If not, is there a maximum file I can let this file grow to without having to clear it?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Joe Clarke Fri, 01/01/2010 - 19:59

What is being written to stdout.log?  This file will grow, but it shouldn't grow explosively.  It cannot, however, be rotated while Daemon Manage is running.  You will need to run logrot in offline mode to properly rotate the file.

BlueyVIII Thu, 01/07/2010 - 09:19

Thanks Joe...

I stopped the Daemons and rotated the file on 23/12/09. The file is currently in excess of 75MB!!!

I've attached the last couple of hundred lines of the log to see if that gives you any clues as I'm perplexed by this.

Could there be a debug mode enabled somewhere in LMS?? I'm not sure which debug mode would write to the stdout.log file.

As usual, any help greatfully received.

Joe Clarke Thu, 01/07/2010 - 09:33

All of this is normal.  It's not unusual for a server to see a stdout.log > 100 MB.  Seeing it greater than 1 GB would be bad.

BlueyVIII Thu, 01/07/2010 - 09:48

Thanks Joe..

I'll leave it as is and try not to worry about it..

I'll make a mental note to manually rotate it each time I stop/restart the daemons...

Joe Clarke Thu, 01/07/2010 - 09:51

You don't have to worry about that.  Every time Tomcat restarts it rotates the stdout.log.  That is, you should see stdout.log-OLD-X.  Each of these can simply be deleted, compressed, moved, etc.  They are not in use.  The stdout.log will always contain the messages from the current execution of Tomcat.


This Discussion