H.323 issue for outgoing call with CUCMBE 7.0

Unanswered Question
Jan 4th, 2010

Hi,


I have an issue with H.323 configuration CUCMBE 7.0. Inbound call is working but outgoing call to PSTN is always give a busy signal. i'm using FXO port for the call. Here is the config of the router:




MEDWAVE-GW01#sh run
Building configuration...

Current configuration : 4137 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MEDWAVE-GW01
!
boot-start-marker
boot-end-marker
!
logging buffered 4096
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool tels
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   option 150 ip 10.10.10.102
!
!
ip domain name medwaveoptique.com
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
l2tp tunnel receive-window 1024
!
!
voice-card 0
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
h323
  call start slow
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
vtp mode transparent
username mario privilege 15 secret 5 $1$lbDD$/eU.O0W7zNrJZMJSXVxG01
archive
log config
  hidekeys
!
!
!
!
!
!
!
bba-group pppoe global
!
!
interface Loopback0
ip address 10.1.9.1 255.255.255.255
h323-gateway voip bind srcaddr 10.1.9.1
!
interface FastEthernet0/0
description Lien Wan uplink vers internet
no ip address
ip virtual-reassembly
no ip mroute-cache
load-interval 30
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
load-interval 30
speed 100
full-duplex
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 172.18.5.1 255.255.255.0
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.200
encapsulation dot1Q 200
ip address 172.16.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
ip http server
no ip http secure-server
ip nat source static tcp 10.10.10.75 3389 interface FastEthernet0/1.100 3389
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static tcp 10.10.10.75 3389 interface Dialer1 3389
!
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 2 permit 172.16.3.0 0.0.0.255
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
access-list 102 permit ip 172.16.3.0 0.0.0.255 any
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
cptone CA
timing hookflash-out 50
caller-id enable
!
voice-port 0/0/1
connection plar opx 1008
caller-id enable
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.10.10.102
ccm-manager config
!
mgcp
mgcp call-agent 10.10.10.102 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface Loopback0
mgcp bind media source-interface Loopback0
!
mgcp profile default
!
!
!
dial-peer voice 999000 pots
service mgcpapp
port 0/0/0
!
dial-peer voice 201 pots
destination-pattern 9[2-9]..[2-9]......
port 0/0/1
forward-digits 10
!
dial-peer voice 2000 voip
destination-pattern 1...
session target ipv4:10.10.10.102
dtmf-relay h245-alphanumeric
codec g711ulaw
!
!
!
!
line con 0
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
session-timeout 60
exec-timeout 0 0
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

MEDWAVE-GW01#





DEBUG VOICE CCAPI INOUT of the outgoing call




MEDWAVE-GW01#
*Jan  4 17:56:24.331: //-1/80AE08053100/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=1008
   ----- ccCallInfo IE subfields -----
   cisco-ani=1008
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=1
   dest=5148172471
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=-1
   cisco-rdnplan=-1
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

*Jan  4 17:56:24.335: //-1/80AE08053100/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x667FC8F8, Call Info(
   Calling Number=1008,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=5148172471(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=2000, Progress Indication=NULL(0), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=219
*Jan  4 17:56:24.335: //-1/80AE08053100/CCAPI/ccCheckClipClir:
   In: Calling Number=1008(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
*Jan  4 17:56:24.335: //-1/80AE08053100/CCAPI/ccCheckClipClir:
   Out: Calling Number=1008(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
*Jan  4 17:56:24.335: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan  4 17:56:24.335: :cc_get_feature_vsa malloc success
*Jan  4 17:56:24.335: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan  4 17:56:24.335:  cc_get_feature_vsa count is 1
*Jan  4 17:56:24.335: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan  4 17:56:24.335: :FEATURE_VSA attributes are: feature_name:0,feature_time:1723255704,feature_id:219
*Jan  4 17:56:24.335: //219/80AE08053100/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=1008(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=5148172471(TON=Unknown, NPI=Unknown))
*Jan  4 17:56:24.335: //219/80AE08053100/CCAPI/cc_process_call_setup_ind:
   Event=0x66B7B650
*Jan  4 17:56:24.339: //219/80AE08053100/CCAPI/ccCallSetContext:
   Context=0x6712658C
*Jan  4 17:56:24.339: //219/80AE08053100/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 219 with tag 2000 to app "_ManagedAppProcess_Default"
*Jan  4 17:56:24.343: //219/80AE08053100/CCAPI/ccCallProceeding:
   Progress Indication=NULL(0)
*Jan  4 17:56:24.347: //219/80AE08053100/CCAPI/ccCallDisconnect:
   Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
*Jan  4 17:56:24.347: //219/80AE08053100/CCAPI/ccCallDisconnect:
   Cause Value=1, Call Entry(Responsed=TRUE, Cause Value=1)
*Jan  4 17:56:24.347: //219/80AE08053100/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
*Jan  4 17:56:24.351: //219/80AE08053100/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x667FC8F8, Tag=0x0, Call Id=219,
   Call Entry(Disconnect Cause=1, Voice Class Cause Code=0, Retry Count=0)
*Jan  4 17:56:24.351: //219/80AE08053100/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
*Jan  4 17:56:24.351: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan  4 17:56:24.351: :cc_free_feature_vsa freeing 66B6CB90
*Jan  4 17:56:24.351: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan  4 17:56:24.351:  vsacount in free is 0
MEDWAVE-GW01#ter
MEDWAVE-GW01#terminal no mon
MEDWAVE-GW01#terminal no monitor
MEDWAVE-GW01#



Anybody have an idea of the problem?





Tks.





Mario

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Mon, 01/04/2010 - 10:13

Cause value 1 means this:


Unallocated (unassigned) number. This cause indicates that the destination requested by the calling user cannot be reached because the number is unassigned. This number is not in the routing table, or it has no path across the ISDN network.


U sure that phone number works?


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

seguinmario Mon, 01/04/2010 - 10:30

Yes, this is a valid number. The call match the dial-peer 2000

to the CUCMBE but it's like the

route pattern doesn't work in CUCMBE. Here is my route pattern in CUCMBE:


9.[2-9]xx[2-9]xxxxxx




What do you think?

Actions

This Discussion