Upgrade from ACS v4.2 Evaluation to ACS v4.2 Licensed

Unanswered Question
Jan 5th, 2010


I'm trying to upgrade un existing (and unfortunately expired) ACS v4.2 Evaluation to an ACS v4.2 Licensed.

The existing ACS is installed on a Windows 2003 Server machine.

I have selected "Yes, keep the existing configuration" (when installing the new product on the same machine)

but I keep geting the error messages, presented below:


Setup failed to export your old user database.


Setup could not backup your old configuration.

Please check there is sufficient disk space and rerun Setup.


I have cleaned up the log files (as other people suggested in similar posts),

and I have 120GB free on the disk where the ACS installation resides.

Any hints on how to tackle with this problem?

Thanks for your help!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ansalaza Tue, 01/05/2010 - 10:37

Did you ever save a backup of the ACS Database (.dmp file)? Or can you still access the GUI and take a backup (System Configuration)?

You could install from scratch and then restore it into the new ACS.


silviugolo Mon, 02/01/2010 - 06:51


So here is how to solve the problem:

  1. Change the time on the system (to a moment in the past -> back one month).
  2. Back up the ACS v4.2 Evaluation on a .dmp file.
  3. Uninstall ACS v4.2 Eval.
  4. Clean up after uninstall using $ACS\ACS Utilities\Support\Clean\Clean.exe.
  5. Delete the content of the folder: \Documents and Settings\Administrator\Application Data\Microsoft\Crypto\RSA
  6. Install ACS v4.2 Full.
  7. Restore from the .dmp file.
  8. Check that the authentication works again.

I hope it will help someone, someday...


This Discussion

Related Content