E1 R2-digital configuration in Riyadh on H.323 Gateway

Unanswered Question
Jan 5th, 2010

Hi All,


Does anybody know where I can get a sample configuration for a voice gateway with E1 r2-digital connections to STC in Riyadh. I can receive calls from the PSTN but outgoing calls fail.

I have the following configuration on my Router.

version 12.4
service timestamps debug datetime
service timestamps log datetime
service password-encryption
!
hostname vsaruhvgw02
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
logging buffered 51200
enable secret 5 <removed>
!
no aaa new-model
clock timezone MST 3
network-clock-participate wic 0
dot11 syslog
!
!
ip cef
!
!
ip domain name voice.ds.corp
ip name-server 10.10.140.30
ip name-server 10.11.140.30
multilink bundle-name authenticated
!
!
voice-card 0
dspfarm
!
!
!
voice service voip
h323
!
!
!
!
!
!
!
!        
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-307895532
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-307895532
revocation-check none
rsakeypair TP-self-signed-307895532
!
!
crypto pki certificate chain TP-self-signed-307895532
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33303738 39353533 32301E17 0D303931 32323931 31313935
.

.

  FB9FEC73 75316441 33C46993 B6656DA0 CA67FA
      quit
!
!
username admin privilege 15 secret 5 <removed>
archive
log config
  hidekeys
!
!
controller E1 0/0/0
framing NO-CRC4
ds0-group 0 timeslots 1-10 type r2-digital r2-compelled ani
ds0-group 1 timeslots 11-15,17-30 type r2-digital r2-compelled ani
cas-custom 0
  country saudiarabia
  ani-digits min 4 max 20
cas-custom 1
  country saudiarabia use-defaults
!
controller E1 0/0/1
!
!
!
!
!
interface GigabitEthernet0/0
description LAN Connection
ip address 10.10.140.11 255.255.255.0
duplex auto
speed auto
h323-gateway voip bind srcaddr 10.10.140.11
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.10.140.254
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
control-plane
!
!
!
voice-port 0/0/0:0
cptone SA
!
voice-port 0/0/0:1
cptone SA
!        
!
no mgcp timer receive-rtcp
!
!
!
dial-peer voice 1 pots
destination-pattern .T
direct-inward-dial
port 0/0/0:1
!
dial-peer voice 1000 voip
preference 1
destination-pattern 68..
session target ipv4:10.10.140.1
dtmf-relay h245-alphanumeric
codec g711ulaw
!
!
gateway
timer receive-rtp 1200
!
!
line con 0
exec-timeout 120 0
login local
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp clock-period 17180112
ntp server 10.10.140.1
ntp server 10.10.140.2
!
end

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Loading.
maxschmid Tue, 01/05/2010 - 05:03

Here is the debug output.

*Jan  5 13:02:31: htsp_timer_stop3 htsp_setup_req
*Jan  5 13:02:32: htsp_process_event: [0/0/0:1(13), R2_Q421_IDLE, E_HTSP_SETUP_REQ]
*Jan  5 13:02:32: r2_q421_seize(0/0/0:1(13)) E_HTSP_SETUP_REQ DNIS=4791234 ANI=6969
*Jan  5 13:02:32: r2_q421_seize(0/0/0:1(13)) Tx SEIZUREvnm_dsp_set_sig_state:[R2 Q.421 0/0/0:1(13)] set signal state = 0x0
*Jan  5 13:02:32: htsp_timer - 5000 msec
*Jan  5 13:02:32: htsp_process_event: [0/0/0:1(13), R2_Q421_OG_SEIZE, E_DSP_SIG_1100]
*Jan  5 13:02:32: r2_q421_seize_ack(0/0/0:1(13)) Rx SEIZE ACK
*Jan  5 13:02:32: htsp_timer_stop
*Jan  5 13:02:32: r2_reg_start_dialing(0/0/0:1(13))
*Jan  5 13:02:32: r2_reg_process_event: [0/0/0:1(13), R2_REG_IDLE, E_R2_REG_START_DIAL(91)]
*Jan  5 13:02:32: r2_reg_start_dial_delay(0/0/0:1(13)) dialout delay 200
*Jan  5 13:02:32: r2_reg_timer(0/0/0:1(13)) 200 msec
*Jan  5 13:02:32: r2_reg_process_event: [0/0/0:1(13), R2_REG_IDLE, E_R2_REG_EVENT_TIMER(84)]
*Jan  5 13:02:32: r2_reg_start_dial(0/0/0:1(13))
*Jan  5 13:02:32: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_IDLE R2 Got Event R2_START
*Jan  5 13:02:32: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:32: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '4'
*Jan  5 13:02:32: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='5'
*Jan  5 13:02:32: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 5
*Jan  5 13:02:32: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:32: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:32: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:32: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '1'
*Jan  5 13:02:32: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='5'
*Jan  5 13:02:32: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 5
*Jan  5 13:02:32: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:32: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:32: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:32: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '6'
*Jan  5 13:02:32: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='5'
*Jan  5 13:02:32: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 5
*Jan  5 13:02:32: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:32: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:32: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:32: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '9'
*Jan  5 13:02:33: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='5'
*Jan  5 13:02:33: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 5
*Jan  5 13:02:33: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:33: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:33: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:33: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '6'
*Jan  5 13:02:33: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='5'
*Jan  5 13:02:33: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 5
*Jan  5 13:02:33: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:33: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:33: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:33: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '9'
*Jan  5 13:02:33: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='5'
*Jan  5 13:02:33: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 5
*Jan  5 13:02:33: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:33: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:33: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:33: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '*'
*Jan  5 13:02:33: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='1'
*Jan  5 13:02:33: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 1
*Jan  5 13:02:33: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:33: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:33: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:33: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '7'
*Jan  5 13:02:33: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='1'
*Jan  5 13:02:33: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 1
*Jan  5 13:02:33: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:34: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:34: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:34: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '9'
*Jan  5 13:02:34: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='1'
*Jan  5 13:02:34: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 1
*Jan  5 13:02:34: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:34: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:34: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:34: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '1'
*Jan  5 13:02:34: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='1'
*Jan  5 13:02:34: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 1
*Jan  5 13:02:34: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:34: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:34: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:34: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '2'
*Jan  5 13:02:34: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='1'
*Jan  5 13:02:34: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 1
*Jan  5 13:02:34: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:34: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:34: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:34: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '3'
*Jan  5 13:02:34: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='1'
*Jan  5 13:02:34: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 1
*Jan  5 13:02:34: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:34: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:34: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF
*Jan  5 13:02:34: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '4'
*Jan  5 13:02:36: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='3'
*Jan  5 13:02:36: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_A R2 Got Event 3
*Jan  5 13:02:36: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:37: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:37: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_B R2 Got Event R2_TONE_OFF
*Jan  5 13:02:37: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '1'
*Jan  5 13:02:37: htsp_digit_ready_up(0/0/0:1(13)): Rx digit='6'
*Jan  5 13:02:37: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_PROCESS_B R2 Got Event 6
*Jan  5 13:02:37: r2_reg_generate_digits(0/0/0:1(13)): Tx digit '#'
*Jan  5 13:02:37: htsp_digit_ready(0/0/0:1(13)): Rx digit='#'
*Jan  5 13:02:37: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_WAIT_IDLE R2 Got Event R2_TONE_OFF
*Jan  5 13:02:37: r2_reg_event_proc(0/0/0:1(13)) ADDR_INFO_COLLECTED (DNIS=4791234, ANI=6969)
*Jan  5 13:02:37: r2_reg_end_dial(0/0/0:1(13))
*Jan  5 13:02:37: r2_reg_process_event: [0/0/0:1(13), R2_REG_DIALING, E_R2_REG_ADDR_COLLECTED(87)]
*Jan  5 13:02:37: r2_reg_addr_collected(0/0/0:1(13))
*Jan  5 13:02:37: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_IDLE R2 Got Event R2_STOP
*Jan  5 13:02:37: r2_reg_timer(0/0/0:1(13)) 300 msec
*Jan  5 13:02:37: htsp_dialing_done(0/0/0:1(13))
*Jan  5 13:02:37: htsp_process_event: [0/0/0:1(13), R2_Q421_OG_SEIZE_ACK, E_DSP_DIALING_DONE]
*Jan  5 13:02:37: r2_q421_dial_done(0/0/0:1(13)) E_HTSP_RELEASE_REQ
*Jan  5 13:02:37: r2_reg_dial_done(0/0/0:1(13))
*Jan  5 13:02:37: r2_reg_process_event: [0/0/0:1(13), R2_REG_DIALING, E_R2_REG_EVENT_TIMER(84)]
*Jan  5 13:02:37: r2_reg_addr_collect_to(0/0/0:1(13))htsp_alert
*Jan  5 13:02:37: htsp_call_bridged invoked
*Jan  5 13:02:37: r2_reg_event_proc(0/0/0:1(13)) ALERTING RECEIVED
*Jan  5 13:02:37: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_IDLE R2 Got Event R2_ALERTING
*Jan  5 13:02:37: htsp_timer_stop3
*Jan  5 13:02:37: htsp_process_event: [0/0/0:1(13), R2_Q421_OG_SEIZE_ACK, E_HTSP_RELEASE_REQ]
*Jan  5 13:02:37: r2_q421_clr_fwd(0/0/0:1(13)) E_HTSP_RELEASE_REQ
*Jan  5 13:02:37: r2_reg_channel_disconnected(0/0/0:1(13))
*Jan  5 13:02:37: r2_q421_clr_fwd(0/0/0:1(13)) Tx CLEAR FWDvnm_dsp_set_sig_state:[R2 Q.421 0/0/0:1(13)] set signal state = 0x8
*Jan  5 13:02:37: htsp_timer - 1000 msec
*Jan  5 13:02:37: r2_reg_process_event: [0/0/0:1(13), R2_REG_WAIT_FOR_CONNECT, E_R2_REG_DISCONNECT(89)]
*Jan  5 13:02:37: r2_reg_disconnect_idle(0/0/0:1(13))
*Jan  5 13:02:37: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_IDLE R2 Got Event R2_STOP
*Jan  5 13:02:37: r2_reg_timer_stop(0/0/0:1(13))
*Jan  5 13:02:37: htsp_process_event: [0/0/0:1(13), R2_Q421_OG_CLR_FWD, E_DSP_SIG_1000]
*Jan  5 13:02:37: r2_q421_clr_fwd_idle(0/0/0:1(13)) Rx IDLE
*Jan  5 13:02:37: htsp_timer_stop
*Jan  5 13:02:37: r2_q421_clr_fwd_idle(0/0/0:1(13)) Tx IDLEvnm_dsp_set_sig_state:[R2 Q.421 0/0/0:1(13)] set signal state = 0x8
*Jan  5 13:02:37: r2_reg_channel_disconnected(0/0/0:1(13))
*Jan  5 13:02:37: r2_reg_process_event: [0/0/0:1(13), R2_REG_IDLE, E_R2_REG_DISCONNECT(89)]
*Jan  5 13:02:37: r2_reg_disconnect_idle(0/0/0:1(13))
*Jan  5 13:02:37: R2 Outgoing Voice(0/0): DSX (E1 0/0/0:12): STATE: R2_OUT_IDLE R2 Got Event R2_STOP
*Jan  5 13:02:37: r2_reg_timer_stop(0/0/0:1(13))debug vpm signal

maxschmid Tue, 01/05/2010 - 05:43

Yes, 4791234 is a local number in Riyadh and 6969 is my extention. The

technician from STC told me that we have to send only the extention as a

calling number.

Paolo Bevilacqua Tue, 01/05/2010 - 05:50

You are receiving a disconnect after alerting. At this point telco should monitor the call and tell you why they fail it.

maxschmid Tue, 01/05/2010 - 06:04

Thanks,

I will ask them again. The last information I received from the STC

technician was that my Router was diconnectiong the call?

Paolo Bevilacqua Tue, 01/05/2010 - 07:21

It may be the htsp 5 secs timer expiring - no valid reason for that.

Which exact IOS is this ?

maxschmid Tue, 01/05/2010 - 07:23

Cisco IOS Software, 2800 Software (C2800NM-SPSERVICESK9-M), Version

12.4(15)T10, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Mon 14-Sep-09 14:01 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T11, RELEASE SOFTWARE (fc1)

vsaruhvgw02 uptime is 6 days, 6 hours, 32 minutes

System returned to ROM by power-on

System restarted at 11:49:45 MST Wed Dec 30 2009

System image file is "flash:c2800nm-spservicesk9-mz.124-15.T10.bin"

maxschmid Tue, 01/05/2010 - 10:29

Unfortunately not

I tried c2800nm-spservicesk9-mz.124-24.T2.bin but no change.

maxschmid Wed, 02/03/2010 - 02:42

Thanks to p.bevilacqua for the assistance.

The problem is solved! STC Does not offer PRI ISDN so I had the make R2 work.

On the gateway configuration the Tunneling Protocol was set to QSIG instead of none. When passing calls to the H.323 Gateway, the Calling Number has to be masked to the extention number and the 0 (PSTN Caccess code) prefix has to be removed. The rest uses a standard H.323 Gateway configuration. Below is the relevant working router configuration (If someone else should ever need this).

!
!!Cisco IOS Software, 2800 Software (C2800NM-SPSERVICESK9-M), Version 12.4(24)T2, RELEASE SOFTWARE (fc2) !
card type e1 0 0
clock timezone MST 3
network-clock-participate wic 0
!
voice call send-alert
!
voice service voip
qsig decode
fax protocol pass-through g711alaw
h323
  h225 timeout tcp call-idle value 2
  h225 timeout t302 1
  h225 timeout t304 1
  h225 timeout setup 1
  call start slow

controller E1 0/0/0
framing NO-CRC4
ds0-group 0 timeslots 1-10 type r2-digital r2-compelled ani

ds0-group 1 timeslots 11-15,17-31 type r2-digital r2-compelled ani

  cas-custom 0
  country saudiarabia
  ani-digits min 4 max 20
cas-custom 1
  country saudiarabia use-defaults
  disconnect-tone
!
interface GigabitEthernet0/0
description LAN Connection
ip address 10.10.140.10 255.255.255.0
duplex auto
speed auto
h323-gateway voip bind srcaddr 10.10.140.10 !
voice-port 0/0/0:0
cptone SA
!
voice-port 0/0/0:1
cptone SA
timeouts interdigit 2
timeouts call-disconnect 3
timeouts wait-release 2
!
!
!
!
!
dial-peer voice 1000 voip
destination-pattern 68..
session target ipv4:10.10.140.1
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 1 pots
preference 1
destination-pattern .T
direct-inward-dial
port 0/0/0:1
!

emadalsindi Sun, 01/16/2011 - 22:52

Hi,

I was wondering if you have faced a problem with call forwarding.

Im facing weird problem. the calls are perfectly working but when a user wants to diver/fowards his calls to his mobile, the calls will fail.

can you please check where i have gone wrong, thanks.

I have different config's from you, im thinking of changing  the E1R2 to your config.

card type e1 0 0

logging message-counter syslog

!

no aaa new-model

clock timezone KSA 3

network-clock-participate wic 0

!

--More--                           dot11 syslog

ip source-route

!

!

ip cef

ip dhcp excluded-address 172.17.3.1 172.17.3.2

!

ip dhcp pool IPPHONES

   network 172.17.3.0 255.255.255.0

   default-router 172.17.3.1

   option 150 ip 172.17.4.2

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

!

!

--More--                           !

!

!

!

!

!

!

voice translation-rule 10

rule 1 /^.*\(....\)/ /\1/

!

!

voice translation-profile CorpSTC

translate calling 10

!

!

voice-card 0

!

controller E1 0/0/0

framing NO-CRC4

ds0-group 1 timeslots 1-6 type r2-digital r2-semi-compelled ani

ds0-group 2 timeslots 17-23 type r2-digital r2-semi-compelled ani

cas-custom 1

  country saudiarabia use-defaults

cas-custom 2

  country saudiarabia use-defaults

!

ip ssh version 2

!

!

voice-port 0/0/0:1

translation-profile outgoing CorpSTC

!

voice-port 0/0/0:2

          translation-profile outgoing CorpSTC

!

voice-port 0/1/0

supervisory disconnect dualtone mid-call

no battery-reversal

cptone SA

timeouts call-disconnect 2

timeouts wait-release 2

connection plar opx 5678

caller-id enable

!

voice-port 0/1/1

supervisory disconnect dualtone mid-call

no battery-reversal

cptone SA

timeouts call-disconnect 2

timeouts wait-release 2

connection plar opx 5678

caller-id enable

!

ccm-manager fax protocol cisco

!

mgcp fax t38 ecm

!

dial-peer cor custom

name private

name none

!

!

dial-peer cor list calls-allowed-all

member private

!

dial-peer cor list calls-internal-only

member none

!

!

dial-peer voice 1 pots

corlist outgoing calls-allowed-all

destination-pattern 9.T

port 0/0/0:2

!

dial-peer voice 6000 voip

destination-pattern 6000

session protocol sipv2

session target ipv4:172.17.4.5

           dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 2 pots

corlist outgoing calls-allowed-all

incoming called-number 56..

direct-inward-dial

port 0/0/0:1

!

dial-peer voice 7000 voip

description AutoAttendant Prompt

destination-pattern 5678

b2bua

session protocol sipv2

session target ipv4:172.17.4.5

dtmf-relay sip-notify

codec g711ulaw

no vad

!

!

!

!

         telephony-service

no auto-reg-ephone

em logout 0:0 0:0 0:0

max-ephones 40

max-dn 40

ip source-address 172.17.4.2 port 2000

auto assign 1 to 22

timeouts interdigit 3

url services http://172.17.4.5/voiceview/common/login.do

url authentication http://172.17.4.5/voiceview/authentication/authenticate.do 

load 7906 SCCP11.8-3-3S

load 7910 P00403020214

load 7911 SCCP11.8-3-3S

load 7960-7940 P00308000500

load 7941 SCCP41.8-3-3S

load 7945 SCCP45.8-3-3S

load 7961 SCCP41.8-3-3S

load 7965 SCCP45.8-3-3S

time-zone 31

date-format dd-mm-yy

dialplan-pattern 1 21556.. extension-length 4 extension-pattern 56..

voicemail 6000

          max-conferences 8 gain -6

moh music-on-hold.au

dn-webedit

time-webedit

transfer-system full-consult

transfer-pattern .T

create cnf-files version-stamp 7960 Jan 12 2011 17:49:23

!

maxschmid Sun, 01/16/2011 - 23:26

I have the same problem but have had no time to fix it (Has a low priority). I suspect that the forwarding fails due to the fact that STC does not allow CLIP NO SCREENING functions and when forwarding the call, the caller ID is not within the valid number range allowed to place calls on the line. I can emagine setting up a dedicated call farward CSS whrere the calling number is replaced by a valid extension number instead.

emadalsindi Mon, 01/17/2011 - 00:08

Thanks for the reply.

I thought I had a unique case.

Im still confused on how to do what you have suggested, I realize through debugging exactly what you have explained, but unfortunately, Im not quite sure how to do a by-pass solution.

Thanks,

Emad

emadalsindi Mon, 01/17/2011 - 01:19

Hi,

I built on your comment and got it working to show as "main" number.. tricky, but works.

Thanks for your guidance.

Emad

Actions

This Discussion