Routing/Firewall/VPN Problems UC540 CCA 2.2(1)

Unanswered Question
Jan 5th, 2010
User Badges:

I'm having a bear getting the firewall configured right...There is very little control over the config.


Connection is DHCP (ISP provides a new IP address every 18 months or so but without DHCP request, no routing...)

DDNS works but address doesn't resolve properly when requests come from inside...


for example:


192.168.10.99 is nat'd to  mypublicaddress.dnsalias.net for svn access

Outside the office, mypublicaddress.dnsalias.net works fine but inside the office it does not.

This breaks the app because it sees mypublicaddress.dnsalias.net and 192.168.10.99 as different hosts


Likewise, I cannot configure or use the VPN on DDNS...worked fine on the RVL200 we replaced but once I turn on DHCP, the other settings are lost..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven Smith Tue, 01/05/2010 - 14:06
User Badges:
  • Gold, 750 points or more

On the local host issues with 192.168.10.99, what is the dns server?  Is it an outbound DNS server?  I believe you can hairpin the traffic on the UC540 so that the application only thinks it is using the WAN address.


What type of VPN are you using?  I don't believe EZVPN has a requirement of a static IP, but the SSL VPN does.

ambleside Tue, 01/05/2010 - 14:13
User Badges:

DNS server is google 8.8.8.8...How do I hairpin the traffic...that's exactly what I'm trying to do..


Yes, EZ VPN works ok...SSL VPN is required for the 525G phones....

ambleside Tue, 01/05/2010 - 14:36
User Badges:

There really aren't any rules to speak of..host ip, internal port, external port...that's it.

Actions

This Discussion