ISDN E1 issue on MGCP gateway: Message type not implemented

Unanswered Question
Jan 5th, 2010

Hi all NetPro-ers,

I am encountering a troublesome issue this week, where our MGCP gateway was working fine and all of a sudden, the incoming and outgoing calls stop working. When i do a debug ISDN Q931, and dial incoming to an IPT extension, i do not see anything from the telco at all. When i do an outgoing call to PSTN, i get a debug shown below. Cause i = 0x82E1 - Message type not implemented

The telco is certain it is not their line that is having the issue but the problem seem to resolve itself and comes back after a few days.

MGCP registration looks good. Call routing on the CSS all seems fine.
If we route it out of another ISDN E1, which integrates to a PABX, the calls worked fine.

Is there anything else i can do?
Router is a 3825 using IOS c3825-advipservicesk9-mz.124-15.T10.bin.
CUCM is 6.1(2). No clock slips on controller e1.


Outgoing call debug isdn q931.
Jan  6 09:44:51.947 VN: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0002
        Sending Complete
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech 
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98381
                Exclusive, Channel 1
        Display i = 'Test'
        Calling Party Number i = 0x0081, '38281000'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x80, '38232000'
                Plan:Unknown, Type:Unknown
Jan  6 09:44:52.383 VN: ISDN Se0/0/0:15 Q931: RX <- ALERTING pd = 8  callref = 0x8002
        Channel ID i = 0xA98381
                Exclusive, Channel 1
Jan  6 09:44:52.711 VN: ISDN Se0/0/0:15 Q931: RX <- BAD PACKET()
hcm235rl1#pd = 8  callref = 0x8002
        Progress Ind i = 0x8282 - Destination address is non-ISDN
Jan  6 09:44:52.711 VN: ISDN Se0/0/0:15 Q931: do_statistics: 0x08 message 0x00 not counted
Jan  6 09:44:52.799 VN: ISDN Se0/0/0:15 Q931: TX -> STATUS pd = 8  callref = 0x0002
        Cause i = 0x82E1 - Message type not implemented
        Call State i = 0x04
hcm235rl1#
Jan  6 09:44:54.295 VN: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x8002
        Date/Time i = 0x0A0106092C00
                Date (dd-mm-yr)   = 10-01-06
                Time (hr:mnt:sec) = 09:44:00

Appreciate any inputs/comments.

Cheers,
Eugene

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Lulzim Islami Tue, 09/14/2010 - 04:04

Dear Eugene,

I'm facing with a same issue with E1 on MGCP gateway. From the post i didn't saw any reply, did you where able to resolve the issue? If yes, can you please share the solution.

Thanks in advance.

Felipe Garrido Tue, 09/14/2010 - 05:17

Valdet,

The error is typically seen when there is a mismatch in the ISDN switchtype setting between the two endpoints. check with the PBX/telco and make sure both sides are set to the same switchtype.

Eugene Cheng Tue, 09/14/2010 - 18:33

Hi,

Yea, sorry I didn't update.

I was able to resolve the issue.

In the MGCP interface setting, the Call routing information - Outbound Calls,

-Called party IE number type unknown
- Called party IE number type unknown

- Called Numbering Plan

- Callikng Numbering Plan

These were all set to Cisco CallManager.

When I changed them all to Unknown.

The problem was resolved.

Maybe you do not need to set all four, but as I didn't have much time to test. I just set them all.

Hope it helps.

Cheers,
Eugene

Lulzim Islami Wed, 09/15/2010 - 00:45

Hi,


I did the changes described bellow but issue remains the same. I also checked with my Telco provider and we have isdn switch type to primary-net5 configured on both sides.

I'm receiving only the Cause i = 0x82E1 - Message type not implemented only, and this is happening when I'm making calls from my site, if I receive calls from PSTN I won't get this cause code.

Thanks,

andrea_spo Tue, 09/06/2011 - 07:24

Hello,

Same here...does anybody found where the problem is?

Thanks

Lulzim Islami Tue, 09/06/2011 - 23:29

Andrea,

Your telco provider should fix this solution, they are not sending these information to you. I tried to switch it to H323 but the issue still remains. So I wull sugest you to contact your telco provider.

Actions

This Discussion