How to force client to connect to closest AP

Unanswered Question
Jan 6th, 2010
User Badges:

Hello

I have a question as in topic. We have few AP managed by WCS->WLC, I have a problem with two clients (terminals on hall), without any reason (I think) they can disconnect form the closest AP and reconnect to farther AP. I change the power on AP to lower but even then client connect to AP with RSSI  -82!! Is there any way to force client to connect specific AP from WCS? (maybe block client for specific AP?). Client network card support CCXv1 (ralink)

Second question: what in WCS -> 802.11b/g/n     " Transmitted Power Threshold" parameter mean?


Thanks for any help and sorry for my poor english


Best regards

Pawel

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Wed, 01/06/2010 - 13:41
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Is the client's wireless NIC drivers up to date?

kirchhoffpolska Thu, 01/07/2010 - 08:00
User Badges:

Yes, But then it starts to work even worse, so that's way I want to setup this via AP (WCS)

Ryan Curry Thu, 01/07/2010 - 10:04
User Badges:

Are all of your client devices running only G or do you have to maintain B data rates as well?


If you are completely G, then you can go into the 802.11b/g/n parameters of the controller and set the high and low manditory speeds to a higher setting, that way when it tries to connect to that AP it won't be able to achieve those speeds and won't connect.  Don't set it too high, maybe 9 (low) and 18 (high).  What is the traffic like on the AP that the device is close to?  Could it be that AP is overloaded and the device is connecting to a weaker signal to get a better data rate?

kirchhoffpolska Sun, 01/10/2010 - 23:14
User Badges:

All clients use G, If I can believe WCS raports AP use only 10 % of bandwidth , 6 clients are maximally connected to one AP. Proably this will be the best solution to change the lowest mandatory speed. One thing is interesting, why client change AP? On WCS in roam reason field I have "New association detected". Clients work in difficult enviroment, welding machine which generate high electromagnetic field, lots of metal cointainers which reflect the signal..

Thanks for help

Ryan Curry Mon, 01/11/2010 - 08:14
User Badges:

Keep in mind that the roaming algorithm is not set by the APs but instead is set by the client.  I know with our Intel drivers we can set the cards to be more or less agressive when roaming.  It's tough to say where the threshold is that is going to keep those clients close to you without any type of air sniffer (Air Magnet for example) so I would say you're probably best to move the manditory speeds to help.

J_Vansen_S Wed, 02/10/2010 - 00:31
User Badges:

I am too experiencing this exact problem on my customer's network.

Clients are not connected to AP closest to it.

The nearest AP i believe are not congested because only 2-3 users are connected to it.

Please advice on how we can force it to connect to cloest AP.

Actions

This Discussion