CME: Block Call Forwarding On Phones

Answered Question
Jan 6th, 2010
User Badges:

Hello,


It has been requested by the business unit to address an issue with employees forwarding their office phones outside the business. No phones are to be forwarded to outside lines at any time.


In Call Manager it's simple. We select the option to disallow CFA to outside lines.


Unfortunately in CME, I don't see an option on the GUI.


I'll assume the change can only be made on the router. In this case I'd like to request assistance as to what the command line should be in order to block our subscribers from forwarding to outside lines.


Thank you!

Correct Answer by Rob Huffman about 7 years 5 months ago

Hi Ross,


You are most welcome my friend


Yes, you are most correct.


The following example restricts the number of digits that a phone user can enter using the CfwdALL soft key to four. In this example, extensions in the phone user's Cisco Unified CME system have four digits, so that means the user can use the IP phone to forward all calls to any extension in the system, but not to any number outside the system.

Router(config)# ephone-dn 1

Router(config-ephone-dn)# number 5001

Router(config-ephone-dn)# call-forward max-length 4


The following example uses an ephone-dn-template to restrict the number of digits that a phone user can enter using the CfwdALL soft key to four.

Router(config)# ephone-dn-template 4

Router(config-ephone-dn-template)# call-forward max-length 4

Router(config-ephone-dn-template)# exit

Router(config)# ephone-dn 1

Router(config-ephone-dn)# number 5001

Router(config-ephone-dn)# ephone-dn-template 4



Cheers!

Rob

Correct Answer by Rob Huffman about 7 years 5 months ago

Hi Ross,


Here is one such method;


call-forward max-length


To restrict the number of digits that can be entered using the CfwdALL soft key on an IP phone, use the call-forward max-length command in ephone-dn or ephone-dn-template configuration mode. To remove a restriction on the number of digits that can be entered, use the no form of this command.


call-forward max-length length


no call-forward max-length


Syntax Description

length

Number of digits that can be entered using the CfwdAll soft key on an IP phone.



This command can be used to prevent a phone user from using the CfwdALL soft key on an IP phone to forward calls to numbers that will incur toll charges when they receive forwarded calls.


If the length argument is set to 0, the CfwdALL soft key is completely disabled. If the ephone-dn associated with the first line button has an active call forward number when this command is used to set the length argument to 0, the CfwdALL soft key will be disabled after the next phone restart



http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/command/reference/cme_c1ht.html#wp1013281



Hope this helps!

Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Rob Huffman Wed, 01/06/2010 - 08:43
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Ross,


Here is one such method;


call-forward max-length


To restrict the number of digits that can be entered using the CfwdALL soft key on an IP phone, use the call-forward max-length command in ephone-dn or ephone-dn-template configuration mode. To remove a restriction on the number of digits that can be entered, use the no form of this command.


call-forward max-length length


no call-forward max-length


Syntax Description

length

Number of digits that can be entered using the CfwdAll soft key on an IP phone.



This command can be used to prevent a phone user from using the CfwdALL soft key on an IP phone to forward calls to numbers that will incur toll charges when they receive forwarded calls.


If the length argument is set to 0, the CfwdALL soft key is completely disabled. If the ephone-dn associated with the first line button has an active call forward number when this command is used to set the length argument to 0, the CfwdALL soft key will be disabled after the next phone restart



http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/command/reference/cme_c1ht.html#wp1013281



Hope this helps!

Rob

rossporubski Wed, 01/06/2010 - 08:48
User Badges:

Hello Rob,


Thank you for taking the time to review my query.


We still must have the subscribers be able to forward to voicemail from their phone. So if I want to block anything over 4 characters, would this be the syntax:


call-forward max-length 4


Thank you

Correct Answer
Rob Huffman Wed, 01/06/2010 - 09:07
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Ross,


You are most welcome my friend


Yes, you are most correct.


The following example restricts the number of digits that a phone user can enter using the CfwdALL soft key to four. In this example, extensions in the phone user's Cisco Unified CME system have four digits, so that means the user can use the IP phone to forward all calls to any extension in the system, but not to any number outside the system.

Router(config)# ephone-dn 1

Router(config-ephone-dn)# number 5001

Router(config-ephone-dn)# call-forward max-length 4


The following example uses an ephone-dn-template to restrict the number of digits that a phone user can enter using the CfwdALL soft key to four.

Router(config)# ephone-dn-template 4

Router(config-ephone-dn-template)# call-forward max-length 4

Router(config-ephone-dn-template)# exit

Router(config)# ephone-dn 1

Router(config-ephone-dn)# number 5001

Router(config-ephone-dn)# ephone-dn-template 4



Cheers!

Rob

p.racho Fri, 11/06/2015 - 01:08
User Badges:

Hi Rob,

How to restrict call forwarding for a SIP phone registered to CME?


Thanks,

Perci


ilana_ilana Tue, 11/10/2015 - 00:05
User Badges:

Hello,

Looking for solution to restrict call forwarding on SIP Phones registered with CME 10.0.

Please share.

Vivek Batra Tue, 11/10/2015 - 00:42
User Badges:
  • Red, 2250 points or more
  • Community Spotlight Award,

    Member's Choice, November 2015

  • Cisco Designated VIP,

    2016 IP Telephony

Just remove call forward all key from softkey template. Doing so, user won't be able to set call forward.

- Vivek

ilana_ilana Tue, 11/10/2015 - 01:04
User Badges:
Requirement is to block call forward all only PSTN numbers. Call forward all to local extensions should work.
rossporubski Mon, 01/25/2010 - 07:16
User Badges:

Hi Rob, I tried this both ways. I tried the first option:


#Router(config)# ephone-dn 59

#

Router(config-ephone-dn)# number 4664

#

Router(config-ephone-dn)# call-forward max-length 6

#

Router(config-ephone-dn)#cntrl z


Router# wr mem



Then I test the line and it still forwards. Did I miss something?


Thank you

Rob Huffman Mon, 01/25/2010 - 08:25
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Ross,


That's strange....did you reset/restart the phone after the config change?

I noticied in your example, that you chose;


call-forward max-length 6


In our discussion I thought you were going to use;


call-forward max-length 4



Just checking


Cheers!

Rob

rossporubski Mon, 01/25/2010 - 12:05
User Badges:

Well Rob, (not that I doubted you) you were 100% correct. I went to my eng dept and ran it by them. They ran the same commands and it worked fine. Weird.


Thanks for your help!

rossporubski Mon, 01/25/2010 - 08:32
User Badges:

Hi Rob,


Our engineering dept. devised a plan to use a series of 2 digit prefixes for all our facilities to append to their 4 digit extension. This enables the business to interconnect all of the facilities over MPLS and 6 digit dial between eachother.


I did reset the phone after running the command on the router but no luck. I'm still able to forward to 7 digit local, and any variation long distance, toll and international.


Thank you

Actions

This Discussion