Changing nic settings on Pres Server

Answered Question
Jan 6th, 2010

Hello I am getting a CDP duplex miss match error on my core switch from one of my UC Presentation servers and I would like to enable auto negotiation.  The current settings of the server is 100 full but the switch is set to auto ( I would like to get a gig). From a ssh shell I can issue the command:

set network nic eth0 auto en

I get a warning that I will lose connectivity but it still comes back at auto disabled.

Am I missing a parameter?

Thank you,

John

I have this problem too.
0 votes
Correct Answer by Tommer Catlin about 6 years 11 months ago

here is the bug:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsy08872&from=summary

as long as you set both to match, you should be fine.  Just turn off CDP for that port and ignore the warnings.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.7 (3 ratings)
Loading.
htluo Thu, 01/07/2010 - 05:54

The "duplex mismatch" is a false alarm.  You'll find it on certain version of CUCM, CUPS, CER.  Just turn off CDP on that specific port.

Michael

http://htluo.blogspot.com

Michael Murray Thu, 01/07/2010 - 07:44

John,

Your set network nic command looks correct. Not sure why it's not taking.

If your CUP server is set to 100/full and the switch is auto/auto then you'll get a duplex mismatch. Autonegotiation is a passive process and while passively detecting speed is easy, detecting duplex is not. So the auto side will configure to 100/half (half duplex being the default), thus your mismatch.

You'll need to either set both sides to 100/full or auto/auto. I would recommend hard coding both sides to 100/full instead of auto/auto.

-mike

John Palmason Thu, 01/07/2010 - 09:51

Thank you, I know this sounds like a basic problem but I wasn't getting the expected behavior.  I have solved this problem and CDP is now happy on the core switch.  Thank you all for taking the time to respond.

John

Actions

This Discussion