3750 VLAN for Voice

Unanswered Question
Jan 6th, 2010

I have a 3750 in a stack and some trunks to 3560s.  We are implementing a new phone system with non-cisco phones.  The phones we are using are aastra's.  Our switches have the auto qos turn on for the trunks. The intention is to plug the existing desktop computers in to the port on the phones.  I am looking for simple config so that we have a separate vlan for our voice.  Secondly, since auto qos is already enabled I -assume- for a basic configuration I can just leave that as is.

I have read about the cisco voice vlan and am wondering if in order to create a vlan for this new phone system I just need to for example add "switchport accesss voice vlan 200" to each port?

Our typical desktop port looks like this:

interface FastEthernet1/0/5
switchport access vlan 10
switchport mode access
switchport port-security maximum 3
switchport port-security
switchport port-security aging time 30
switchport port-security aging type inactivity
storm-control broadcast level 30.00 10.00
storm-control multicast level 30.00 10.00
storm-control unicast level 60.00 10.00
spanning-tree portfast


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Reza Sharifi Wed, 01/06/2010 - 18:02

Hi Bart,

Since you are adding a second vlan, you would need to trunk the ports and use dot1q for encapsulation:

Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport trunk native vlan id
!--- This is the VLAN with untagged frames used by the PC.

Switch(config-if)#switchport mode trunk
!--- This enables trunking on the port for two VLANs, data and voice.
Switch(config-if)#switchport voice vlan id
Switch(config-if)#spanning-tree portfast trunk



Giuseppe Larosa Thu, 01/07/2010 - 02:19

Hello Bart,

with Cisco IP phones it is actually  enough to add

switchport voice vlan y

to the port to create a so called mini trunk.

I'm not sure that the same configuration is fine with non Cisco devices.

In that case, the configuration suggested by Reza is good I would just add

switchport trunk allowed vlan x,y

where x is the data vlan and y is the voice vlan.

I would suggest to test using two phones the two types of configuration: look for correct registration of phones, capability to call / receive calls and also check qos statistics on the port to be sure traffic is treated correctly.

Hope to help


urbanrunner2010 Thu, 01/07/2010 - 10:16

So is it correct to say that for non-cisco phones you should not use the Cisco Voice Vlan?

Also, is the method described above what most people use (anyone else out there agree / disagree with what's already been said) ? 

Thanks again!

urbanrunner2010 Thu, 01/07/2010 - 17:02


I had previously read the discussion in the link you posted.  I just now read it again.  I am still confused as to what configs will work with non-cisco phones and why.  Perhaps this is a case of there being multiple ways to accomplish the same thing.?

For example near the bottom of the post I see this:

Alot of talk here about CDP, which is all well and good, but what it the IP Phone is a non Cisco phone?

I believe the best config is;

switchport mode access
switchport access vlan 50
switchport voice vlan 100

This way the Voice and Data VLANs are hard coded.  No CDP necessary so this works with non cisco phones.

     Comment by Luca — October 6, 2009 @

Reza Sharifi Thu, 01/07/2010 - 18:05


The configuration I provided you should work just fine. If you have your Call Manager, Exchange Server, etc... set up you can simply plug a couple of phones to your switch and test it.


Giuseppe Larosa Fri, 01/08/2010 - 00:21

Hello Bart,

CDP is cisco proprietary and it is a component of the mini trunk, for this reason the configuration of an explicit trunk when non Cisco IP phones are involved is the likely configuration.

As suggested by Reza and I the best thing to do is to test using two phones you will find out the working configuration.

Hope to help


urbanrunner2010 Sat, 01/09/2010 - 06:41

Good info.  Thanks.  The use of the explicit trunk with a non-cisco phone makes more sense now.  I'll test it out and report back.  I'm going to start another thread regarding auto QOS.

bthielen3 Mon, 01/11/2010 - 18:31

After reviewing this for use with NON-Cisco phones I took out the line about the voice vlan.  This seems to me to be correct for the port for a phone with a PC plugged in to it(phone with builitin switch), do you agree?


switchport trunk encapsulation dot1q
switchport trunk native vlan 3
switchport mode trunk
spanning-tree portfast trunk
switchport trunk allowed vlan 3,92


This Discussion

Related Content