Upgrade IOS Problem for C2960

Unanswered Question
Jan 6th, 2010

There are three 2960 took this problem:

WS-C2960-48TC-S 12.2(25)  2

WS-C2960-24TC-S 12.2(25)  1

upgrade from 12.2(25) to 12.2(50)

upload the IOS by TFTP to flash:

boot system flash:****

wr

reload

Failed to get configuration
Invalid parameter block -- no mac address available.
Xmodem file system is available.

The system has been interrupted, or encountered an error
while non-volatile environment variables were being read
out of flash.  If you interrupted the system, it would be
a good idea to issue the reset command now, or the
environment variables may be lost.  The following
commands will initialize the flash filesystem, and finish
loading the operating system software:

    flash_init
    boot


switch: flash_init
Initializing Flash...
...no flash filesystems found.

than i try to type some command:

switch: dir

List of filesystems currently registered:

xmodem[0]: (read-only)
null[1]: (read-write)


switch: flash_init
Initializing Flash...
...no flash filesystems found.

switch:

i try to sent original IOS to null: filesystem and successed, but after reboot nothing happen...

is this a hardware problem? just like flash card get crashed....

any suggestion?

thanks and Best REgards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
sam_chang88 Wed, 01/06/2010 - 23:00

switch: flash_init
Initializing Flash...
...no flash filesystems found.

no flash:

HOW to do the next?

I say the 2960, not 2900xl

Leo Laohoo Thu, 01/07/2010 - 13:15

Type "i", press enter and try again.  Do you get any output when you type "?"?

PRAVEEN KUMAR GVK Sun, 08/21/2011 - 18:25

hi

me to same problem i am using 2960 l2 switch

how can i upgrade

                                                thanks

Reza Sharifi Sun, 08/21/2011 - 18:48

Parveen,

Are you trying to upgrade your IOS or your current IOS does not load?

sam_chang88 Mon, 08/22/2011 - 19:46

only you can do that buy the service of smartnet for the 2960, and change the new one, back the old to factory.

PRAVEEN KUMAR GVK Thu, 05/17/2012 - 03:09

hi

sam there is no ios in ur switch. u have to upload usig xodem in hypererminal.

i did the same it working fine.

regards

praveen kumar gvk.

Actions

This Discussion

Related Content